aboutsummaryrefslogtreecommitdiff
path: root/net/packter-agent
diff options
context:
space:
mode:
Diffstat (limited to 'net/packter-agent')
-rw-r--r--net/packter-agent/Makefile64
-rw-r--r--net/packter-agent/distinfo2
-rw-r--r--net/packter-agent/pkg-descr7
-rw-r--r--net/packter-agent/pkg-plist16
4 files changed, 89 insertions, 0 deletions
diff --git a/net/packter-agent/Makefile b/net/packter-agent/Makefile
new file mode 100644
index 000000000000..18411ff46fab
--- /dev/null
+++ b/net/packter-agent/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: packter-agent
+# Date created: 2012-09-05
+# Whom: Masaki TAGAWA <masaki@club.kyutech.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= packter-agent
+PORTVERSION= 2.5
+CATEGORIES= net
+MASTER_SITES= http://www.packter.net/
+DISTNAME= PackterAgent-${PORTVERSION}
+
+MAINTAINER= masaki@club.kyutech.ac.jp
+COMMENT= An agent of the tool for graphical Internet traffic visualization
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+GNU_CONFIGURE= yes
+USE_GNOME= glib20
+
+PORTDOCS= AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS README
+
+OPTIONS_DEFINE= IPV6 PACKTERTC
+PACKTERTC_DESC= Install Packter TC
+OPTIONS_DEFAULT= IPV6
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MIPV6}
+CONFIGURE_ARGS+= --enable-ipv6
+.else
+CONFIGURE_ARGS+= --disable-ipv6
+.endif
+
+.if ${PORT_OPTIONS:MPACKTERTC}
+USE_PERL5_RUN= yes
+RUN_DEPENDS+= p5-XML-Pastor>=0:${PORTSDIR}/devel/p5-XML-Pastor
+PLIST_SUB+= PACKTERTC=""
+.else
+PLIST_SUB+= PACKTERTC="@comment "
+.endif
+
+post-install:
+.if ${PORT_OPTIONS:MPACKTERTC}
+ @${MKDIR} ${DATADIR}
+ ${CP} -pr ${WRKSRC}/packter_tc ${DATADIR}/
+.endif
+
+.for f in packter.conf
+ @if [ ! -f ${PREFIX}/etc/${f} ]; then \
+ ${CP} -p ${PREFIX}/etc/${f}.sample ${PREFIX}/etc/${f} ; \
+ fi
+.endfor
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/packter-agent/distinfo b/net/packter-agent/distinfo
new file mode 100644
index 000000000000..c2a705100d82
--- /dev/null
+++ b/net/packter-agent/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PackterAgent-2.5.tar.gz) = 24c01c0fc2c5254768e53845bccd63ba6fc26e63e5ff4bd890c3dda102555882
+SIZE (PackterAgent-2.5.tar.gz) = 257778
diff --git a/net/packter-agent/pkg-descr b/net/packter-agent/pkg-descr
new file mode 100644
index 000000000000..15fd13691a6f
--- /dev/null
+++ b/net/packter-agent/pkg-descr
@@ -0,0 +1,7 @@
+PACKTER is a free and opensource software for visualization of Internet
+traffic.
+PACKTER systems are composed of Packter Viewer and Packter Agent.
+Packter Viewer draws a flying object by receiving Packter Protocol from
+Packter Agent.
+
+WWW: http://www.packter.net
diff --git a/net/packter-agent/pkg-plist b/net/packter-agent/pkg-plist
new file mode 100644
index 000000000000..13b1164b1484
--- /dev/null
+++ b/net/packter-agent/pkg-plist
@@ -0,0 +1,16 @@
+bin/pt_agent
+bin/pt_sflow
+bin/pt_netflow
+bin/pt_thmon
+@unexec if cmp -s %D/etc/packter.conf.sample %D/etc/packter.conf; then rm -f %D/etc/packter.conf; fi
+etc/packter.conf.sample
+@exec [ -f %D/etc/packter.conf ] || cp -p %D/etc/packter.conf.sample %D/etc/packter.conf
+%%PACKTERTC%%%%DATADIR%%/packter_tc/IPTB.pm
+%%PACKTERTC%%%%DATADIR%%/packter_tc/InterTrackMessage.xsd
+%%PACKTERTC%%%%DATADIR%%/packter_tc/btm.conf
+%%PACKTERTC%%%%DATADIR%%/packter_tc/dp.conf
+%%PACKTERTC%%%%DATADIR%%/packter_tc/itm.conf
+%%PACKTERTC%%%%DATADIR%%/packter_tc/packter_tc.pl
+%%PACKTERTC%%%%DATADIR%%/packter_tc/xsd.pl
+@dirrm %%DATADIR%%/packter_tc
+@dirrm %%DATADIR%%