aboutsummaryrefslogtreecommitdiff
path: root/net/pear-Net_NNTP/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/pear-Net_NNTP/Makefile')
-rw-r--r--net/pear-Net_NNTP/Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/net/pear-Net_NNTP/Makefile b/net/pear-Net_NNTP/Makefile
index ad8347912e9a..93562c5b07fd 100644
--- a/net/pear-Net_NNTP/Makefile
+++ b/net/pear-Net_NNTP/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Net_NNTP
-PORTVERSION= 0.10.0
+PORTVERSION= 0.10.1
CATEGORIES= net news www pear
MAINTAINER= sheepkiller@cultdeadsheep.org
@@ -18,7 +18,14 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
-LIB_FILES= NNTP/Protocol.php NNTP/Header.php NNTP/Message.php
+LIB_FILES= NNTP/Realtime.php NNTP/Protocol.php NNTP/Header.php NNTP/Message.php
+PORTDOCS= README
+
+.if defined(NOPORTEXAMPLES)
+PLIST_SUB+= PORTEXAMPLES="@comment "
+.else
+PLIST_SUB+= PORTEXAMPLES=""
+.endif
do-install:
@${MKDIR} ${PEARDIR}/Net/NNTP
@@ -27,9 +34,13 @@ do-install:
@${CP} -p ${WRKSRC}/${FILE} ${PEARDIR}/Net/NNTP
.endfor
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Net
-.if !(NOPORTDOCS)
+.if !(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/examples/news.php.net/* ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/examples/news.php.net/*.php ${EXAMPLESDIR}
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/examples/news.php.net/${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>