aboutsummaryrefslogtreecommitdiff
path: root/net/pear-Net_NNTP/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/pear-Net_NNTP/Makefile')
-rw-r--r--net/pear-Net_NNTP/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/net/pear-Net_NNTP/Makefile b/net/pear-Net_NNTP/Makefile
index d415f3e39062..c8e42b7b3e65 100644
--- a/net/pear-Net_NNTP/Makefile
+++ b/net/pear-Net_NNTP/Makefile
@@ -6,23 +6,26 @@
#
PORTNAME= Net_NNTP
-PORTVERSION= 0.2
+PORTVERSION= 0.9.2
CATEGORIES= net news www
MAINTAINER= sheepkiller@cultdeadsheep.org
COMMENT= PEAR class that provides an implementation of the NNTP protocol
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
RUN_DEPENDS= ${BUILD_DEPENDS}
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+LIB_FILES= NNTP/Protocol.php NNTP/Header.php NNTP/Message.php
+
do-install:
-.if !exists(${PEARDIR}/Net)
- @${MKDIR} ${PEARDIR}/Net
-.endif
+ @${MKDIR} ${PEARDIR}/Net/NNTP
@${CP} -p ${WRKSRC}/NNTP.php ${PEARDIR}/Net
+.for FILE in ${LIB_FILES}
+ @${CP} -p ${WRKSRC}/${FILE} ${PEARDIR}/Net/NNTP
+.endfor
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Net
.include <bsd.port.post.mk>