aboutsummaryrefslogtreecommitdiff
path: root/net/pear-Net_Socket/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/pear-Net_Socket/Makefile')
-rw-r--r--net/pear-Net_Socket/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/net/pear-Net_Socket/Makefile b/net/pear-Net_Socket/Makefile
new file mode 100644
index 000000000000..1d830b2cf1ad
--- /dev/null
+++ b/net/pear-Net_Socket/Makefile
@@ -0,0 +1,36 @@
+# Ports collection makefile for: pear-Net_Socket
+# Date created: 24 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_Socket
+PORTVERSION= 1.0.1
+CATEGORIES= net www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${CP} -Rp ${WRKSRC}/* ${PEARDIR}/Net
+ @${CHOWN} -R root:wheel ${PEARDIR}/Net/Socket.php
+
+.include <bsd.port.post.mk>