aboutsummaryrefslogtreecommitdiff
path: root/net/polyorb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/polyorb/Makefile')
-rw-r--r--net/polyorb/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/net/polyorb/Makefile b/net/polyorb/Makefile
index 309da2e31ba6..0c548506a727 100644
--- a/net/polyorb/Makefile
+++ b/net/polyorb/Makefile
@@ -40,14 +40,9 @@ do-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} default
post-install:
- @cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d -empty -print | ${XARGS} ${RMDIR}
- @cd ${STAGEDIR}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
- ${SORT} >> ${TMPPLIST}
- @cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | ${SORT} -r | \
- ${SED} -e '/lib\/gnat$$/d' -e '/share\/doc$$/d' -e '/share\/gps/d' \
- -e 's/^/@dirrm /g' >> ${TMPPLIST}
- @echo "@unexec rmdir %D/lib/gnat 2>/dev/null || true" >> ${TMPPLIST}
- @echo "@unexec rmdir %D/share/gps/plug-ins 2>/dev/null || true" >> ${TMPPLIST}
- @echo "@unexec rmdir %D/share/gps 2>/dev/null || true" >> ${TMPPLIST}
+ @(cd ${STAGEDIR}${PREFIX}; \
+ ${FIND} * -type d -empty -print | ${XARGS} ${RMDIR})
+ @(cd ${STAGEDIR}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
+ ${SORT} >> ${TMPPLIST})
.include <bsd.port.mk>