aboutsummaryrefslogtreecommitdiff
path: root/net/proxychains/files
diff options
context:
space:
mode:
Diffstat (limited to 'net/proxychains/files')
-rw-r--r--net/proxychains/files/patch-::acconfig.h8
-rw-r--r--net/proxychains/files/patch-::config.h.in9
-rw-r--r--net/proxychains/files/patch-::configure22
-rw-r--r--net/proxychains/files/patch-::configure.in18
-rw-r--r--net/proxychains/files/patch-proxychains::libproxychains.c21
-rw-r--r--net/proxychains/files/patch-proxychains::main.c11
6 files changed, 42 insertions, 47 deletions
diff --git a/net/proxychains/files/patch-::acconfig.h b/net/proxychains/files/patch-::acconfig.h
new file mode 100644
index 000000000000..e020c43e417b
--- /dev/null
+++ b/net/proxychains/files/patch-::acconfig.h
@@ -0,0 +1,8 @@
+--- acconfig.h.orig Thu Jun 24 12:07:12 2004
++++ acconfig.h Thu Jun 24 12:07:20 2004
+@@ -7,3 +7,5 @@
+
+ /* Define if you need the GNU extensions to compile */
+ #undef _GNU_SOURCE
++
++#undef PREFIX_DIR
diff --git a/net/proxychains/files/patch-::config.h.in b/net/proxychains/files/patch-::config.h.in
deleted file mode 100644
index bc26541f4017..000000000000
--- a/net/proxychains/files/patch-::config.h.in
+++ /dev/null
@@ -1,9 +0,0 @@
---- config.h.in.old Sat Jun 14 15:08:43 2003
-+++ config.h.in Sat Jun 14 15:09:24 2003
-@@ -6,3 +6,6 @@
- /* Version number of package */
- #undef VERSION
-
-+/* PREFIX needed for libproxychains.c */
-+#undef PREFIX
-+
diff --git a/net/proxychains/files/patch-::configure b/net/proxychains/files/patch-::configure
deleted file mode 100644
index d97365486d48..000000000000
--- a/net/proxychains/files/patch-::configure
+++ /dev/null
@@ -1,22 +0,0 @@
---- configure.old Sat Jun 14 15:08:33 2003
-+++ configure Sat Jun 14 15:09:49 2003
-@@ -807,6 +807,8 @@
-
- VERSION=1.8.2
-
-+PREFIX=$prefix
-+
- if test "`cd $srcdir && pwd`" != "`pwd`" && test -f $srcdir/config.status; then
- { echo "configure: error: source directory already configured; run "make distclean" there first" 1>&2; exit 1; }
- fi
-@@ -816,6 +818,10 @@
-
- cat >> confdefs.h <<EOF
- #define VERSION "$VERSION"
-+EOF
-+
-+cat >> confdefs.h <<EOF
-+#define PREFIX "$PREFIX"
- EOF
-
-
diff --git a/net/proxychains/files/patch-::configure.in b/net/proxychains/files/patch-::configure.in
new file mode 100644
index 000000000000..62e9c081da97
--- /dev/null
+++ b/net/proxychains/files/patch-::configure.in
@@ -0,0 +1,18 @@
+--- configure.in.orig Fri May 7 11:34:58 2004
++++ configure.in Thu Jun 24 14:56:30 2004
+@@ -12,11 +12,14 @@
+
+ AM_INIT_AUTOMAKE(proxychains,2.1)
+
+-AC_PREFIX_DEFAULT(/usr)
++AC_PREFIX_DEFAULT(/usr/local)
+ if test "x$prefix" = "xNONE"; then
+ prefix=$ac_default_prefix
+ ac_configure_args="$ac_configure_args --prefix $prefix"
++else
++ prefix=$prefix
+ fi
++AC_DEFINE_UNQUOTED(PREFIX_DIR, "${prefix}")
+
+ dnl without this order in this file, automake will be confused!
+ dnl
diff --git a/net/proxychains/files/patch-proxychains::libproxychains.c b/net/proxychains/files/patch-proxychains::libproxychains.c
index e431672d5615..f083d27ad508 100644
--- a/net/proxychains/files/patch-proxychains::libproxychains.c
+++ b/net/proxychains/files/patch-proxychains::libproxychains.c
@@ -1,22 +1,11 @@
---- proxychains/libproxychains.c.orig Wed Jun 4 11:11:03 2003
-+++ proxychains/libproxychains.c Sat Jun 14 15:17:55 2003
-@@ -14,6 +14,10 @@
- * (at your option) any later version. *
- * *
- ***************************************************************************/
-+#ifdef HAVE_CONFIG_H
-+#include <config.h>
-+#endif
-+
- #include <stdio.h>
- #include <unistd.h>
- #include <stdlib.h>
-@@ -72,7 +76,7 @@
+--- proxychains/libproxychains.c.orig Fri May 7 11:34:59 2004
++++ proxychains/libproxychains.c Thu Jun 24 10:54:27 2004
+@@ -73,7 +73,7 @@
if(!(file=fopen("./proxychains.conf","r")))
if(!(file=fopen(buff,"r")))
- if(!(file=fopen("/etc/proxychains.conf","r")))
-+ if(!(file=fopen(PREFIX "/etc/proxychains.conf","r")))
++ if(!(file=fopen(PREFIX_DIR "/etc/proxychains.conf","r")))
{
- perror("1");
+ perror("Can't locate proxychains.conf");
exit(1);
diff --git a/net/proxychains/files/patch-proxychains::main.c b/net/proxychains/files/patch-proxychains::main.c
new file mode 100644
index 000000000000..74394c262773
--- /dev/null
+++ b/net/proxychains/files/patch-proxychains::main.c
@@ -0,0 +1,11 @@
+--- proxychains/main.c.orig Thu Jun 24 13:13:46 2004
++++ proxychains/main.c Thu Jun 24 13:14:05 2004
+@@ -41,7 +41,7 @@
+ "More help in README file\n");
+ return 0 ;
+ }
+- putenv("LD_PRELOAD=/usr/lib/libproxychains.so");
++ putenv("LD_PRELOAD=" PREFIX_DIR "/lib/libproxychains.so.2");
+ execvp(argv[1],&argv[1]);
+ perror("proxychains can't load process....");
+ return EXIT_SUCCESS;