aboutsummaryrefslogtreecommitdiff
path: root/net/pygopherd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/pygopherd/Makefile')
-rw-r--r--net/pygopherd/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/net/pygopherd/Makefile b/net/pygopherd/Makefile
new file mode 100644
index 000000000000..94c522177605
--- /dev/null
+++ b/net/pygopherd/Makefile
@@ -0,0 +1,36 @@
+# ex:ts=8
+# Ports collection makefile for: pygopherd
+# Date created: Sep 6, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= pygopherd
+PORTVERSION= 1.1.0
+CATEGORIES= net python
+MASTER_SITES= http://gopher.quux.org:70/devel/gopher/Downloads/pygopherd/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN8= pygopherd.8
+
+post-patch:
+.for file in setup.py bin/pygopherd conf/pygopherd.conf pygopherd.8
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/${file}
+.endfor
+ @${REINPLACE_CMD} -e "s|/usr/bin/python2.2|${SETENV} python|g" \
+ ${WRKSRC}/bin/pygopherd
+ @${FIND} ${WRKSRC} -name "*.py" | ${XARGS} ${REINPLACE_CMD} \
+ -e "s|/usr/bin/python2.2|${SETENV} python|g"
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/${MAN8} ${MANPREFIX}/man/man8
+
+.include <bsd.port.mk>