aboutsummaryrefslogtreecommitdiff
path: root/net/qoauth
diff options
context:
space:
mode:
Diffstat (limited to 'net/qoauth')
-rw-r--r--net/qoauth/Makefile38
-rw-r--r--net/qoauth/distinfo3
-rw-r--r--net/qoauth/pkg-descr4
-rw-r--r--net/qoauth/pkg-plist15
4 files changed, 60 insertions, 0 deletions
diff --git a/net/qoauth/Makefile b/net/qoauth/Makefile
new file mode 100644
index 000000000000..d275d3967f2d
--- /dev/null
+++ b/net/qoauth/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: qoauth
+# Date created: 2010-09-18
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qoauth
+PORTVERSION= 1.0.1
+CATEGORIES= net devel security
+MASTER_SITES= http://files.ayoy.net/qoauth/release/${PORTVERSION}/src/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= QT support for OAuth-powered network services
+
+BUILD_DEPENDS+= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
+LIB_DEPENDS= qca.2:${PORTSDIR}/devel/qca
+RUN_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
+
+USE_LDCONFIG= yes
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib qtestlib network qmake_build moc_build
+HAS_CONFIGURE= yes
+USE_OPENSSL= yes
+
+QMAKEFLAGS+= PREFIX=${PREFIX}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,target.path}/pkgconfig,INSTALL_PREFIX}/libdata/pkgconfig,g' \
+ ${WRKSRC}/src/src.pro
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${MAKE_ENV} \
+ ${QMAKE} ${QMAKEFLAGS} qoauth.pro
+
+.include <bsd.port.mk>
diff --git a/net/qoauth/distinfo b/net/qoauth/distinfo
new file mode 100644
index 000000000000..145b10a18a89
--- /dev/null
+++ b/net/qoauth/distinfo
@@ -0,0 +1,3 @@
+MD5 (qoauth-1.0.1-src.tar.bz2) = bcb6d01e6c9a6fb22099c9e0f5889578
+SHA256 (qoauth-1.0.1-src.tar.bz2) = b8579a77cecb07928e557c4a019db902a0f040b22f7926f147299e87ac5a54fd
+SIZE (qoauth-1.0.1-src.tar.bz2) = 42298
diff --git a/net/qoauth/pkg-descr b/net/qoauth/pkg-descr
new file mode 100644
index 000000000000..17887a495ab4
--- /dev/null
+++ b/net/qoauth/pkg-descr
@@ -0,0 +1,4 @@
+QOAuth is an attempt to support interaction with OAuth-powered network services
+in a Qt way
+
+WWW: http://github.com/ayoy/qoauth
diff --git a/net/qoauth/pkg-plist b/net/qoauth/pkg-plist
new file mode 100644
index 000000000000..54ea1ac79119
--- /dev/null
+++ b/net/qoauth/pkg-plist
@@ -0,0 +1,15 @@
+include/QtOAuth/QtOAuth
+include/QtOAuth/interface.h
+include/QtOAuth/qoauth_global.h
+include/QtOAuth/qoauth_namespace.h
+lib/libqoauth.prl
+lib/libqoauth.so
+lib/libqoauth.so.1
+lib/libqoauth.so.1.0
+lib/libqoauth.so.1.0.1
+libdata/pkgconfig/qoauth.pc
+share/qt4/mkspecs/features/oauth.prf
+@dirrmtry share/qt4/mkspecs/features
+@dirrmtry share/qt4/mkspecs
+@dirrmtry share/qt4
+@dirrm include/QtOAuth