aboutsummaryrefslogtreecommitdiff
path: root/net/qt4-network
diff options
context:
space:
mode:
Diffstat (limited to 'net/qt4-network')
-rw-r--r--net/qt4-network/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/net/qt4-network/Makefile b/net/qt4-network/Makefile
index 894e1ddb460a..7c6de1357ba0 100644
--- a/net/qt4-network/Makefile
+++ b/net/qt4-network/Makefile
@@ -8,7 +8,7 @@
PORTNAME= network
PORTVERSION= 4.2.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES?= net ipv6
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -69,5 +69,9 @@ pre-configure:
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtNetwork.pc|${PREFIX}/libdata/pkgconfig/QtNetwork.pc|g' \
${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
+ -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
+ -E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
+ ${WRKSRC}/../../lib/*Qt*
.include <bsd.port.post.mk>