aboutsummaryrefslogtreecommitdiff
path: root/net/rinetd
diff options
context:
space:
mode:
Diffstat (limited to 'net/rinetd')
-rw-r--r--net/rinetd/Makefile1
-rw-r--r--net/rinetd/files/patch-rinetd.c2
-rw-r--r--net/rinetd/files/patch-select2poll16
3 files changed, 10 insertions, 9 deletions
diff --git a/net/rinetd/Makefile b/net/rinetd/Makefile
index ba63e73ff669..dac10b5a8a63 100644
--- a/net/rinetd/Makefile
+++ b/net/rinetd/Makefile
@@ -20,6 +20,7 @@ COMMENT= A simple TCP port redirector
WRKSRC= ${WRKDIR}/rinetd/
MAKE_JOBS_SAFE= yes
+USE_DOS2UNIX= yes
MAN8= rinetd.8
PORTDOCS= index.html
diff --git a/net/rinetd/files/patch-rinetd.c b/net/rinetd/files/patch-rinetd.c
index fe942d0093de..3c32c5bf626d 100644
--- a/net/rinetd/files/patch-rinetd.c
+++ b/net/rinetd/files/patch-rinetd.c
@@ -2,7 +2,7 @@
+++ rinetd.c Thu Jul 19 22:20:26 2001
@@ -243,6 +243,7 @@
signal(SIGHUP, hup);
- #endif /* WIN32 */
+ #endif /* WIN32 */
signal(SIGTERM, term);
+ setsid();
initArrays();
diff --git a/net/rinetd/files/patch-select2poll b/net/rinetd/files/patch-select2poll
index 5fa3f1411d27..cbcb3d749b48 100644
--- a/net/rinetd/files/patch-select2poll
+++ b/net/rinetd/files/patch-select2poll
@@ -1,15 +1,15 @@
--- rinetd.c.orig Mon Apr 14 22:19:23 2003
+++ rinetd.c Tue Oct 4 07:25:42 2005
@@ -12,6 +12,7 @@
- #include <netinet/in.h>
- #include <getopt.h>
- #include <errno.h>
-+#include <poll.h>
- #define INVALID_SOCKET (-1)
- #include <sys/time.h>
- #endif /* WIN32 */
+ #include <netinet/in.h>
+ #include <getopt.h>
+ #include <errno.h>
++#include <poll.h>
+ #define INVALID_SOCKET (-1)
+ #include <sys/time.h>
+ #endif /* WIN32 */
@@ -94,6 +95,7 @@
- #include "match.h"
+ #include "match.h"
SOCKET *seFds = 0;
+static int first_set = 0;