aboutsummaryrefslogtreecommitdiff
path: root/net/rrdtool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/rrdtool/Makefile')
-rw-r--r--net/rrdtool/Makefile47
1 files changed, 18 insertions, 29 deletions
diff --git a/net/rrdtool/Makefile b/net/rrdtool/Makefile
index 501cf6d0ebba..c05ed67e85a5 100644
--- a/net/rrdtool/Makefile
+++ b/net/rrdtool/Makefile
@@ -6,51 +6,40 @@
#
PORTNAME= rrdtool
-PORTVERSION= 1.0.49
+PORTVERSION= 1.2.4
CATEGORIES= net
MASTER_SITES= http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/
MAINTAINER= demon@FreeBSD.org
COMMENT= Round Robin Database Tools
-USE_PERL5= yes
-MAKE_ENV= PERL=${PERL}
+LIB_DEPENDS= cgi.1:${PORTSDIR}/devel/cgilib \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ art_lgpl_2.5:${PORTSDIR}/graphics/libart_lgpl2 \
+ png.5:${PORTSDIR}/graphics/png
+USE_PERL5= yes
USE_LIBTOOL_VER=15
+USE_GMAKE= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --enable-shared --enable-local-zlib \
- --program-transform-name=''
-CONFIGURE_ENV= PERL=${PERL}
+CONFIGURE_ARGS= --enable-perl-site-install
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib -fPIC
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libart-2.0 -I${LOCALBASE}/include/freetype2
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS:= ${CFLAGS:N-ffast-math}
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+INSTALLS_SHLIB= yes
-MAN1= RRDp.1 RRDs.1 bin_dec_hex.1 rrdcgi.1 rrdcreate.1 rrddump.1 \
- rrdfetch.1 rrdgraph.1 rrdlast.1 rrdresize.1 rrdrestore.1 \
- rrdtool.1 rrdtune.1 rrdtutorial.1 rrdtutorial.es.1 rrdupdate.1 \
- cdeftutorial.1 rpntutorial.1 rrdinfo.1 rrdxport.1 rrd-beginners.1
+MAN1= bin_dec_hex.1 cdeftutorial.1 rpntutorial.1 rrd-beginners.1 \
+ rrdbuild.1 rrdcgi.1 rrdcreate.1 rrddump.1 rrdfetch.1 rrdfirst.1 \
+ rrdgraph.1 rrdgraph_data.1 rrdgraph_examples.1 rrdgraph_graph.1 \
+ rrdgraph_rpn.1 rrdinfo.1 rrdlast.1 rrdresize.1 rrdrestore.1 \
+ rrdthreads.1 rrdtool.1 rrdtune.1 rrdtutorial.1 rrdupdate.1 \
+ rrdxport.1
MAN3= RRDp.3 RRDs.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-OPTIONS= "ISO-8859-2 fonts support" off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_LATIN2)
-CONFIGURE_ARGS+=--enable-latin2
-.endif
-
-.if ${ARCH} == "amd64"
-CONFIGURE_ARGS+=--with-pic
-.endif
-
-.if ${ARCH} == "ia64"
-BROKEN= "Does not build on ia64"
-.endif
-
post-extract:
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's/install-idocDATA install-ihtmlDATA//g' \
@@ -65,4 +54,4 @@ post-install:
@${ECHO_MSG} "############################################################################"
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>