aboutsummaryrefslogtreecommitdiff
path: root/net/rrdtool10
diff options
context:
space:
mode:
Diffstat (limited to 'net/rrdtool10')
-rw-r--r--net/rrdtool10/Makefile40
-rw-r--r--net/rrdtool10/distinfo1
-rw-r--r--net/rrdtool10/files/patch-aa12
-rw-r--r--net/rrdtool10/files/patch-ab18
-rw-r--r--net/rrdtool10/files/patch-ac21
-rw-r--r--net/rrdtool10/files/patch-ae14
-rw-r--r--net/rrdtool10/files/patch-af11
-rw-r--r--net/rrdtool10/files/patch-ag11
-rw-r--r--net/rrdtool10/files/patch-ak11
-rw-r--r--net/rrdtool10/pkg-comment1
-rw-r--r--net/rrdtool10/pkg-descr13
-rw-r--r--net/rrdtool10/pkg-plist85
12 files changed, 0 insertions, 238 deletions
diff --git a/net/rrdtool10/Makefile b/net/rrdtool10/Makefile
deleted file mode 100644
index d0007efddc2b..000000000000
--- a/net/rrdtool10/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-# New ports collection makefile for: rrdtool
-# Date created: 20 July 1999
-# Whom: Dmitry Sivachenko <dima@Chg.RU>
-#
-# $FreeBSD$
-#
-
-PORTNAME= rrdtool
-PORTVERSION= 1.0.33
-CATEGORIES= net
-MASTER_SITES= http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/
-
-MAINTAINER= demon@FreeBSD.org
-
-USE_PERL5= yes
-MAKE_ENV+= PERL=${PERL}
-
-USE_GMAKE= yes
-USE_LIBTOOL= yes
-INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --enable-shared=yes
-CONFIGURE_ENV= PERL=${PERL}
-CFLAGS:= ${CFLAGS:N-ffast-math}
-
-MAN1= RRDp.1 RRDs.1 bin_dec_hex.1 rrdcgi.1 rrdcreate.1 rrddump.1 \
- rrdfetch.1 rrdgraph.1 rrdlast.1 rrdresize.1 rrdrestore.1 \
- rrdtool.1 rrdtune.1 rrdtutorial.1 rrdtutorial.es.1 rrdupdate.1 \
- cdeftutorial.1 rpntutorial.1 rrdinfo.1
-MAN3= RRDp.3 RRDs.3
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-
-post-install:
-.if !defined(BATCH)
- @${ECHO} ""
- @${ECHO} "############################################################################"
- @${ECHO} "# See ${PREFIX}/share/examples/rrdtool for some demonstration code #"
- @${ECHO} "############################################################################"
-.endif
-
-.include <bsd.port.mk>
diff --git a/net/rrdtool10/distinfo b/net/rrdtool10/distinfo
deleted file mode 100644
index aedd58977a94..000000000000
--- a/net/rrdtool10/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (rrdtool-1.0.33.tar.gz) = 54bb6daf131cdc4bbe2bcf005bf583a5
diff --git a/net/rrdtool10/files/patch-aa b/net/rrdtool10/files/patch-aa
deleted file mode 100644
index ebf17ddaf33b..000000000000
--- a/net/rrdtool10/files/patch-aa
+++ /dev/null
@@ -1,12 +0,0 @@
---- perl-shared/Makefile.PL.orig Tue Jun 13 20:51:17 2000
-+++ perl-shared/Makefile.PL Tue Jun 13 20:51:19 2000
-@@ -10,7 +10,8 @@
- 'NAME' => 'RRDs',
- 'VERSION_FROM' => 'RRDs.pm', # finds $VERSION
- 'DEFINE' => "-DPERLPATCHLEVEL=$Config{PATCHLEVEL}",
-- 'INC' => '-I../src -I../gd1.3',
-+ 'CCFLAGS' => "-DHAVE_CONFIG_H",
-+ 'INC' => '-I../config -I../src -I../gd1.3',
- # where to look for the necessary libraries
- # Perl will figure out which one is valid
- 'depend' => {'RRDs.c' => "../src/.libs/librrd_private.a"},
diff --git a/net/rrdtool10/files/patch-ab b/net/rrdtool10/files/patch-ab
deleted file mode 100644
index 2513bfe423fb..000000000000
--- a/net/rrdtool10/files/patch-ab
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/rrd_tool.c.orig Tue Jun 13 20:56:08 2000
-+++ src/rrd_tool.c Tue Jun 13 20:56:10 2000
-@@ -317,12 +317,12 @@
- datai=data;
- printf(" ");
- for (i = 0; i<ds_cnt;i++)
-- printf("%14s",ds_namv[i]);
-+ printf("%14s ",ds_namv[i]);
- printf ("\n\n");
- for (i = start; i <= end; i += step){
-- printf("%10lu:", i);
-+ printf("%10lu: ", i);
- for (ii = 0; ii < ds_cnt; ii++)
-- printf(" %0.10e", *(datai++));
-+ printf(" %0.10e ", *(datai++));
- printf("\n");
- }
- for (i=0;i<ds_cnt;i++)
diff --git a/net/rrdtool10/files/patch-ac b/net/rrdtool10/files/patch-ac
deleted file mode 100644
index 26d5410e4faf..000000000000
--- a/net/rrdtool10/files/patch-ac
+++ /dev/null
@@ -1,21 +0,0 @@
---- Makefile.in.orig Wed Oct 4 13:09:37 2000
-+++ Makefile.in Wed Oct 4 13:10:39 2000
-@@ -383,12 +383,12 @@
-
- # lets schedule the perl stuff for installation
- # the special call to install-sh is because the -d switch is not portable
--install-data-local:
-- ./config/mkinstalldirs $(DESTDIR)$(prefix)/lib/perl/auto/RRDs
-- $(INSTALL) -m 644 perl-piped/RRDp.pm $(DESTDIR)$(prefix)/lib/perl
-- $(INSTALL) -m 644 perl-shared/RRDs.pm $(DESTDIR)$(prefix)/lib/perl
-- $(INSTALL) -m 644 perl-shared/blib/arch/auto/RRDs/RRDs.bs $(DESTDIR)$(prefix)/lib/perl/auto/RRDs
-- $(INSTALL) -m 755 perl-shared/blib/arch/auto/RRDs/RRDs.@SO_EXT@ $(DESTDIR)$(prefix)/lib/perl/auto/RRDs
-+install-data-local: site-perl-inst
-+# ./config/mkinstalldirs $(DESTDIR)$(prefix)/lib/perl/auto/RRDs
-+# $(INSTALL) -m 644 perl-piped/RRDp.pm $(DESTDIR)$(prefix)/lib/perl
-+# $(INSTALL) -m 644 perl-shared/RRDs.pm $(DESTDIR)$(prefix)/lib/perl
-+# $(INSTALL) -m 644 perl-shared/blib/arch/auto/RRDs/RRDs.bs $(DESTDIR)$(prefix)/lib/perl/auto/RRDs
-+# $(INSTALL) -m 755 perl-shared/blib/arch/auto/RRDs/RRDs.@SO_EXT@ $(DESTDIR)$(prefix)/lib/perl/auto/RRDs
-
- # rules for building the perl module
- perl_piped: perl-piped/Makefile
diff --git a/net/rrdtool10/files/patch-ae b/net/rrdtool10/files/patch-ae
deleted file mode 100644
index 98feb795d0ff..000000000000
--- a/net/rrdtool10/files/patch-ae
+++ /dev/null
@@ -1,14 +0,0 @@
---- doc/Makefile.in.orig Fri Jan 7 20:56:21 2000
-+++ doc/Makefile.in Fri Jan 7 20:57:05 2000
-@@ -96,9 +96,9 @@
- EXTRA_DIST = $(POD) $(HTML) $(TXT)
-
- # some install rules
--idocdir = $(prefix)/doc
-+idocdir = $(prefix)/share/doc/rrdtool
- idoc_DATA = $(POD) $(TXT)
--ihtmldir = $(prefix)/html
-+ihtmldir = $(prefix)/share/doc/rrdtool/html
- ihtml_DATA = $(HTML)
- imandir = $(prefix)/man/man1
- iman_DATA = $(MAN)
diff --git a/net/rrdtool10/files/patch-af b/net/rrdtool10/files/patch-af
deleted file mode 100644
index a109c319e248..000000000000
--- a/net/rrdtool10/files/patch-af
+++ /dev/null
@@ -1,11 +0,0 @@
---- examples/Makefile.in.orig Fri Jan 7 20:58:16 2000
-+++ examples/Makefile.in Fri Jan 7 20:59:13 2000
-@@ -81,7 +81,7 @@
-
- EXTRA_DIST = cgi-demo.cgi.in piped-demo.pl.in shared-demo.pl.in stripes.pl.in bigtops.pl.in minmax.pl.in
-
--examplesdir = $(prefix)/examples
-+examplesdir = $(prefix)/share/examples/rrdtool
- examples_SCRIPTS = cgi-demo.cgi piped-demo.pl shared-demo.pl stripes.pl bigtops.pl minmax.pl
- mkinstalldirs = $(SHELL) $(top_srcdir)/config/mkinstalldirs
- CONFIG_HEADER = ../config/config.h
diff --git a/net/rrdtool10/files/patch-ag b/net/rrdtool10/files/patch-ag
deleted file mode 100644
index fde216a89988..000000000000
--- a/net/rrdtool10/files/patch-ag
+++ /dev/null
@@ -1,11 +0,0 @@
---- contrib/Makefile.in.orig Thu Feb 22 12:56:40 2001
-+++ contrib/Makefile.in Thu Feb 22 12:56:57 2001
-@@ -87,7 +87,7 @@
- ZLIB_LIB_DIR = @ZLIB_LIB_DIR@
-
- SUBDIRS = trytime
--contribdir = $(prefix)/contrib
-+contribdir = $(prefix)/share/examples/rrdtool
- contrib_DATA = README
- EXTRA_DIST = rrdview log2rrd rrd-file-icon rrdproc rrdlastds add_ds killspike rrdfetchnames snmpstats rrdexplorer php3 php4
- mkinstalldirs = $(SHELL) $(top_srcdir)/config/mkinstalldirs
diff --git a/net/rrdtool10/files/patch-ak b/net/rrdtool10/files/patch-ak
deleted file mode 100644
index f998e6995400..000000000000
--- a/net/rrdtool10/files/patch-ak
+++ /dev/null
@@ -1,11 +0,0 @@
---- contrib/trytime/Makefile.in.orig Fri Jan 7 21:11:21 2000
-+++ contrib/trytime/Makefile.in Fri Jan 7 21:11:41 2000
-@@ -76,7 +76,7 @@
- ZLIB_LIB_DIR = @ZLIB_LIB_DIR@
-
- EXTRA_DIST = trytime.c
--contribdir = $(prefix)/contrib/trytime
-+contribdir = $(prefix)/share/examples/rrdtool/trytime
- contrib_DATA = README trytime.c
- mkinstalldirs = $(SHELL) $(top_srcdir)/config/mkinstalldirs
- CONFIG_HEADER = ../../config/config.h
diff --git a/net/rrdtool10/pkg-comment b/net/rrdtool10/pkg-comment
deleted file mode 100644
index 73242bc78bb6..000000000000
--- a/net/rrdtool10/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Round Robin Database Tools
diff --git a/net/rrdtool10/pkg-descr b/net/rrdtool10/pkg-descr
deleted file mode 100644
index ca95d58a230d..000000000000
--- a/net/rrdtool10/pkg-descr
+++ /dev/null
@@ -1,13 +0,0 @@
-It is pretty easy to gather status information from all sorts of things,
-ranging from the temperature in your office to the number of octets which
-have passed through the FDDI interface of your router. But it is not so
-trivial to store this data in a efficient and systematic manner. This is
-where RRDtool kicks in. It lets you log and analyze the data you gather from
-all kinds of data-sources (DS). The data analysis part of RRDtool is based
-on the ability to quickly generate graphical representations of the data
-values collected over a definable time period.
-
-WWW: http://ee-staff.ethz.ch/~oetiker/webtools/rrdtool/
-
---dima
-dima@Chg.RU
diff --git a/net/rrdtool10/pkg-plist b/net/rrdtool10/pkg-plist
deleted file mode 100644
index 3afc8fccadcc..000000000000
--- a/net/rrdtool10/pkg-plist
+++ /dev/null
@@ -1,85 +0,0 @@
-bin/rrdtool
-bin/rrdcgi
-bin/trytime
-bin/rrdupdate
-lib/librrd.a
-lib/librrd.so.0
-lib/librrd.so
-include/rrd.h
-share/examples/rrdtool/cgi-demo.cgi
-share/examples/rrdtool/piped-demo.pl
-share/examples/rrdtool/shared-demo.pl
-share/examples/rrdtool/stripes.pl
-share/examples/rrdtool/bigtops.pl
-share/examples/rrdtool/minmax.pl
-share/examples/rrdtool/trytime/trytime.c
-share/examples/rrdtool/trytime/README
-share/examples/rrdtool/README
-share/doc/rrdtool/rrdtool.pod
-share/doc/rrdtool/rrdinfo.pod
-share/doc/rrdtool/rrdlast.pod
-share/doc/rrdtool/rrdcreate.pod
-share/doc/rrdtool/rrdupdate.pod
-share/doc/rrdtool/cdeftutorial.pod
-share/doc/rrdtool/rpntutorial.pod
-share/doc/rrdtool/rrdgraph.pod
-share/doc/rrdtool/bin_dec_hex.pod
-share/doc/rrdtool/rrdfetch.pod
-share/doc/rrdtool/rrdrestore.pod
-share/doc/rrdtool/rrddump.pod
-share/doc/rrdtool/rrdtune.pod
-share/doc/rrdtool/rrdresize.pod
-share/doc/rrdtool/rrdcgi.pod
-share/doc/rrdtool/rrdtutorial.pod
-share/doc/rrdtool/rrdtutorial.es.pod
-share/doc/rrdtool/rrdtool.txt
-share/doc/rrdtool/rrdinfo.txt
-share/doc/rrdtool/rrdlast.txt
-share/doc/rrdtool/rrdcreate.txt
-share/doc/rrdtool/rrdupdate.txt
-share/doc/rrdtool/cdeftutorial.txt
-share/doc/rrdtool/rpntutorial.txt
-share/doc/rrdtool/rrdgraph.txt
-share/doc/rrdtool/bin_dec_hex.txt
-share/doc/rrdtool/rrdfetch.txt
-share/doc/rrdtool/rrdrestore.txt
-share/doc/rrdtool/rrddump.txt
-share/doc/rrdtool/rrdtune.txt
-share/doc/rrdtool/rrdresize.txt
-share/doc/rrdtool/rrdcgi.txt
-share/doc/rrdtool/rrdtutorial.txt
-share/doc/rrdtool/rrdtutorial.es.txt
-share/doc/rrdtool/RRDs.txt
-share/doc/rrdtool/RRDp.txt
-share/doc/rrdtool/html/rrdtool.html
-share/doc/rrdtool/html/rrdinfo.html
-share/doc/rrdtool/html/rrdlast.html
-share/doc/rrdtool/html/rrdcreate.html
-share/doc/rrdtool/html/rrdupdate.html
-share/doc/rrdtool/html/cdeftutorial.html
-share/doc/rrdtool/html/rpntutorial.html
-share/doc/rrdtool/html/rrdgraph.html
-share/doc/rrdtool/html/bin_dec_hex.html
-share/doc/rrdtool/html/rrdfetch.html
-share/doc/rrdtool/html/rrdrestore.html
-share/doc/rrdtool/html/rrddump.html
-share/doc/rrdtool/html/rrdtune.html
-share/doc/rrdtool/html/rrdresize.html
-share/doc/rrdtool/html/rrdcgi.html
-share/doc/rrdtool/html/rrdtutorial.html
-share/doc/rrdtool/html/rrdtutorial.es.html
-share/doc/rrdtool/html/RRDs.html
-share/doc/rrdtool/html/RRDp.html
-lib/perl5/site_perl/%%PERL_VER%%/RRDp.pm
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/RRDp/.packlist
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/RRDs.pm
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/ntmake.pl
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/RRDs/RRDs.so
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/RRDs/RRDs.bs
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/RRDs/.packlist
-@dirrm share/examples/rrdtool/trytime
-@dirrm share/examples/rrdtool
-@dirrm share/doc/rrdtool/html
-@dirrm share/doc/rrdtool
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/RRDp
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/RRDs