aboutsummaryrefslogtreecommitdiff
path: root/net/rtorrent/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/rtorrent/Makefile')
-rw-r--r--net/rtorrent/Makefile42
1 files changed, 0 insertions, 42 deletions
diff --git a/net/rtorrent/Makefile b/net/rtorrent/Makefile
deleted file mode 100644
index 6ab1f20fca3a..000000000000
--- a/net/rtorrent/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# New ports collection makefile for: rtorrent
-# Date created: Mar 03 2005
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= rtorrent
-PORTVERSION= 0.4.3
-CATEGORIES= net
-MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
-
-MAINTAINER= flz@FreeBSD.org
-COMMENT= BitTorrent Client written in C++
-
-LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl \
- torrent.6:${PORTSDIR}/net/libtorrent
-
-MAN1= rtorrent.1
-
-USE_GCC= 3.4
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-debug
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-USE_AUTOTOOLS= libtool:13:inc
-
-SUB_FILES= pkg-message
-
-PORTDOCS= README
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/configure
-
-post-install:
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}/
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/rtorrent.rc ${EXAMPLESDIR}/
- ${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>