aboutsummaryrefslogtreecommitdiff
path: root/net/ruby-soap
diff options
context:
space:
mode:
Diffstat (limited to 'net/ruby-soap')
-rw-r--r--net/ruby-soap/Makefile11
-rw-r--r--net/ruby-soap/distinfo2
-rw-r--r--net/ruby-soap/pkg-plist7
3 files changed, 15 insertions, 5 deletions
diff --git a/net/ruby-soap/Makefile b/net/ruby-soap/Makefile
index b3215d4ea501..68e2d476a5be 100644
--- a/net/ruby-soap/Makefile
+++ b/net/ruby-soap/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= soap
-PORTVERSION= 1.3.5
-PORTREVISION= 1
+PORTVERSION= 1.3.6
CATEGORIES= net ruby
MASTER_SITES= http://www.jin.gr.jp/~nahi/Ruby/SOAP4R/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -17,8 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
RUN_DEPENDS= ${RUBY_SITELIBDIR}/application.rb:${PORTSDIR}/sysutils/ruby-application.rb \
- ${RUBY_SITELIBDIR}/urb.rb:${PORTSDIR}/net/ruby-urb \
- ${RUBY_SITELIBDIR}/http-access.rb:${PORTSDIR}/www/ruby-http-access \
+ ${RUBY_SITELIBDIR}/uri.rb:${PORTSDIR}/net/ruby-uri \
+ ${RUBY_SITELIBDIR}/http-access2.rb:${PORTSDIR}/www/ruby-http-access \
+ ${RUBY_SITELIBDIR}/GServer.rb:${PORTSDIR}/net/ruby-gserver \
${RUBY_SITELIBDIR}/date3.rb:${PORTSDIR}/devel/ruby-date2 \
${RUBY_SITELIBDIR}/nqxml/info.rb:${PORTSDIR}/textproc/ruby-nqxml
@@ -29,6 +29,9 @@ NO_BUILD= yes
DOCS_EN= RELEASE_en.html rubyStyle.css
DOCS_JA= RELEASE_ja.html
+post-extract:
+ ${CP} ${WRKSRC}/redist/soap/httpserver.rb ${WRKSRC}/sample/
+
post-patch:
${RUBY} -i -pe 'gsub /\brubyStyle.css\b/, "../\\1"' ${WRKSRC}/RELEASE_ja.html
diff --git a/net/ruby-soap/distinfo b/net/ruby-soap/distinfo
index eb0c469915c7..bba42d1b7518 100644
--- a/net/ruby-soap/distinfo
+++ b/net/ruby-soap/distinfo
@@ -1 +1 @@
-MD5 (ruby/soap4r-1_3_5.tar.gz) = 0bbd862e4130d230d8e6932e9ee00fd0
+MD5 (ruby/soap4r-1_3_6.tar.gz) = 81b849dc7ade37fa9b27f2f1df64041b
diff --git a/net/ruby-soap/pkg-plist b/net/ruby-soap/pkg-plist
index ce981f9dbdd1..a3d3f5e7c512 100644
--- a/net/ruby-soap/pkg-plist
+++ b/net/ruby-soap/pkg-plist
@@ -17,11 +17,14 @@
%%RUBY_SITELIBDIR%%/soap/rpcRouter.rb
%%RUBY_SITELIBDIR%%/soap/rpcUtils.rb
%%RUBY_SITELIBDIR%%/soap/saxdriver.rb
+%%RUBY_SITELIBDIR%%/soap/server.rb
%%RUBY_SITELIBDIR%%/soap/soap.rb
+%%RUBY_SITELIBDIR%%/soap/standaloneServer.rb
%%RUBY_SITELIBDIR%%/soap/streamHandler.rb
%%RUBY_SITELIBDIR%%/soap/xmlparser.rb
@dirrm %%RUBY_SITELIBDIR%%/soap
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/apacheClient.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/httpserver.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/hippo5tq2.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/hippoClient.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/whois.rb
@@ -65,7 +68,10 @@
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/test/interopR2/SOAP4R_SOAPBuildersInteropTest_R2GroupB.wsdl
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/test/interopR2/SOAP4R_SOAPBuildersInteropTest_R2base.wsdl
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/test/interopR2/base.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/test/interopR2/client.NetRemoting.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/test/interopR2/client4S4C.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/test/interopR2/clientApacheAxis.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/test/interopR2/clientApacheSOAP.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/test/interopR2/clientASP.NET.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/test/interopR2/clientBase.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/test/interopR2/clientSOAP4R.rb
@@ -73,6 +79,7 @@
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/test/interopR2/clientWhiteMesa.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/test/interopR2/iSimonReg.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/test/interopR2/server.cgi
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/test/interopR2/server.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/soap/test/interopR2/simonReg.rb
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/soap/test/interopR2
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/soap/test/interop