aboutsummaryrefslogtreecommitdiff
path: root/net/ruby-spread/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ruby-spread/Makefile')
-rw-r--r--net/ruby-spread/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/net/ruby-spread/Makefile b/net/ruby-spread/Makefile
new file mode 100644
index 000000000000..b54cc1f7d505
--- /dev/null
+++ b/net/ruby-spread/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: ruby-spread
+# Date created: 2002 July 22
+# Whom: seanc@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= spread
+PORTVERSION= 0.2
+CATEGORIES= net ruby
+MASTER_SITES= http://www.rubynet.org/modules/net/spread/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= seanc@FreeBSD.org
+
+LIB_DEPENDS= tspread.1:${PORTSDIR}/net/spread
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/flooder.rb ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/user.rb ${RUBY_MODEXAMPLESDIR}
+ ${MKDIR} ${RUBY_MODDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_MODDOCDIR}
+.endif
+
+.include <bsd.port.mk>