aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-grpc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/rubygem-grpc/Makefile')
-rw-r--r--net/rubygem-grpc/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/net/rubygem-grpc/Makefile b/net/rubygem-grpc/Makefile
new file mode 100644
index 000000000000..95b55544f500
--- /dev/null
+++ b/net/rubygem-grpc/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= grpc
+PORTVERSION= 1.4.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= tz@FreeBSD.org
+COMMENT= Ruby implementation of gRPC
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss \
+ grpc>=0:devel/grpc \
+ rubygem-google-protobuf>=3.0:devel/rubygem-google-protobuf \
+ rubygem-googleauth>=0.5.1:security/rubygem-googleauth
+LIB_DEPENDS= libcares.so:dns/c-ares
+
+MAKE_JOBS_UNSAFE=yes
+
+USE_RUBY= yes
+USES= gem gmake pkgconfig
+
+post-extract:
+ @${RM} -r ${WRKSRC}/include ${WRKSRC}/third_party ${WRKSRC}/src/boringssl \
+ ${WRKSRC}/src/core ${WRKSRC}/Makefile ${WRKSRC}/.yardopts ${WRKSRC}/etc
+ @${CP} ${FILESDIR}/grpc.gemspec ${WRKSRC}
+
+.include <bsd.port.mk>