aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-grpc
diff options
context:
space:
mode:
Diffstat (limited to 'net/rubygem-grpc')
-rw-r--r--net/rubygem-grpc/Makefile12
-rw-r--r--net/rubygem-grpc/distinfo6
-rw-r--r--net/rubygem-grpc/files/grpc.gemspecbin8650 -> 10025 bytes
-rw-r--r--net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb17
-rw-r--r--net/rubygem-grpc/files/patch-src_ruby_lib_grpc.rb10
5 files changed, 26 insertions, 19 deletions
diff --git a/net/rubygem-grpc/Makefile b/net/rubygem-grpc/Makefile
index 5a5d153d4c42..ea940547fbb0 100644
--- a/net/rubygem-grpc/Makefile
+++ b/net/rubygem-grpc/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= grpc
-PORTVERSION= 1.4.0
-PORTREVISION= 2
+PORTVERSION= 1.8.0
CATEGORIES= net rubygems
MASTER_SITES= RG
@@ -14,9 +13,11 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss \
grpc>=0:devel/grpc \
rubygem-google-protobuf>=3.0:devel/rubygem-google-protobuf \
- rubygem-googleauth>=0.5.1:security/rubygem-googleauth
+ rubygem-googleauth>=0.5.1:security/rubygem-googleauth \
+ rubygem-googleapis-common-protos-types>=1.0.0:devel/rubygem-googleapis-common-protos-types
-LIB_DEPENDS= libcares.so:dns/c-ares
+LIB_DEPENDS= libcares.so:dns/c-ares \
+ libunwind.so:devel/libunwind
BUILD_DEPENDS= ca_root_nss>=0:security/ca_root_nss \
grpc>=0:devel/grpc
@@ -31,4 +32,7 @@ post-extract:
${WRKSRC}/src/core ${WRKSRC}/Makefile ${WRKSRC}/.yardopts ${WRKSRC}/etc
@${CP} ${FILESDIR}/grpc.gemspec ${WRKSRC}
+post-patch:
+ @${REINPLACE_CMD} 's,%%LOCALBASE%%,${LOCALBASE},' ${WRKSRC}/src/ruby/lib/grpc.rb
+
.include <bsd.port.mk>
diff --git a/net/rubygem-grpc/distinfo b/net/rubygem-grpc/distinfo
index 59df70da9c7d..8d1326d38dc1 100644
--- a/net/rubygem-grpc/distinfo
+++ b/net/rubygem-grpc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1498614608
-SHA256 (rubygem/grpc-1.4.0.gem) = 927d8d3b486d8fa597cab6932b77a7a2b932e66d240d2182599ae2bac82e38ea
-SIZE (rubygem/grpc-1.4.0.gem) = 2736128
+TIMESTAMP = 1514703376
+SHA256 (rubygem/grpc-1.8.0.gem) = 1372253d7fb102a2e1d9c6e93275dab328bf8f66bdc202bad368c02256de9e0d
+SIZE (rubygem/grpc-1.8.0.gem) = 2744832
diff --git a/net/rubygem-grpc/files/grpc.gemspec b/net/rubygem-grpc/files/grpc.gemspec
index 0955cf3dbd98..dc6e73dd178d 100644
--- a/net/rubygem-grpc/files/grpc.gemspec
+++ b/net/rubygem-grpc/files/grpc.gemspec
Binary files differ
diff --git a/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb b/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
index 1c897d8fad81..7c2525c0f0b2 100644
--- a/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
+++ b/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
@@ -1,6 +1,6 @@
---- src/ruby/ext/grpc/extconf.rb.orig 2017-06-28 17:25:39 UTC
+--- src/ruby/ext/grpc/extconf.rb.orig 2017-12-31 07:02:12 UTC
+++ src/ruby/ext/grpc/extconf.rb
-@@ -70,9 +70,9 @@ ENV['LD'] = ENV['CC']
+@@ -56,9 +56,9 @@ ENV['LD'] = ENV['CC']
ENV['AR'] = 'libtool -o' if RUBY_PLATFORM =~ /darwin/
@@ -12,8 +12,8 @@
+ENV['EMBED_CARES'] = 'false'
ENV['ARCH_FLAGS'] = RbConfig::CONFIG['ARCH_FLAG']
ENV['ARCH_FLAGS'] = '-arch i386 -arch x86_64' if RUBY_PLATFORM =~ /darwin/
- ENV['CFLAGS'] = '-DGPR_BACKWARDS_COMPATIBILITY_MODE'
-@@ -81,16 +81,16 @@ output_dir = File.expand_path(RbConfig::CONFIG['topdir
+ ENV['CPPFLAGS'] = '-DGPR_BACKWARDS_COMPATIBILITY_MODE'
+@@ -67,17 +67,18 @@ output_dir = File.expand_path(RbConfig::CONFIG['topdir
grpc_lib_dir = File.join(output_dir, 'libs', grpc_config)
ENV['BUILDDIR'] = output_dir
@@ -21,13 +21,16 @@
- puts 'Building internal gRPC into ' + grpc_lib_dir
- nproc = 4
- nproc = Etc.nprocessors * 2 if Etc.respond_to? :nprocessors
-- system("make -j#{nproc} -C #{grpc_root} #{grpc_lib_dir}/libgrpc.a CONFIG=#{grpc_config} Q=")
+- make = bsd ? 'gmake' : 'make'
+- system("#{make} -j#{nproc} -C #{grpc_root} #{grpc_lib_dir}/libgrpc.a CONFIG=#{grpc_config} Q=")
- exit 1 unless $? == 0
-end
+#unless windows
+# puts 'Building internal gRPC into ' + grpc_lib_dir
-+# puts("gmake -C #{grpc_root} #{grpc_lib_dir}/libgrpc.a CONFIG=#{grpc_config} Q=")
-+# system("gmake -C #{grpc_root} #{grpc_lib_dir}/libgrpc.a CONFIG=#{grpc_config} Q=")
++# nproc = 4
++# nproc = Etc.nprocessors * 2 if Etc.respond_to? :nprocessors
++# make = bsd ? 'gmake' : 'make'
++# system("#{make} -j#{nproc} -C #{grpc_root} #{grpc_lib_dir}/libgrpc.a CONFIG=#{grpc_config} Q=")
+# exit 1 unless $? == 0
+#end
diff --git a/net/rubygem-grpc/files/patch-src_ruby_lib_grpc.rb b/net/rubygem-grpc/files/patch-src_ruby_lib_grpc.rb
index e9afe592efd6..77413e178ccd 100644
--- a/net/rubygem-grpc/files/patch-src_ruby_lib_grpc.rb
+++ b/net/rubygem-grpc/files/patch-src_ruby_lib_grpc.rb
@@ -1,11 +1,11 @@
---- src/ruby/lib/grpc.rb.orig 2017-06-28 17:25:39 UTC
+--- src/ruby/lib/grpc.rb.orig 2017-12-31 07:02:12 UTC
+++ src/ruby/lib/grpc.rb
-@@ -27,7 +27,7 @@
- # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
- # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+@@ -12,7 +12,7 @@
+ # See the License for the specific language governing permissions and
+ # limitations under the License.
-ssl_roots_path = File.expand_path('../../../../etc/roots.pem', __FILE__)
-+ssl_roots_path = '/usr/local/etc/ssl/cert.pem'
++ssl_roots_path = '%%LOCALBASE%%/etc/ssl/cert.pem'
require_relative 'grpc/errors'
require_relative 'grpc/grpc'