aboutsummaryrefslogtreecommitdiff
path: root/net/rwhoisd/files
diff options
context:
space:
mode:
Diffstat (limited to 'net/rwhoisd/files')
-rw-r--r--net/rwhoisd/files/patch-aa85
-rw-r--r--net/rwhoisd/files/patch-ab19
-rw-r--r--net/rwhoisd/files/patch-ac38
-rw-r--r--net/rwhoisd/files/patch-ad54
-rw-r--r--net/rwhoisd/files/patch-ae27
-rw-r--r--net/rwhoisd/files/patch-af10
-rw-r--r--net/rwhoisd/files/patch-ag20
-rw-r--r--net/rwhoisd/files/rwhoisd.sh2
8 files changed, 59 insertions, 196 deletions
diff --git a/net/rwhoisd/files/patch-aa b/net/rwhoisd/files/patch-aa
index bcb60067f649..c3ff541a6aaa 100644
--- a/net/rwhoisd/files/patch-aa
+++ b/net/rwhoisd/files/patch-aa
@@ -1,78 +1,11 @@
---- Makefile.in.orig Thu Aug 8 20:37:37 1996
-+++ Makefile.in Fri May 23 03:06:12 1997
-@@ -2,7 +2,7 @@
- @SET_MAKE@
+--- Makefile.in.orig Tue Jun 3 23:20:53 1997
++++ Makefile.in Sat Nov 25 15:44:00 2000
+@@ -25,7 +25,7 @@
+ BIN_SUBDIRS = server tools
+ ALL_SUBDIRS = $(LIB_SUBDIRS) $(BIN_SUBDIRS) $(SAMPLE_DATA_DIR)
- # set install program
--INSTALL = @INSTALL@
-+INSTALL = /usr/bin/install -c -s -o bin -g bin
+-all: libraries libwrap binaries
++all: libraries binaries
- # set prefix values
- prefix = @prefix@
-@@ -25,12 +25,12 @@
- PARSER_DIR = $(TOOLS_DIR)/rwhoisparse
- LIBWRAP_DIR = tools/tcpd_wrapper
- CLIENT_DIR = client
--SAMPLE_DATA_DIR = @SAMPLE_DATA_DIR@
-+SAMPLE_DATA_DIR = ${RWHOIS_ROOT_DIR}
- LIBRWHOIS = librwhois.a
- LIBMKDB = libmkdb.a
- LIBWRAP = libwrap.a
-
--all: librwhois libmkdb libwrap make-server indexer parser make-client
-+all: librwhois libmkdb make-server indexer parser make-client
-
- librwhois:
- @echo "Making $(LIBRWHOIS)"
-@@ -77,7 +77,7 @@
-
- install-chroot:
- @echo "Setup chroot stuff"
-- chroot.sh $(RWHOIS_ROOT_DIR)
-+ ./chroot.sh $(RWHOIS_ROOT_DIR)
-
- install-client:
- @echo "Installing RWhois Client"
-@@ -86,21 +86,13 @@
- install-sample-data: sample-data-install
-
- sample-data-install:
-- @echo "Setting up for quickie install with sample data"
-- @echo "This is located in `pwd`/sample.data"
-- @echo "Setting up RWhois default data directory (data will reside here)"
-+ if [ -d ${.CURDIR}/sample.data/bin ]; then rm -r ${.CURDIR}/sample.data/bin; fi
-+ if [ -d ${.CURDIR}/sample.data/etc ]; then rm -r ${.CURDIR}/sample.data/etc; fi
-+ cp -r ${.CURDIR}/sample.data/ ${SAMPLE_DATA_DIR}
- (sh tools/install/setup_rwhois_conf $(SAMPLE_DATA_DIR))
-- @echo "Setting up index scripts"
- (sh tools/install/setup_index_scripts $(SAMPLE_DATA_DIR))
-- @echo "Copying the indexer into the sample data area"
-- if [ $(SAMPLE_DATA_DIR) != $(RWHOIS_ROOT_DIR) ]; then \
-- if [ ! -d $(SAMPLE_DATA_DIR)/bin ]; then \
-- mkdir $(SAMPLE_DATA_DIR)/bin; \
-- fi; \
-- cp $(RWHOIS_ROOT_DIR)/bin/rmkdbindex $(SAMPLE_DATA_DIR)/bin; \
-- fi
-- @echo "Running index scripts"
- (sh tools/install/run_index_scripts $(SAMPLE_DATA_DIR))
-+ /usr/sbin/chown -R nobody ${SAMPLE_DATA_DIR}/data ${SAMPLE_DATA_DIR}/rwhois.log
-
- clean:
- @echo "Cleaning Server"
-@@ -109,8 +101,6 @@
- (cd $(COMMON_DIR); $(MAKE) clean)
- @echo "Cleaning MKDB"
- (cd $(MKDB_DIR); $(MAKE) clean)
-- @echo "Cleaning TCPD stuff"
-- (cd $(LIBWRAP_DIR); $(MAKE) clean)
- @echo "Cleaning RWhois Indexer"
- (cd $(INDEXER_DIR); $(MAKE) clean)
- @echo "Cleaning RWhois Parser"
-@@ -133,7 +123,6 @@
- (cd $(MKDB_DIR); $(MAKE) distclean)
- (cd $(INDEXER_DIR); $(MAKE) distclean)
- (cd $(PARSER_DIR); $(MAKE) distclean)
-- (cd $(LIBWRAP_DIR); $(MAKE) clean)
- (cd $(CLIENT_DIR); $(MAKE) distclean)
-
- dist:
+ libraries:
+ @for dir in $(LIB_SUBDIRS); do \
diff --git a/net/rwhoisd/files/patch-ab b/net/rwhoisd/files/patch-ab
deleted file mode 100644
index 90489b414c71..000000000000
--- a/net/rwhoisd/files/patch-ab
+++ /dev/null
@@ -1,19 +0,0 @@
---- client/Makefile.in.orig Wed Sep 25 18:10:48 1996
-+++ client/Makefile.in Fri May 23 02:34:00 1997
-@@ -6,7 +6,7 @@
-
- CC = @CC@
- RANLIB = @RANLIB@
--INSTALL = @INSTALL@
-+INSTALL = /usr/bin/install -c -s -o bin -g bin
-
-
- #
-@@ -56,6 +56,7 @@
- install:
- if [ ! -d $(bindir) ]; then mkdir $(bindir); fi
- $(INSTALL) rwhois $(bindir)
-+ /bin/ln -sf ${PREFIX}/lib/rwhois/bin/rwhois ${PREFIX}/bin/rwhois
-
- clean:
- rm -f rwhois *.o *~ librwclient.a
diff --git a/net/rwhoisd/files/patch-ac b/net/rwhoisd/files/patch-ac
index 7832c52b13c2..05ca015c5c8c 100644
--- a/net/rwhoisd/files/patch-ac
+++ b/net/rwhoisd/files/patch-ac
@@ -1,31 +1,33 @@
---- server/Makefile.in.orig Wed Sep 25 13:03:56 1996
-+++ server/Makefile.in Fri May 9 22:48:56 1997
-@@ -7,14 +7,15 @@
+--- server/Makefile.in.orig Fri May 12 01:10:25 2000
++++ server/Makefile.in Sat Nov 25 15:27:16 2000
+@@ -9,7 +9,7 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
bindir = $(exec_prefix)/bin
+-etcdir = $(exec_prefix)/etc
+sbindir = $(exec_prefix)/sbin
- etcdir = $(exec_prefix)/etc
- # local libs/includes
- COMMON_INC = -I../common
- COMMON_LIBS = -L../common -lrwhois
+ srcdir = @srcdir@
+ VPATH = @srcdir@
+@@ -18,8 +18,8 @@
+ COMMON_INC = -I$(srcdir)/../common
+ COMMON_LIBS = -L../common -lrwcommon
--WRAP_INC = -I../tools/tcpd_wrapper
--WRAP_LIBS = -L../tools/tcpd_wrapper -lwrap
-+WRAP_INC = -I${PREFIX}/include
-+WRAP_LIBS = -L${PREFIX}/lib -lwrap
+-WRAP_INC = -I$(srcdir)../tools/tcpd_wrapper
+-WRAP_LIBS = -L../tools/tcpd_wrapper -lwrap
++WRAP_INC = -I${LOCALBASE}/include
++WRAP_LIBS = -L${LOCALBASE}/lib -lwrap
- MKDB_INC = -I../mkdb
- MKDB_LIBS = -L../mkdb -lmkdb
-@@ -77,8 +78,8 @@
- $(CC) -c $(CFLAGS) $(LOCAL_INC) $*.c
+ MKDB_INC = -I$(srcdir)/../mkdb
+ MKDB_LIBS = -L../mkdb -lmkdb
+@@ -97,8 +97,8 @@
install:
+ if [ ! -d $(exec_prefix) ]; then mkdir $(exec_prefix); fi
- if [ ! -d $(etcdir) ]; then mkdir $(etcdir); fi
- $(INSTALL) rwhoisd $(etcdir)
-+ if [ ! -d $(sbindir) ]; then mkdir -p $(sbindir); fi
++ if [ ! -d $(sbindir) ]; then mkdir $(sbindir); fi
+ $(INSTALL) rwhoisd $(sbindir)
- clean:
- rm -f *.[oa]
+ uninstall:
+ $(RM) $(etcdir)/rwhoisd
diff --git a/net/rwhoisd/files/patch-ad b/net/rwhoisd/files/patch-ad
deleted file mode 100644
index d72758599cbd..000000000000
--- a/net/rwhoisd/files/patch-ad
+++ /dev/null
@@ -1,54 +0,0 @@
---- chroot.sh.orig Wed Jul 31 15:34:34 1996
-+++ chroot.sh Thu Jun 5 09:45:59 1997
-@@ -10,9 +10,15 @@
- #umask 022
-
- RWHOIS_ROOT_DIR=$1
--COPY="cp"
-+COPY="/bin/cp"
-
- # check if these directories exist
-+if test ! -d ${RWHOIS_ROOT_DIR}
-+then
-+ echo "make directory ${RWHOIS_ROOT_DIR}."
-+ mkdir ${RWHOIS_ROOT_DIR}
-+fi
-+
- if test ! -d ${RWHOIS_ROOT_DIR}/etc
- then
- echo "make directory ${RWHOIS_ROOT_DIR}/etc".
-@@ -35,20 +41,30 @@
- then
- echo "make directory ${RWHOIS_ROOT_DIR}/usr"
- mkdir $RWHOIS_ROOT_DIR/usr
-- mkdir $RWHOIS_ROOT_DIR/usr/lib
--elif test ! -d $RWHOIS_ROOT_DIR/usr/lib
-+fi
-+
-+if test ! -d $RWHOIS_ROOT_DIR/usr/lib
- then
- echo "make directory ${RWHOIS_ROOT_DIR}/usr/lib"
- mkdir $RWHOIS_ROOT_DIR/usr/lib
- fi
-
-+if test ! -d $RWHOIS_ROOT_DIR/usr/libexec
-+then
-+ echo "make directory ${RWHOIS_ROOT_DIR}/usr/libexec"
-+ mkdir $RWHOIS_ROOT_DIR/usr/libexec
-+fi
-+
- #copy /etc/resolv.conf to (rwhois_root)/etc
- $COPY /etc/resolv.conf ${RWHOIS_ROOT_DIR}/etc
-
- #copy /usr/lib/files to (rwhois_root)/usr/lib
-- $COPY /usr/lib/ld.so /usr/lib/libnsl.so.1 /usr/lib/libsocket.so.1 /usr/lib/libc.so.1 /usr/lib/libdl.so.1 /usr/lib/libintl.so.1 /usr/lib/libmp.so.1 /usr/lib/libw.so.1 /usr/lib/libmapmalloc.so.1 $RWHOIS_ROOT_DIR/usr/lib
-+ $COPY /usr/lib/libc.so.* ${PREFIX}/lib/libwrap.so.* $RWHOIS_ROOT_DIR/usr/lib
-+
-+#copy /usr/lib/files to (rwhois_root)/usr/lib
-+ $COPY /usr/libexec/ld.so $RWHOIS_ROOT_DIR/usr/libexec
-
- #copy /usr/bin/execut. to (rwhois_root)/bin
-- $COPY /usr/bin/sh /usr/bin/sort $RWHOIS_ROOT_DIR/bin
-+ $COPY /bin/sh /usr/bin/sort /bin/date $RWHOIS_ROOT_DIR/bin
-
- echo "done"
diff --git a/net/rwhoisd/files/patch-ae b/net/rwhoisd/files/patch-ae
index 9fcaee9d93a5..6d86925ae455 100644
--- a/net/rwhoisd/files/patch-ae
+++ b/net/rwhoisd/files/patch-ae
@@ -1,20 +1,11 @@
---- sample.data/rwhois.conf.orig Fri May 23 01:59:32 1997
-+++ sample.data/rwhois.conf Fri May 23 02:00:37 1997
-@@ -10,7 +10,7 @@
- # to. If it is not set, it will default to the current working
- # directory.
- # NOTE: you want to change this.
--root-dir: /home/devel2/davidb/src/rwhois-dev/sample.data
-+root-dir: /usr/local/lib/rwhois
-
- # schema-file: The config file that contains the top-level schema
- # information. This file must exist. The old 'object-file' refers to
-@@ -85,7 +85,7 @@
- # chrooted: NO
-
- # userid: If run as root, rwhoisd will change to this user
--userid: davidb
+--- sample.data/rwhoisd.conf.orig Wed Nov 26 08:23:46 1997
++++ sample.data/rwhoisd.conf Sat Nov 25 15:30:05 2000
+@@ -109,7 +109,7 @@
+ # users group, as found in /etc/passwd.
+ # note that this really, really should be an unprivileged user
+ # this options doesn't have a default.
+-userid: rwhoisd
+userid: nobody
- # verbosity: What level of reporting (to the console) do you wish.
- # The default is '1'. '0' is quiet and numbers greater then '1' are
+ # pid-file: where to put the file containing the pid of the server.
+ # normal default is "rwhoisd.pid"
diff --git a/net/rwhoisd/files/patch-af b/net/rwhoisd/files/patch-af
deleted file mode 100644
index ebb060dd17aa..000000000000
--- a/net/rwhoisd/files/patch-af
+++ /dev/null
@@ -1,10 +0,0 @@
---- common/misc.c.orig Tue Oct 13 23:12:30 1998
-+++ common/misc.c Tue Oct 13 23:12:58 1998
-@@ -380,7 +380,6 @@
- char *program;
- char *param;
- {
-- int errno = 0;
- extern char **environ;
- char *myenviron[MAX_SET];
- char *argv[MAX_SET];
diff --git a/net/rwhoisd/files/patch-ag b/net/rwhoisd/files/patch-ag
new file mode 100644
index 000000000000..3c87514cd4e8
--- /dev/null
+++ b/net/rwhoisd/files/patch-ag
@@ -0,0 +1,20 @@
+--- tools/Xpgp/Xpgp.c.orig Fri Jan 30 09:25:58 1998
++++ tools/Xpgp/Xpgp.c Sat Nov 25 15:58:33 2000
+@@ -55,7 +55,7 @@
+
+ key = xcalloc(1, sizeof(char) * 1050);
+
+- gets(key);
++ fgets(key, sizeof(key), stdin);
+ fprintf(fp, "%s\n",key);
+
+ if (strstr(key, "END"))
+@@ -72,7 +72,7 @@
+ free(key);
+
+ newstr = xcalloc(1, sizeof(char)*100);
+- gets(newstr);
++ fgets(newstr, sizeof(newstr), stdin);
+
+ if (STRN_EQ(newstr, "-X-pgp off keyadd", 17))
+ {
diff --git a/net/rwhoisd/files/rwhoisd.sh b/net/rwhoisd/files/rwhoisd.sh
index 08c071bd0e42..878e8877aa44 100644
--- a/net/rwhoisd/files/rwhoisd.sh
+++ b/net/rwhoisd/files/rwhoisd.sh
@@ -10,7 +10,7 @@ start)
# remove or comment the following line and uncomment the one below it once you have
# configured your server's data
echo "rwhoisd not started; sample data still in place. See ${PREFIX}/share/doc/rwhois for details."
- #[ -x ${PREFIX}/lib/rwhois/sbin/rwhoisd ] && ${PREFIX}/lib/rwhois/sbin/rwhoisd -c ${PREFIX}/lib/rwhois/rwhois.conf & && echo -n ' rwhoisd'
+ #[ -x ${PREFIX}/lib/rwhois/sbin/rwhoisd ] && ${PREFIX}/lib/rwhois/sbin/rwhoisd -c ${PREFIX}/lib/rwhois/rwhoisd.conf & && echo -n ' rwhoisd'
;;
stop)
# killall rwhoisd && echo -n ' rwhoisd