aboutsummaryrefslogtreecommitdiff
path: root/net/samba4wins/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/samba4wins/Makefile')
-rw-r--r--net/samba4wins/Makefile73
1 files changed, 0 insertions, 73 deletions
diff --git a/net/samba4wins/Makefile b/net/samba4wins/Makefile
deleted file mode 100644
index 3a919fdb2e51..000000000000
--- a/net/samba4wins/Makefile
+++ /dev/null
@@ -1,73 +0,0 @@
-# Created by: Timur I. Bakeyev <timur@gnu.org>
-# $FreeBSD$
-
-PORTNAME= samba4wins
-PORTVERSION= 1.0.8
-PORTREVISION= 0
-CATEGORIES= net
-MASTER_SITES= http://ftp.sernet.de/pub/samba4WINS/debian/pool/
-DISTNAME= ${PORTNAME}_${PORTVERSION}-2
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Full featured replicating WINS server for UNIX
-
-CONFLICTS= ja-samba-2.* ja-samba-4.* samba-2.* samba-4.* sharity-light-1.*
-
-MAKE_JOBS_UNSAFE= yes
-USES= iconv perl5
-GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf autoheader
-
-WRKSRC= ${WRKDIR}/${PORTNAME}/source
-
-# directories
-VARDIR?= /var
-S4W_DATADIR= ${PREFIX}/share/${PORTNAME}
-S4W_LOGDIR= ${VARDIR}/log/${PORTNAME}
-S4W_RUNDIR= ${VARDIR}/run
-S4W_LOCKDIR= ${VARDIR}/db/${PORTNAME}
-S4W_PRIVATE= ${S4W_LOCKDIR}/private
-S4W_CONFDIR= ${PREFIX}/etc
-S4W_LIBDIR= ${PREFIX}/lib/${PORTNAME}
-S4W_CONFIG= ${S4W_CONFDIR}/samba4wins.conf
-
-CONFIGURE_ARGS+= --exec-prefix=${PREFIX} \
- --datadir=${S4W_DATADIR} \
- --libdir=${S4W_LIBDIR} \
- --localstatedir=${VARDIR} \
- --with-privatedir=${S4W_PRIVATE} \
- --with-lockdir=${S4W_LOCKDIR} \
- --with-piddir=${S4W_RUNDIR} \
- --with-logfilebase=${S4W_LOGDIR}
-
-CONFIGURE_ARGS+= --disable-reg-gconf --disable-socket-wrapper \
- --with-readline=/usr --with-included-popt \
- ${ICONV_CONFIGURE_BASE} --without-sqlite3 \
- --without-pthreads --without-python
-
-USE_RC_SUBR= smbd4wins
-SUB_LIST+= S4W_RUNDIR=${S4W_RUNDIR}
-
-PLIST_SUB+= S4W_LOGDIR=${S4W_LOGDIR} \
- S4W_LOCKDIR=${S4W_LOCKDIR}
-
-INSTALL_TARGET= showlayout installbin installdat installmisc installlib installpc
-
-NO_STAGE= yes
-post-build:
- @for f in ${WRKSRC}/scripting/bin/*; do \
- ${REINPLACE_CMD} -i '' -e 's|smbscript|${PREFIX}/bin/smbscript4|' \
- $${f} && ${MV} $${f} $${f}4; \
- done
-
-post-install:
- @${MKDIR} ${S4W_CONFDIR}
- ${INSTALL_DATA} ${FILESDIR}/samba4wins.conf.sample ${S4W_CONFDIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-. for d in HOWTO.txt NEWS.txt README.txt TODO.txt
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/${PORTNAME}-${d} ${DOCSDIR}/${d}
-. endfor
-.endif
-
-.include <bsd.port.mk>