aboutsummaryrefslogtreecommitdiff
path: root/net/sdl_net
diff options
context:
space:
mode:
Diffstat (limited to 'net/sdl_net')
-rw-r--r--net/sdl_net/Makefile9
-rw-r--r--net/sdl_net/distinfo2
-rw-r--r--net/sdl_net/files/patch-Makefile.in14
-rw-r--r--net/sdl_net/pkg-plist2
4 files changed, 22 insertions, 5 deletions
diff --git a/net/sdl_net/Makefile b/net/sdl_net/Makefile
index 51862173a195..331056963c91 100644
--- a/net/sdl_net/Makefile
+++ b/net/sdl_net/Makefile
@@ -6,19 +6,22 @@
#
PORTNAME= sdl_net
-PORTVERSION= 1.1.1
+PORTVERSION= 1.2.0
CATEGORIES= net
-MASTER_SITES= http://www.devolution.com/~slouken/SDL/projects/SDL_net/src/
+MASTER_SITES= http://www.libsdl.org/projects/SDL_net/release/
DISTNAME= SDL_net-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
-LIB_DEPENDS= SDL-1.0.2:${PORTSDIR}/devel/sdl \
+LIB_DEPENDS= SDL-1.1.3:${PORTSDIR}/devel/sdl-devel \
GUI.0:${PORTSDIR}/graphics/guilib
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+
USE_LIBTOOL= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
post-extract:
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
diff --git a/net/sdl_net/distinfo b/net/sdl_net/distinfo
index c30e5c7b020e..f408276e55ce 100644
--- a/net/sdl_net/distinfo
+++ b/net/sdl_net/distinfo
@@ -1 +1 @@
-MD5 (SDL_net-1.1.1.tar.gz) = fc85251bad967f056c41fe2709088801
+MD5 (SDL_net-1.2.0.tar.gz) = c8d4452f58c457b6f3dd6ca04bf3f071
diff --git a/net/sdl_net/files/patch-Makefile.in b/net/sdl_net/files/patch-Makefile.in
new file mode 100644
index 000000000000..8addb5121e42
--- /dev/null
+++ b/net/sdl_net/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- Makefile.in 2001/04/06 13:15:50 1.1
++++ Makefile.in 2001/04/06 13:16:13
+@@ -89,7 +89,7 @@
+
+ lib_LTLIBRARIES = libSDL_net.la
+
+-libSDL_netincludedir = $(includedir)/SDL
++libSDL_netincludedir = $(includedir)/SDL11
+ libSDL_netinclude_HEADERS = SDL_net.h
+
+
diff --git a/net/sdl_net/pkg-plist b/net/sdl_net/pkg-plist
index e8b9b46ac404..4585e6cde7fd 100644
--- a/net/sdl_net/pkg-plist
+++ b/net/sdl_net/pkg-plist
@@ -1,4 +1,4 @@
-include/SDL/SDL_net.h
+include/SDL11/SDL_net.h
lib/libSDL_net.a
lib/libSDL_net.so
lib/libSDL_net.so.0