aboutsummaryrefslogtreecommitdiff
path: root/net/silc-client
diff options
context:
space:
mode:
Diffstat (limited to 'net/silc-client')
-rw-r--r--net/silc-client/Makefile44
-rw-r--r--net/silc-client/distinfo6
-rw-r--r--net/silc-client/files/patch-apps__irssi__Makefile.in11
-rw-r--r--net/silc-client/files/patch-doc-Makefile.in25
-rw-r--r--net/silc-client/files/patch-doc__Makefile.in17
-rw-r--r--net/silc-client/files/patch-irssi::src::core::network.c11
-rw-r--r--net/silc-client/pkg-install61
-rw-r--r--net/silc-client/pkg-plist227
8 files changed, 160 insertions, 242 deletions
diff --git a/net/silc-client/Makefile b/net/silc-client/Makefile
index 5c07785da9e3..245ddc742a66 100644
--- a/net/silc-client/Makefile
+++ b/net/silc-client/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= silc
-PORTVERSION= 1.0.3
+PORTVERSION= 1.1
CATEGORIES= net ipv6 security
MASTER_SITES= http://www.silcnet.org/download/%SUBDIR%/ \
http://ftp.silcnet.org/%SUBDIR%/ \
@@ -28,22 +28,15 @@ MAINTAINER= aquatique-ports@rambler.ru
COMMENT= Secure Internet Live Conferencing (SILC) network client
USE_BZIP2= yes
-USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GNOME= glib12
USE_GMAKE= yes
-CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc/${PORTNAME} \
- --with-simdir=${PREFIX}/lib/silcsim/client \
- --with-helpdir=${PREFIX}/share/${PORTNAME}/help \
- --with-docdir=${PREFIX}/share/doc/silc \
+CONFIGURE_ARGS= --docdir=${DOCSDIR} \
+ --mandir=${MANPREFIX}/man \
--with-perl=no \
--without-libtoolfix
-#INSTALLS_SHLIB= yes
-PLIST_SUB= INSTALL_DIR="${INSTALL_DIR}"
-PKGDEINSTALL= ${PKGINSTALL}
-
-INSTALL_DIR?= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
+MAN1= silc.1
.ifndef(WITH_PTHREADS)
CONFIGURE_ARGS+= --without-pthreads
@@ -61,32 +54,23 @@ pre-everything::
.ifndef(WITH_PTHREADS)
@${ECHO_MSG} '===> Define WITH_PTHREADS to enable pthreads support'
.endif
- @${ECHO_MSG}
-.ifndef(WITH_OPTIMIZED_CFLAGS)
- @${ECHO_MSG} '===> Define WITH_OPTIMIZED_CFLAGS to enable compilation optimizations'
- @${ECHO_MSG} '===> which is known to break some platforms (e.g., alpha)'
-.endif
post-patch:
-.ifndef(WITH_OPTIMIZED_CFLAGS)
- @${PERL} -pi -e 's/-O2//' ${WRKSRC}/${CONFIGURE_SCRIPT}
-.endif
# install neither documentation nor silc server, we have ports for those
- @${PERL} -pi -e 's/-D_THREAD_SAFE//' ${WRKSRC}/${CONFIGURE_SCRIPT}
- @${PERL} -pi -e 's/docdir/DOCDIR/' ${WRKSRC}/doc/Makefile.in
- @${PERL} -pi -e 's/^(install-data-am:) install-docDATA$$/\1/' \
+ @${REINPLACE_CMD} -e 's/-D_THREAD_SAFE//' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's/docdir/DOCDIR/' ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e 's/^install-data-am: install-docDATA$$/install-data-am:/' \
${WRKSRC}/apps/irssi/docs/Makefile.in
- @${PERL} -pi -e 's/^(install-data-am:) install-moduleLTLIBRARIES$$/\1/' \
+ @${REINPLACE_CMD} -e 's/^install-data-am: install-moduleLTLIBRARIES$$/install-data-am:/' \
${WRKSRC}/apps/irssi/src/perl/Makefile.in
- @${PERL} -pi -e 's/--libtool-enable-shared//' \
+ @${REINPLACE_CMD} -e 's/--libtool-enable-shared//' \
${WRKSRC}/lib/silccrypt/Makefile.in
-
-#post-configure:
-# @${CP} ${LIBTOOL} ${WRKSRC}
+ @${REINPLACE_CMD} -e 's/^MODULESDIR="$$silc_prefix/MODULESDIR="$$silc_prefix\/share\/silc/' ${WRKSRC}/configure
post-install:
- @${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
- ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @if [ ! -f ${PREFIX}/etc/silc.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/silc.conf.sample ${PREFIX}/etc/silc.conf ; \
+ fi
.include <bsd.port.pre.mk>
@@ -94,7 +78,7 @@ post-install:
WITHOUT_OPTIMIZED_ASM= yes
.endif
-.if ${OSVERSION} >= 400014 && !defined(WITHOUT_IPV6)
+.ifndef(WITHOUT_IPV6)
CONFIGURE_ARGS+= --enable-ipv6
.endif
diff --git a/net/silc-client/distinfo b/net/silc-client/distinfo
index 32982d373853..66df2d1df580 100644
--- a/net/silc-client/distinfo
+++ b/net/silc-client/distinfo
@@ -1,3 +1,3 @@
-MD5 (silc-client-1.0.3.tar.bz2) = 6727a65fe71b90b018086afe8fc84cf9
-SHA256 (silc-client-1.0.3.tar.bz2) = ee4b39b1122ac47f678edb874288412d208f57ccad9e81b1086126276d6a5440
-SIZE (silc-client-1.0.3.tar.bz2) = 1424405
+MD5 (silc-client-1.1.tar.bz2) = 3b2d25e2379c79d88169ef777230f318
+SHA256 (silc-client-1.1.tar.bz2) = b41f162cd06e3b21daacd39a54438cc5b8c63228110bebeaf7b8c886bf107326
+SIZE (silc-client-1.1.tar.bz2) = 1611218
diff --git a/net/silc-client/files/patch-apps__irssi__Makefile.in b/net/silc-client/files/patch-apps__irssi__Makefile.in
new file mode 100644
index 000000000000..8ff69bf5206b
--- /dev/null
+++ b/net/silc-client/files/patch-apps__irssi__Makefile.in
@@ -0,0 +1,11 @@
+--- ./apps/irssi/Makefile.in.orig Mon Jun 4 05:22:15 2007
++++ ./apps/irssi/Makefile.in Tue Jun 5 00:55:54 2007
+@@ -813,7 +813,7 @@
+ -mkdir -p $(mandir)/man1
+
+ doc-install-client:
+- $(INSTALL_DATA) $(silc_top_srcdir)/apps/irssi/silc.conf $(docdir)/example_silc.conf
++ $(INSTALL_DATA) $(silc_top_srcdir)/apps/irssi/silc.conf $(sysconfdir)/silc.conf.sample
+ -@if test -f $(silc_top_srcdir)/doc/silc.1 ; then \
+ $(INSTALL_DATA) $(silc_top_srcdir)/doc/silc.1 $(mandir)/man1; \
+ fi
diff --git a/net/silc-client/files/patch-doc-Makefile.in b/net/silc-client/files/patch-doc-Makefile.in
deleted file mode 100644
index 40d4ec93815e..000000000000
--- a/net/silc-client/files/patch-doc-Makefile.in
+++ /dev/null
@@ -1,25 +0,0 @@
---- doc/Makefile.in.orig Thu Jan 18 12:14:15 2007
-+++ doc/Makefile.in Thu Jan 18 12:14:46 2007
-@@ -402,22 +402,9 @@
-
-
- all:
-- touch draft-riikonen-silc-spec-08.txt
-- touch draft-riikonen-silc-pp-09.txt
-- touch draft-riikonen-silc-ke-auth-08.txt
-- touch draft-riikonen-silc-commands-06.txt
-- touch draft-riikonen-silc-flags-payloads-04.txt
-- touch draft-riikonen-presence-attrs-03.txt
-
- dist-hook:
- $(SILC_TOP_SRCDIR)/scripts/manpages.pl
-- rm draft-riikonen*.txt
-- touch draft-riikonen-silc-spec-08.txt
-- touch draft-riikonen-silc-pp-09.txt
-- touch draft-riikonen-silc-ke-auth-08.txt
-- touch draft-riikonen-silc-commands-06.txt
-- touch draft-riikonen-silc-flags-payloads-04.txt
-- touch draft-riikonen-presence-attrs-03.txt
-
- doc-install:
- -mkdir -p $(DOCDIR)
diff --git a/net/silc-client/files/patch-doc__Makefile.in b/net/silc-client/files/patch-doc__Makefile.in
new file mode 100644
index 000000000000..43dfdac3e7a0
--- /dev/null
+++ b/net/silc-client/files/patch-doc__Makefile.in
@@ -0,0 +1,17 @@
+--- ./doc/Makefile.in.orig Tue Jun 5 01:18:13 2007
++++ ./doc/Makefile.in Tue Jun 5 01:18:39 2007
+@@ -449,14 +449,6 @@
+ $(SILC_TOP_SRCDIR)/scripts/manpages.pl
+
+ doc-install:
+- -mkdir -p $(docdir)
+- -$(INSTALL_DATA) $(top_srcdir)/doc/FAQ $(docdir)/
+- -$(INSTALL_DATA) $(top_srcdir)/COPYING $(docdir)/
+- -$(INSTALL_DATA) $(top_srcdir)/CHANGES $(docdir)/
+- -$(INSTALL_DATA) $(top_srcdir)/CREDITS $(docdir)/
+- -$(INSTALL_DATA) $(top_srcdir)/README* $(docdir)/
+- -$(INSTALL_DATA) $(top_srcdir)/INSTALL $(docdir)/
+- -$(INSTALL_DATA) $(top_srcdir)/TODO $(docdir)/
+
+ install-data-hook: doc-install
+
diff --git a/net/silc-client/files/patch-irssi::src::core::network.c b/net/silc-client/files/patch-irssi::src::core::network.c
deleted file mode 100644
index 538a83a47c26..000000000000
--- a/net/silc-client/files/patch-irssi::src::core::network.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- apps/irssi/src/core/network.c.orig Sun Jan 25 10:11:14 2004
-+++ apps/irssi/src/core/network.c Sun Jan 25 10:11:29 2004
-@@ -611,7 +611,7 @@
- int net_hosterror_notfound(int error)
- {
- #ifdef HAVE_IPV6
-- return error != 1 && (error == EAI_NONAME || error == EAI_NODATA);
-+ return error != 1 && (error == EAI_NONAME);
- #else
- return error == HOST_NOT_FOUND || error == NO_ADDRESS;
- #endif
diff --git a/net/silc-client/pkg-install b/net/silc-client/pkg-install
deleted file mode 100644
index 3ee0226a61f4..000000000000
--- a/net/silc-client/pkg-install
+++ /dev/null
@@ -1,61 +0,0 @@
-#!/bin/sh
-# $FreeBSD$
-
-# based on original from op port, written by Cyrille Lefevre
-# <clefevre@citeweb.net>
-
-[ $# != 2 ] && exit 1
-PKGNAME=$1
-ACTION=$2
-
-CONF_DIR=${PKG_PREFIX}/etc/silc
-DOC_DIR=${PKG_PREFIX}/share/doc/silc
-#/example_silc.conf
-
-CONF_FILE=silc.conf
-CONF_OWN=root
-CONF_GRP=wheel
-CONF_MODE=444
-
-SAMP_SUFX=.sample
-
-INSTALL=install
-CMP=cmp
-RM=rm
-RMDIR=rmdir
-
-INSTALL_DIR="${INSTALL} -d -o root -g wheel -m 755"
-
-case "$ACTION" in
-
-POST-INSTALL)
- if [ -f "${CONF_DIR}/${CONF_FILE}" ]
- then
- echo "$PKGNAME: Will not overwrite existing ${CONF_DIR}/${CONF_FILE} configuration file."
- else
- ${INSTALL} -c -o ${CONF_OWN} -g ${CONF_GRP} -m ${CONF_MODE} \
- ${DOC_DIR}/example_silc.conf \
- ${CONF_DIR}/${CONF_FILE}
- fi
- ;;
-
-DEINSTALL)
- if ${CMP} -s ${DOC_DIR}/example_silc.conf \
- ${CONF_DIR}/${CONF_FILE}; then
- ${RM} -f ${CONF_DIR}/${CONF_FILE}
- else
- echo "$PKGNAME: Will not remove existing ${CONF_DIR}/${CONF_FILE} configuration file."
- echo "$PKGNAME: However, if you are permanently removing this port, you should do a 'rm -f ${CONF_DIR}/${CONF_FILE}' to remove the configuration file left."
- echo "$PKGNAME: Also, do not forget to 'rmdir ${CONF_DIR} 2>/dev/null'"
- fi
- ;;
-
-PRE-INSTALL|POST-DEINSTALL)
- ;;
-
-*)
- exit 1
- ;;
-esac
-
-exit
diff --git a/net/silc-client/pkg-plist b/net/silc-client/pkg-plist
index f22affed4767..f2471ea5f5d0 100644
--- a/net/silc-client/pkg-plist
+++ b/net/silc-client/pkg-plist
@@ -1,113 +1,116 @@
bin/silc
-share/silc/help/action
-share/silc/help/admin
-share/silc/help/alias
-share/silc/help/attr
-share/silc/help/away
-share/silc/help/ban
-share/silc/help/beep
-share/silc/help/bind
-share/silc/help/cat
-share/silc/help/cd
-share/silc/help/channel
-share/silc/help/clear
-share/silc/help/close
-share/silc/help/cmode
-share/silc/help/connect
-share/silc/help/cumode
-share/silc/help/cycle
-share/silc/help/date
-share/silc/help/dehilight
-share/silc/help/detach
-share/silc/help/disconnect
-share/silc/help/echo
-share/silc/help/eval
-share/silc/help/exec
-share/silc/help/file
-share/silc/help/format
-share/silc/help/getkey
-share/silc/help/help
-share/silc/help/hilight
-share/silc/help/ignore
-share/silc/help/info
-share/silc/help/invite
-share/silc/help/invitelist
-share/silc/help/join
-share/silc/help/key
-share/silc/help/kick
-share/silc/help/kickban
-share/silc/help/kill
-share/silc/help/knockout
-share/silc/help/lastlog
-share/silc/help/layout
-share/silc/help/levels
-share/silc/help/list
-share/silc/help/listkeys
-share/silc/help/load
-share/silc/help/log
-share/silc/help/me
-share/silc/help/motd
-share/silc/help/mmsg
-share/silc/help/msg
-share/silc/help/names
-share/silc/help/nick
-share/silc/help/notice
-share/silc/help/oper
-share/silc/help/part
-share/silc/help/perlflush
-share/silc/help/ping
-share/silc/help/query
-share/silc/help/quit
-share/silc/help/reconnect
-share/silc/help/reload
-share/silc/help/rmreconns
-share/silc/help/rmrejoins
-share/silc/help/save
-share/silc/help/sconnect
-share/silc/help/script
-share/silc/help/scrollback
-share/silc/help/server
-share/silc/help/set
-share/silc/help/shutdown
-share/silc/help/silcnet
-share/silc/help/silcoper
-share/silc/help/smsg
-share/silc/help/stats
-share/silc/help/statusbar
-share/silc/help/toggle
-share/silc/help/topic
-share/silc/help/umode
-share/silc/help/unalias
-share/silc/help/unignore
-share/silc/help/unload
-share/silc/help/unquery
-share/silc/help/users
-share/silc/help/version
-share/silc/help/watch
-share/silc/help/whois
-share/silc/help/whowas
-share/silc/help/window
-share/silc/themes/default.theme
-share/silc/scripts/autoop.pl
-share/silc/scripts/beep.pl
-share/silc/scripts/clones.pl
-share/silc/scripts/dns.pl
-share/silc/scripts/hello.pl
-share/silc/scripts/mail-maildir.pl
-share/silc/scripts/mail.pl
-share/silc/scripts/silc-mime.pl
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/CREDITS
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/example_silc.conf
-@dirrm share/silc/themes
-@dirrm share/silc/help
-@dirrm share/silc/scripts
-@dirrm share/silc
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrmtry etc/silc
-@dirrmtry lib/silcsim/client
-@dirrmtry lib/silcsim
+%%DATADIR%%/help/action
+%%DATADIR%%/help/admin
+%%DATADIR%%/help/alias
+%%DATADIR%%/help/attr
+%%DATADIR%%/help/away
+%%DATADIR%%/help/ban
+%%DATADIR%%/help/beep
+%%DATADIR%%/help/bind
+%%DATADIR%%/help/cat
+%%DATADIR%%/help/cd
+%%DATADIR%%/help/channel
+%%DATADIR%%/help/clear
+%%DATADIR%%/help/close
+%%DATADIR%%/help/cmode
+%%DATADIR%%/help/connect
+%%DATADIR%%/help/cumode
+%%DATADIR%%/help/cycle
+%%DATADIR%%/help/date
+%%DATADIR%%/help/dehilight
+%%DATADIR%%/help/detach
+%%DATADIR%%/help/disconnect
+%%DATADIR%%/help/echo
+%%DATADIR%%/help/eval
+%%DATADIR%%/help/exec
+%%DATADIR%%/help/file
+%%DATADIR%%/help/format
+%%DATADIR%%/help/getkey
+%%DATADIR%%/help/help
+%%DATADIR%%/help/hilight
+%%DATADIR%%/help/ignore
+%%DATADIR%%/help/info
+%%DATADIR%%/help/invite
+%%DATADIR%%/help/invitelist
+%%DATADIR%%/help/join
+%%DATADIR%%/help/key
+%%DATADIR%%/help/kick
+%%DATADIR%%/help/kickban
+%%DATADIR%%/help/kill
+%%DATADIR%%/help/knockout
+%%DATADIR%%/help/lastlog
+%%DATADIR%%/help/layout
+%%DATADIR%%/help/levels
+%%DATADIR%%/help/list
+%%DATADIR%%/help/listkeys
+%%DATADIR%%/help/load
+%%DATADIR%%/help/log
+%%DATADIR%%/help/me
+%%DATADIR%%/help/motd
+%%DATADIR%%/help/mmsg
+%%DATADIR%%/help/msg
+%%DATADIR%%/help/names
+%%DATADIR%%/help/nick
+%%DATADIR%%/help/notice
+%%DATADIR%%/help/oper
+%%DATADIR%%/help/part
+%%DATADIR%%/help/perlflush
+%%DATADIR%%/help/ping
+%%DATADIR%%/help/query
+%%DATADIR%%/help/quit
+%%DATADIR%%/help/recode
+%%DATADIR%%/help/reconnect
+%%DATADIR%%/help/reload
+%%DATADIR%%/help/rmreconns
+%%DATADIR%%/help/rmrejoins
+%%DATADIR%%/help/save
+%%DATADIR%%/help/sconnect
+%%DATADIR%%/help/script
+%%DATADIR%%/help/scrollback
+%%DATADIR%%/help/server
+%%DATADIR%%/help/set
+%%DATADIR%%/help/shutdown
+%%DATADIR%%/help/silcnet
+%%DATADIR%%/help/silcoper
+%%DATADIR%%/help/smsg
+%%DATADIR%%/help/stats
+%%DATADIR%%/help/statusbar
+%%DATADIR%%/help/toggle
+%%DATADIR%%/help/topic
+%%DATADIR%%/help/umode
+%%DATADIR%%/help/unalias
+%%DATADIR%%/help/unignore
+%%DATADIR%%/help/unload
+%%DATADIR%%/help/unquery
+%%DATADIR%%/help/users
+%%DATADIR%%/help/version
+%%DATADIR%%/help/watch
+%%DATADIR%%/help/whois
+%%DATADIR%%/help/whowas
+%%DATADIR%%/help/window
+%%DATADIR%%/themes/default.theme
+%%DATADIR%%/themes/plugin.theme
+%%DATADIR%%/scripts/autoop.pl
+%%DATADIR%%/scripts/autorejoin.pl
+%%DATADIR%%/scripts/buf.pl
+%%DATADIR%%/scripts/command.pl
+%%DATADIR%%/scripts/dns.pl
+%%DATADIR%%/scripts/kills.pl
+%%DATADIR%%/scripts/mail.pl
+%%DATADIR%%/scripts/mlock.pl
+%%DATADIR%%/scripts/msg-event.pl
+%%DATADIR%%/scripts/quitmsg.pl
+%%DATADIR%%/scripts/redirect.pl
+%%DATADIR%%/scripts/scriptassist.pl
+%%DATADIR%%/scripts/silc.pl
+%%DATADIR%%/scripts/splitlong.pl
+%%DATADIR%%/scripts/usercount.pl
+@unexec if cmp -s %D/etc/silc.conf.sample %D/etc/silc.conf; then rm -f %D/etc/silc.conf; fi
+etc/silc.conf.sample
+@exec if [ ! -f %D/etc/silc.conf ] ; then cp -p %D/%F %B/silc.conf; fi
+@dirrm %%DATADIR%%/themes
+@dirrm %%DATADIR%%/help
+@dirrm %%DATADIR%%/scripts
+@dirrm %%DATADIR%%/modules
+@dirrm %%DATADIR%%
+@dirrm %%DOCSDIR%%