aboutsummaryrefslogtreecommitdiff
path: root/net/socks5/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/socks5/Makefile')
-rw-r--r--net/socks5/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/net/socks5/Makefile b/net/socks5/Makefile
new file mode 100644
index 000000000000..4a9172d98751
--- /dev/null
+++ b/net/socks5/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: socks5
+# Version required: beta-0.12
+# Date created: 24 Apr 1996
+# Whom: pst
+#
+# $Id$
+#
+
+PKGNAME= socks5-0.12
+DISTNAME= socks5-beta-0.12
+CATEGORIES+= net security
+MASTER_SITES= ftp://ftp.nec.com/pub/socks/socks5/
+
+NO_CDROM= NEC has a funky license for this software
+RESTRICTED= ITAR license required to export outside US/Canada
+NO_PACKAGE= put an extra slug in to make sure he's dead
+
+# here are some extra configure args you may wish to use
+# see the readme file before screwing with them
+#
+#EXTRA_CONFIGURE_ARGS= \
+# --with-default-server=socks.mydomain.com \
+# --with-syslog-facility=LOG_AUTH \
+# --with-passwd
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libconffile=${PREFIX}/etc/libsocks5.conf \
+ --with-srvconffile=${PREFIX}/etc/socks5.conf \
+ --with-srvpidfile=/var/run/socks5.pid \
+ --with-srvidtfile=/var/run/socks5.ident \
+ ${EXTRA_CONFIGURE_ARGS}
+
+.include <bsd.port.mk>