aboutsummaryrefslogtreecommitdiff
path: root/net/sshping
diff options
context:
space:
mode:
Diffstat (limited to 'net/sshping')
-rw-r--r--net/sshping/Makefile33
-rw-r--r--net/sshping/Makefile.201708160131
-rw-r--r--net/sshping/distinfo3
-rw-r--r--net/sshping/pkg-descr7
4 files changed, 74 insertions, 0 deletions
diff --git a/net/sshping/Makefile b/net/sshping/Makefile
new file mode 100644
index 000000000000..9ee2f8927766
--- /dev/null
+++ b/net/sshping/Makefile
@@ -0,0 +1,33 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sshping
+PORTVERSION= 0.0.2017081601
+CATEGORIES= net
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= SSH-based ping to measure character echo latency and bandwidth
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libssh.so:security/libssh
+
+USES= compiler:c++14-lang localbase:ldflags
+USE_GITHUB= yes
+
+GH_ACCOUNT= spook
+GH_TAGNAME= 0856aa5
+
+LDFLAGS+= -lssh
+
+PLIST_FILES= bin/sshping
+
+do-build:
+ ${CXX} ${CXXFLAGS} ${LDFLAGS} -I ${WRKSRC}/ext \
+ ${WRKSRC}/src/sshping.cxx -o ${WRKSRC}/bin/sshping
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/sshping/Makefile.2017081601 b/net/sshping/Makefile.2017081601
new file mode 100644
index 000000000000..d877cf2b2345
--- /dev/null
+++ b/net/sshping/Makefile.2017081601
@@ -0,0 +1,31 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sshping
+PORTVERSION= 0.0.2017081601
+CATEGORIES= net
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= SSH-based ping to measure character echo latency and bandwidth
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libssh.so:security/libssh
+
+USES= localbase:ldflags
+USE_GITHUB= yes
+
+GH_ACCOUNT= spook
+GH_TAGNAME= 0856aa5
+
+PLIST_FILES= bin/sshping
+
+do-build:
+ ${CXX} ${CXXFLAGS} ${LDFLAGS} -I ${WRKSRC}/ext ${WRKSRC}/src/sshping.cxx -lssh \
+ -o ${WRKSRC}/bin/sshping
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/sshping/distinfo b/net/sshping/distinfo
new file mode 100644
index 000000000000..b939e0c34932
--- /dev/null
+++ b/net/sshping/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1502887230
+SHA256 (spook-sshping-0.0.2017081601-0856aa5_GH0.tar.gz) = 41979f8a742048a875b2454900d49527e2e8e2156d32806301c3aab006edcfb4
+SIZE (spook-sshping-0.0.2017081601-0856aa5_GH0.tar.gz) = 3531961
diff --git a/net/sshping/pkg-descr b/net/sshping/pkg-descr
new file mode 100644
index 000000000000..4c87768b44d0
--- /dev/null
+++ b/net/sshping/pkg-descr
@@ -0,0 +1,7 @@
+Utility to test the performance of interactive ssh sessions or scp file
+transfers. It uses ssh to log into a remote system, then runs two tests: the
+first test sends one character at a time, waiting for each character to be
+returned while it records the latency time for each. The second test sends a
+dummy file over scp to /dev/null on the remote system.
+
+WWW: https://github.com/spook/sshping/