aboutsummaryrefslogtreecommitdiff
path: root/net/tcpproxy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/tcpproxy/Makefile')
-rw-r--r--net/tcpproxy/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/net/tcpproxy/Makefile b/net/tcpproxy/Makefile
new file mode 100644
index 000000000000..21573bd6e60b
--- /dev/null
+++ b/net/tcpproxy/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: tcpproxy
+# Date created: 2011-03-30
+# Whom: Alexander Hausner <alex@hugo.bmg.gv.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcpproxy
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= http://www.spreadspace.org/tcpproxy/releases/ \
+ http://alex.bmg.gv.at/programs/
+
+MAINTAINER= alex@hugo.bmg.gv.at
+COMMENT= A simple tcp connection proxy for ipv4 and ipv6
+
+BUILD_DEPENDS= ragel:${PORTSDIR}/devel/ragel
+
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+
+USERS= _tcpproxy
+GROUPS= _tcpproxy
+
+MAN8= tcpproxy.8
+
+USE_RC_SUBR= tcpproxy
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+
+PLIST_FILES= bin/tcpproxy etc/tcpproxy_sample.conf
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tcpproxy ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/contrib/example.conf ${PREFIX}/etc/tcpproxy_sample.conf
+ ${INSTALL_MAN} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/doc/${MAN8} ${PREFIX}/man/man8
+
+.include <bsd.port.mk>