aboutsummaryrefslogtreecommitdiff
path: root/net/tightvnc
diff options
context:
space:
mode:
Diffstat (limited to 'net/tightvnc')
-rw-r--r--net/tightvnc/Makefile41
-rw-r--r--net/tightvnc/distinfo1
-rw-r--r--net/tightvnc/files/patch-Imakefile12
-rw-r--r--net/tightvnc/files/patch-Xvnc::config::cf::vnclibs.def10
-rw-r--r--net/tightvnc/files/patch-Xvnc::config::imake::imakemdep.h21
-rw-r--r--net/tightvnc/files/patch-vncviewer::Imakefile15
-rw-r--r--net/tightvnc/pkg-comment1
-rw-r--r--net/tightvnc/pkg-descr10
-rw-r--r--net/tightvnc/pkg-plist22
9 files changed, 133 insertions, 0 deletions
diff --git a/net/tightvnc/Makefile b/net/tightvnc/Makefile
new file mode 100644
index 000000000000..20f4d775f5a8
--- /dev/null
+++ b/net/tightvnc/Makefile
@@ -0,0 +1,41 @@
+# ex:ts=8
+# New ports collection makefile for: vnc-tight
+# Date created: Nov 24, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= vnc-tight
+PORTVERSION= 1.2.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= tightvnc-${PORTVERSION}_unixsrc
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
+
+USE_BZIP2= yes
+WRKSRC= ${WRKDIR}/vnc_unixsrc
+USE_IMAKE= yes
+ALL_TARGET= World
+NO_INSTALL_MANPAGES= yes
+
+post-patch:
+.for file in vncviewer/Imakefile Xvnc/config/cf/vnclibs.def
+ @${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/${file}
+.endfor
+ @${PERL} -pi -e "s,/usr/local/vnc/classes,${DATADIR}/classes,g ; \
+ s,^#!/usr/bin/perl,#!${PERL},g" ${WRKSRC}/vncserver
+
+do-install:
+ @(cd ${WRKSRC}; ./vncinstall ${PREFIX}/bin)
+.for file in Xvnc vncviewer vncpasswd vncconnect
+ @strip ${PREFIX}/bin/${file}
+.endfor
+ @${MKDIR} ${DATADIR}
+ ${CP} -R ${WRKSRC}/classes ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/net/tightvnc/distinfo b/net/tightvnc/distinfo
new file mode 100644
index 000000000000..4cffe8104813
--- /dev/null
+++ b/net/tightvnc/distinfo
@@ -0,0 +1 @@
+MD5 (tightvnc-1.2.1_unixsrc.tar.bz2) = 6ab5f3d6a650792d519ba1f12fdde037
diff --git a/net/tightvnc/files/patch-Imakefile b/net/tightvnc/files/patch-Imakefile
new file mode 100644
index 000000000000..763d07c2d11b
--- /dev/null
+++ b/net/tightvnc/files/patch-Imakefile
@@ -0,0 +1,12 @@
+--- Imakefile.orig Sat Nov 24 16:41:40 2001
++++ Imakefile Sat Nov 24 16:42:20 2001
+@@ -9,8 +9,7 @@
+ make all
+ @echo ""
+ @echo Built $(SUBDIRS).
+- @echo 'To build Xvnc, do "cd Xvnc", followed by "make World"'
+- @echo ""
++ (cd Xvnc ; make World)
+
+ MakeSubdirs($(SUBDIRS))
+ DependSubdirs($(SUBDIRS))
diff --git a/net/tightvnc/files/patch-Xvnc::config::cf::vnclibs.def b/net/tightvnc/files/patch-Xvnc::config::cf::vnclibs.def
new file mode 100644
index 000000000000..5cb1c5ecbe36
--- /dev/null
+++ b/net/tightvnc/files/patch-Xvnc::config::cf::vnclibs.def
@@ -0,0 +1,10 @@
+--- Xvnc/config/cf/vnclibs.def.orig Tue Jan 30 05:24:14 2001
++++ Xvnc/config/cf/vnclibs.def Sat Nov 24 17:16:47 2001
+@@ -5,5 +5,5 @@
+ * and programs/Xserver/hw/vnc whenever you change this file.
+ */
+
+-VNCLIBS = $(TOP)/../libvncauth/libvncauth.a /usr/lib/libjpeg.a
+-VNCCPPFLAGS = -I$(TOP)/../include
++VNCLIBS = $(TOP)/../libvncauth/libvncauth.a %%LOCALBASE%%/lib/libjpeg.a
++VNCCPPFLAGS = -I$(TOP)/../include -I%%LOCALBASE%%/include
diff --git a/net/tightvnc/files/patch-Xvnc::config::imake::imakemdep.h b/net/tightvnc/files/patch-Xvnc::config::imake::imakemdep.h
new file mode 100644
index 000000000000..1aaeade24b1f
--- /dev/null
+++ b/net/tightvnc/files/patch-Xvnc::config::imake::imakemdep.h
@@ -0,0 +1,21 @@
+--- Xvnc/config/imake/imakemdep.h.orig Sat Nov 24 16:43:07 2001
++++ Xvnc/config/imake/imakemdep.h Sat Nov 24 16:44:48 2001
+@@ -225,6 +225,9 @@
+ #ifdef hpux
+ #define USE_CC_E
+ #endif
++#if defined(__FreeBSD__)
++#define USE_CC_E
++#endif
+ #ifdef WIN32
+ #define USE_CC_E
+ #define DEFAULT_CC "cl"
+@@ -253,7 +256,7 @@
+ #ifdef _CRAY
+ #define DEFAULT_CPP "/lib/pcpp"
+ #endif
+-#if defined(__386BSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__FreeBSD__)
++#if defined(__386BSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
+ #define DEFAULT_CPP "/usr/libexec/cpp"
+ #endif
+ #if defined(__sgi) && defined(__ANSI_CPP__)
diff --git a/net/tightvnc/files/patch-vncviewer::Imakefile b/net/tightvnc/files/patch-vncviewer::Imakefile
new file mode 100644
index 000000000000..e12c76004766
--- /dev/null
+++ b/net/tightvnc/files/patch-vncviewer::Imakefile
@@ -0,0 +1,15 @@
+--- vncviewer/Imakefile.orig Sat Nov 24 16:30:55 2001
++++ vncviewer/Imakefile Sat Nov 24 16:32:38 2001
+@@ -13,10 +13,10 @@
+ DEFINES = -DMITSHM
+ #endif
+
+-INCLUDES = -I../include -I. -I/usr/include
++INCLUDES = -I../include -I. -I/usr/include -I%%LOCALBASE%%/include
+ VNCAUTH_LIB = ../libvncauth/libvncauth.a
+ ZLIB_LIB = /usr/lib/libz.a
+-JPEG_LIB = /usr/lib/libjpeg.a
++JPEG_LIB = %%LOCALBASE%%/lib/libjpeg.a
+
+ DEPLIBS = XawClientDepLibs $(VNCAUTH_LIB) $(ZLIB_LIB) $(JPEG_LIB)
+ LOCAL_LIBRARIES = XawClientLibs $(VNCAUTH_LIB) $(ZLIB_LIB) $(JPEG_LIB)
diff --git a/net/tightvnc/pkg-comment b/net/tightvnc/pkg-comment
new file mode 100644
index 000000000000..b726221a8ee9
--- /dev/null
+++ b/net/tightvnc/pkg-comment
@@ -0,0 +1 @@
+Enhanced version of VNC
diff --git a/net/tightvnc/pkg-descr b/net/tightvnc/pkg-descr
new file mode 100644
index 000000000000..656fdbbd13e6
--- /dev/null
+++ b/net/tightvnc/pkg-descr
@@ -0,0 +1,10 @@
+Enhanced version of VNC, called TightVNC (grown from the VNC Tight Encoder
+project), which is optimized to work over slow network connections such as
+low-speed modem links. While original VNC may be very slow when your
+connection is not fast enough, with TightVNC you can work remotely almost
+in real time in most environments. Besides bandwidth optimizations,TightVNC
+also includes many other improvements, optimizations and bugfixes over VNC.
+Note that TightVNC is free, cross-platform and compatible with the standard
+VNC.
+
+WWW: http://www.tightvnc.com/
diff --git a/net/tightvnc/pkg-plist b/net/tightvnc/pkg-plist
new file mode 100644
index 000000000000..f1a62888c208
--- /dev/null
+++ b/net/tightvnc/pkg-plist
@@ -0,0 +1,22 @@
+bin/Xvnc
+bin/vncviewer
+bin/vncpasswd
+bin/vncserver
+bin/vncconnect
+share/vnc-tight/classes/DesCipher.class
+share/vnc-tight/classes/animatedMemoryImageSource.class
+share/vnc-tight/classes/authenticationPanel.class
+share/vnc-tight/classes/clipboardFrame.class
+share/vnc-tight/classes/hextile.vnc
+share/vnc-tight/classes/index.vnc
+share/vnc-tight/classes/noshared.vnc
+share/vnc-tight/classes/optionsFrame.class
+share/vnc-tight/classes/rfbProto.class
+share/vnc-tight/classes/shared.vnc
+share/vnc-tight/classes/vncCanvas.class
+share/vnc-tight/classes/vncviewer.class
+share/vnc-tight/classes/vncviewer.jar
+share/vnc-tight/classes/tight.vnc
+share/vnc-tight/classes/zlib.vnc
+@dirrm share/vnc-tight/classes
+@dirrm share/vnc-tight