aboutsummaryrefslogtreecommitdiff
path: root/net/tintin++-devel
diff options
context:
space:
mode:
Diffstat (limited to 'net/tintin++-devel')
-rw-r--r--net/tintin++-devel/Makefile20
-rw-r--r--net/tintin++-devel/distinfo1
-rw-r--r--net/tintin++-devel/files/patch-aa160
-rw-r--r--net/tintin++-devel/files/patch-ab175
-rw-r--r--net/tintin++-devel/pkg-comment1
-rw-r--r--net/tintin++-devel/pkg-descr6
-rw-r--r--net/tintin++-devel/pkg-plist3
7 files changed, 0 insertions, 366 deletions
diff --git a/net/tintin++-devel/Makefile b/net/tintin++-devel/Makefile
deleted file mode 100644
index 031748eb0dea..000000000000
--- a/net/tintin++-devel/Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
-# New ports collection makefile for: tintin++
-# Version required: 1.5pl6
-# Date created: 15 Nov 1994
-# Whom: ache
-#
-# $Id: Makefile,v 1.4 1995/04/15 05:41:59 asami Exp $
-#
-
-DISTNAME= tintin++v1.5pl6
-PKGNAME= tintin-1.5.6
-CATEGORIES+= networking games
-MASTER_SITES= ftp://princeton.edu/pub/tintin++/dist/
-EXTRACT_SUFX= .tar.Z
-
-MAINTAINER= ache@FreeBSD.ORG
-
-WRKSRC= ${WRKDIR}/tintin++/src
-GNU_CONFIGURE= yes
-
-.include <bsd.port.mk>
diff --git a/net/tintin++-devel/distinfo b/net/tintin++-devel/distinfo
deleted file mode 100644
index cf0255698251..000000000000
--- a/net/tintin++-devel/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (tintin++v1.5pl6.tar.Z) = 35e53d661606d035c3e92a249e44160f
diff --git a/net/tintin++-devel/files/patch-aa b/net/tintin++-devel/files/patch-aa
deleted file mode 100644
index 76295f0429c0..000000000000
--- a/net/tintin++-devel/files/patch-aa
+++ /dev/null
@@ -1,160 +0,0 @@
-*** Makefile.in.orig Fri Sep 9 19:35:20 1994
---- Makefile.in Tue Nov 15 02:07:48 1994
-***************
-*** 10,17 ****
- # try uncommenting the 'gcc' line and commenting the 'cc' one.
- # Tintin++ doesn't *need* an ANSI compiler anymore, but gcc
- # is still better than cc on many platforms...
-! CC = @CC@ -O
-! CFLAGS = @DEFS@
- LIBS = @LIBS@
- PIPE = @PIPE@
- # If you plan on doing debugging (with gdb), it is very helpful to turn all
---- 10,16 ----
- # try uncommenting the 'gcc' line and commenting the 'cc' one.
- # Tintin++ doesn't *need* an ANSI compiler anymore, but gcc
- # is still better than cc on many platforms...
-! CFLAGS += @DEFS@
- LIBS = @LIBS@
- PIPE = @PIPE@
- # If you plan on doing debugging (with gdb), it is very helpful to turn all
-***************
-*** 22,31 ****
-
- # BINDIR is the directory you wish tt++ to be placed if you wish to use
- # make install.
-! BINDIR = ..
-
- # DEFAULT_FILE_DIR is the path to tintin files.
-! DEFAULT_FILE_DIR = @HOME@
-
- #########################################
- # You shouldn't need to change anything #
---- 21,30 ----
-
- # BINDIR is the directory you wish tt++ to be placed if you wish to use
- # make install.
-! BINDIR = /usr/local/bin
-
- # DEFAULT_FILE_DIR is the path to tintin files.
-! DEFAULT_FILE_DIR = /usr/local/lib/tintin
-
- #########################################
- # You shouldn't need to change anything #
-***************
-*** 41,54 ****
- variables.c highlight.c antisub.c ivars.c help.c text.c glob.c
- OFILES = $(CFILES:.c=.o)
-
-! all: tintin++ install
-
- tintin++: $(OFILES) tintin.h
- @echo "Linking..."
- $(CC) $(CFLAGS) $(FFLAGS) $(LFLAGS) -o tt++ $(OFILES) $(LIBS)
-
-! install: all
-! @./install.sh $(BINDIR) $(DEFAULT_FILE_DIR) $(COMPRESSED_HELP)
-
- # Autocompile all .c files into .o files using this rule:
- .c.o:
---- 40,54 ----
- variables.c highlight.c antisub.c ivars.c help.c text.c glob.c
- OFILES = $(CFILES:.c=.o)
-
-! all: tintin++
-
- tintin++: $(OFILES) tintin.h
- @echo "Linking..."
- $(CC) $(CFLAGS) $(FFLAGS) $(LFLAGS) -o tt++ $(OFILES) $(LIBS)
-
-! install:
-! @mkdir -p $(DEFAULT_FILE_DIR)
-! @./install.sh $(BINDIR) $(DEFAULT_FILE_DIR) Ok
-
- # Autocompile all .c files into .o files using this rule:
- .c.o:
-*** configure.old Sun Aug 28 14:06:38 1994
---- configure Tue Nov 15 01:42:46 1994
-***************
-*** 474,489 ****
- OLD_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS -pipe"
-
-! echo "Do you want the helpfile to be compressed (yes/no)? "
-! read YESNO
-! if test $YESNO; then
-! if echo "$YESNO"|grep -i "no" >/dev/null; then
-! DEFS="$DEFS -DCOMPRESSED_HELP=0"
-! else
-! DEFS="$DEFS -DCOMPRESSED_HELP=1"
-! COMPRESSED_HELP="Ok"
-! fi
-! fi
-
- test -n "$silent" || echo "checking for -pipe"
- cat > conftest.${ac_ext} <<EOF
---- 474,492 ----
- OLD_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS -pipe"
-
-! DEFS="$DEFS -DCOMPRESSED_HELP=1"
-! COMPRESSED_HELP="Ok"
-!
-! #echo "Do you want the helpfile to be compressed (yes/no)? "
-! #read YESNO
-! #if test $YESNO; then
-! # if echo "$YESNO"|grep -i "no" >/dev/null; then
-! # DEFS="$DEFS -DCOMPRESSED_HELP=0"
-! # else
-! # DEFS="$DEFS -DCOMPRESSED_HELP=1"
-! # COMPRESSED_HELP="Ok"
-! # fi
-! #fi
-
- test -n "$silent" || echo "checking for -pipe"
- cat > conftest.${ac_ext} <<EOF
-***************
-*** 854,860 ****
- :;
- fi
-
-! for ac_func in bcopy
- do
- ac_tr_func=HAVE_`echo $ac_func | tr '[a-z]' '[A-Z]'`
- test -n "$silent" || echo "checking for ${ac_func}"
---- 857,863 ----
- :;
- fi
-
-! for ac_func in
- do
- ac_tr_func=HAVE_`echo $ac_func | tr '[a-z]' '[A-Z]'`
- test -n "$silent" || echo "checking for ${ac_func}"
-*** install.sh.old Fri Sep 9 05:43:26 1994
---- install.sh Tue Nov 15 02:05:24 1994
-***************
-*** 5,16 ****
-
- echo " "
- echo "Copying the tintin++ executable to \"$1\"..."
-! strip tt++
-! cp tt++ "$1"
-
- echo "Copying the tintin++ help file to \"$2\"..."
- if [ "$3" ]; then
-! cp support/.tt_help.txt.Z "$2/"
- else
- echo Uncompressing.
- uncompress -c support/.tt_help.txt.Z | cat > "$2"/.tt_help.txt
---- 5,15 ----
-
- echo " "
- echo "Copying the tintin++ executable to \"$1\"..."
-! install -c -s -o bin -g bin -m 555 tt++ "$1"
-
- echo "Copying the tintin++ help file to \"$2\"..."
- if [ "$3" ]; then
-! install -c -o bin -g bin -m 444 support/.tt_help.txt.Z "$2"
- else
- echo Uncompressing.
- uncompress -c support/.tt_help.txt.Z | cat > "$2"/.tt_help.txt
diff --git a/net/tintin++-devel/files/patch-ab b/net/tintin++-devel/files/patch-ab
deleted file mode 100644
index c6a4eb4d7eea..000000000000
--- a/net/tintin++-devel/files/patch-ab
+++ /dev/null
@@ -1,175 +0,0 @@
-*** utils.c.old Sun Aug 28 18:12:16 1994
---- utils.c Tue Nov 15 01:58:20 1994
-***************
-*** 21,26 ****
---- 21,28 ----
- #include <unistd.h>
- #endif
-
-+ #include <sys/param.h>
-+
- void syserr();
-
- /*********************************************/
-***************
-*** 56,62 ****
---- 58,66 ----
- char *msg;
- {
- extern int errno, sys_nerr;
-+ #if !defined(BSD) || (BSD < 199306)
- extern char *sys_errlist[];
-+ #endif
-
- fprintf(stderr,"ERROR: %s (%d",msg, errno);
- if(errno>0 && errno<sys_nerr)
-*** parse.c.bak Sun Aug 28 18:12:10 1994
---- parse.c Tue Nov 15 02:21:20 1994
-***************
-*** 670,679 ****
- if(ses && !PSEUDO_PROMPT)
- write_line_mud("", ses);
- else if (!is_split)
-! write(1,"> ", 3);
- else {
- sprintf(strng,"8> 7[%d;%df", input_row, input_col);
-! write(1,strng, strlen(strng)+1);
- display_col+=2;
- }
- }
---- 670,679 ----
- if(ses && !PSEUDO_PROMPT)
- write_line_mud("", ses);
- else if (!is_split)
-! write(1,"> ", 2);
- else {
- sprintf(strng,"8> 7[%d;%df", input_row, input_col);
-! write(1,strng, strlen(strng));
- display_col+=2;
- }
- }
-*** misc.c.bak Sun Aug 28 18:12:08 1994
---- misc.c Tue Nov 15 02:28:26 1994
-***************
-*** 106,112 ****
- char temp[2];
- temp[0]=7;
- temp[1]=0;
-! write(1, temp, 2);
- }
-
-
---- 106,112 ----
- char temp[2];
- temp[0]=7;
- temp[1]=0;
-! write(1, temp, 1);
- }
-
-
-***************
-*** 172,178 ****
- cleanup_session(sesptr);
- ses=NULL;
- if (is_split)
-! write(1, "c", 3);
- tintin_puts2("TINTIN suffers from bloodlack, and the lack of a beating heart...", ses);
- tintin_puts2("TINTIN is dead! R.I.P.", ses);
- tintin_puts2("Your blood freezes as you hear TINTIN's death cry.", ses);
---- 172,178 ----
- cleanup_session(sesptr);
- ses=NULL;
- if (is_split)
-! write(1, "c", 2);
- tintin_puts2("TINTIN suffers from bloodlack, and the lack of a beating heart...", ses);
- tintin_puts2("TINTIN is dead! R.I.P.", ses);
- tintin_puts2("Your blood freezes as you hear TINTIN's death cry.", ses);
-*** main.c.bak Sun Aug 28 18:12:06 1994
---- main.c Tue Nov 15 02:33:37 1994
-***************
-*** 562,568 ****
- if(ses->logfile) {
- if (!OLD_LOG) {
- count=0;
-! for(n=0;n<=didget;n++)
- if (buffer[n]!='\r') {
- temp[count]=buffer[n];
- count++;
---- 562,568 ----
- if(ses->logfile) {
- if (!OLD_LOG) {
- count=0;
-! for(n=0;n<didget;n++)
- if (buffer[n]!='\r') {
- temp[count]=buffer[n];
- count++;
-***************
-*** 732,738 ****
- sprintf(strng,"%c8%s\n\r%c7%c[%d;%df", E, cptr, E, E, input_row, input_col);
- else
- sprintf(strng,"%s\n\r", cptr);
-! write(1,strng, strlen(strng)+1);
- display_col=1;
- if (redraw && term_echoing && !is_split)
- write(1, k_input, strlen(k_input));
---- 732,738 ----
- sprintf(strng,"%c8%s\n\r%c7%c[%d;%df", E, cptr, E, E, input_row, input_col);
- else
- sprintf(strng,"%s\n\r", cptr);
-! write(1,strng, strlen(strng));
- display_col=1;
- if (redraw && term_echoing && !is_split)
- write(1, k_input, strlen(k_input));
-***************
-*** 764,770 ****
- cptr++;
- sprintf(strng,"%s\n\r", cptr);
- }
-! write(1,strng, strlen(strng)+1);
- display_col=1;
- }
- text_came=TRUE;
---- 764,770 ----
- cptr++;
- sprintf(strng,"%s\n\r", cptr);
- }
-! write(1,strng, strlen(strng));
- display_col=1;
- }
- text_came=TRUE;
-***************
-*** 832,838 ****
- input_col=1;
- sprintf(fn, "%c[2J%c[1;%dr%c[%d;1f", E, E, display_row, E, split_line);
- write(1,fn, strlen(fn));
-! write(1,"-------------------------------------------------------------------------------", 80);
- sprintf(fn, "%c[%d;1f%c7", E, split_line-1, E);
- write(1,fn,strlen(fn));
- sprintf(fn, "%c[%d;1f", E, input_row);
---- 832,838 ----
- input_col=1;
- sprintf(fn, "%c[2J%c[1;%dr%c[%d;1f", E, E, display_row, E, split_line);
- write(1,fn, strlen(fn));
-! write(1,"--------------------------------------------------------------------------------", 80);
- sprintf(fn, "%c[%d;1f%c7", E, split_line-1, E);
- write(1,fn,strlen(fn));
- sprintf(fn, "%c[%d;1f", E, input_row);
-*** net.c.bak Sun Aug 28 18:12:10 1994
---- net.c Tue Nov 15 03:27:09 1994
-***************
-*** 80,86 ****
-
- tintin_puts("#Trying to connect..", ses);
-
-! alarm(15); /* We'll allow connect to hang in 15seconds! NO MORE! */
- ticker_interrupted=FALSE;
- connectresult=connect(sock, (struct sockaddr *)&sockaddr, sizeof(sockaddr));
- #if defined(DEBUG)
---- 80,86 ----
-
- tintin_puts("#Trying to connect..", ses);
-
-! alarm(30); /* We'll allow connect to hang in 30seconds! NO MORE! */
- ticker_interrupted=FALSE;
- connectresult=connect(sock, (struct sockaddr *)&sockaddr, sizeof(sockaddr));
- #if defined(DEBUG)
diff --git a/net/tintin++-devel/pkg-comment b/net/tintin++-devel/pkg-comment
deleted file mode 100644
index 92f988ed40d1..000000000000
--- a/net/tintin++-devel/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-TINTIN++ v1.5pl6 is a client program to help playing muds.
diff --git a/net/tintin++-devel/pkg-descr b/net/tintin++-devel/pkg-descr
deleted file mode 100644
index a7d66ff3c745..000000000000
--- a/net/tintin++-devel/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
- TINTIN++ is a client program specialized to help playing muds.
- This is a souped up version of TINTIN III, many new features
- have been added since III. We saw room for improvement on the
- features available from TINTIN, and since we like the format of
- the program, we decided to use TINTIN as a base for what we
- hope to make one of the most powerful clients around.
diff --git a/net/tintin++-devel/pkg-plist b/net/tintin++-devel/pkg-plist
deleted file mode 100644
index 96dcef4e76e5..000000000000
--- a/net/tintin++-devel/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-@cwd /usr/local
-bin/tt++
-lib/tintin