aboutsummaryrefslogtreecommitdiff
path: root/net/tn3270/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/tn3270/Makefile')
-rw-r--r--net/tn3270/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/net/tn3270/Makefile b/net/tn3270/Makefile
index 5e3d01d9ba14..96d8b779436d 100644
--- a/net/tn3270/Makefile
+++ b/net/tn3270/Makefile
@@ -19,6 +19,17 @@ MAN1= tn3270.1 mset.1
MAN5= map3270.5
MANCOMPRESSED= maybe
+LIBTELNETDIR?= /usr/src/lib/libtelnet
+
+post-extract:
+ @if [ ! -d ${LIBTELNETDIR} ]; then \
+ ${ECHO} "You need libtelnet sources in"; \
+ ${ECHO} "${LIBTELNETDIR}"; \
+ ${ECHO} "to build this port."; \
+ exit 1; \
+ fi
+ ${CP} -rp ${LIBTELNETDIR} ${WRKSRC}
+
do-configure:
${ECHO} "BINDIR= ${PREFIX}/bin" > ${WRKDIR}/Makefile.inc
${ECHO} "MANDIR= ${PREFIX}/man/man" >> ${WRKDIR}/Makefile.inc