aboutsummaryrefslogtreecommitdiff
path: root/net/torsocks/files
diff options
context:
space:
mode:
Diffstat (limited to 'net/torsocks/files')
-rw-r--r--net/torsocks/files/patch-Makefile.am21
-rw-r--r--net/torsocks/files/patch-configure.in70
-rw-r--r--net/torsocks/files/patch-torsocks.in37
-rw-r--r--net/torsocks/files/patch-tsocks.c11
-rw-r--r--net/torsocks/files/patch-usewithtor.in16
-rw-r--r--net/torsocks/files/pkg-message.in12
6 files changed, 167 insertions, 0 deletions
diff --git a/net/torsocks/files/patch-Makefile.am b/net/torsocks/files/patch-Makefile.am
new file mode 100644
index 000000000000..c23f3dbe80b3
--- /dev/null
+++ b/net/torsocks/files/patch-Makefile.am
@@ -0,0 +1,21 @@
+--- src/Makefile.am.orig 2009-02-07 11:48:12.000000000 +0100
++++ src/Makefile.am 2009-02-18 17:29:26.000000000 +0100
+@@ -1,7 +1,7 @@
+ # Makefile used by configure to create real Makefile
+
+-LIBS = -ldl -lc -lresolv
+-libdir = @prefix@/lib/torsocks
++LIBS = -lc
++libdir = @prefix@/lib
+
+ # Install helper programs
+ #bin_PROGRAMS = validateconf inspectsocks saveme
+@@ -16,7 +16,7 @@
+
+ # Install configuration file
+ usewithtorconfdir = $(CONFDIR)/
+-usewithtorconf_DATA = torsocks.conf
++usewithtorconf_DATA = torsocks.conf.sample
+
+ # Install invocation scripts
+ bin_SCRIPTS = torsocks usewithtor
diff --git a/net/torsocks/files/patch-configure.in b/net/torsocks/files/patch-configure.in
new file mode 100644
index 000000000000..17953f5bc85a
--- /dev/null
+++ b/net/torsocks/files/patch-configure.in
@@ -0,0 +1,70 @@
+--- configure.in.orig 2009-02-12 15:59:50.000000000 +0200
++++ configure.in 2009-02-12 17:27:16.000000000 +0200
+@@ -123,11 +123,9 @@
+ dnl Checks for libraries.
+ dnl Replace `main' with a function in -ldl:
+
+-AC_CHECK_LIB(dl, dlsym, [ tempdso="yes" ],tempdso="no")
+-if test "$tempdso" = "no"; then
+- AC_CHECK_LIB(c, dlsym,,AC_MSG_ERROR("dlsym() not found in libc or libdl." \
+- "Check your system for libc.so and/or libdl.so."))
+-fi
++dnl Checks for libraries.
++AC_CHECK_LIB(c, dlsym,,AC_MSG_ERROR(""dlsym() not found in libc." \
++ "Check your system for libc.so."))
+
+ AC_CHECK_LIB(resolv, res_query, [ tempres="no" ],tempres="yes")
+ if test "$tempres" = "no"; then
+@@ -356,8 +354,8 @@
+ dnl Find the correct res_querydomain prototype on this machine
+ AC_MSG_CHECKING(for correct res_querydomain prototype)
+ PROTO=
+-PROTO1='const char *name, const char *domain, int class, int type, unsigned char *answer, int anslen'
+-for testproto in "${PROTO1}"
++PROTO1='const char *name, const char *domain, int class, int type, u_char *answer, int anslen'
++for PROTO in "${PROTO1}"
+ do
+ if test "${PROTO}" = ""; then
+ AC_TRY_COMPILE([
+@@ -376,8 +374,8 @@
+ AC_MSG_CHECKING(for correct res_send prototype)
+ PROTO=
+ PROTO1='const char *msg, int msglen, char *answer, int anslen'
+-PROTO2='const unsigned char *msg, int msglen, unsigned char *answer, int anslen'
+-for testproto in "${PROTO1}" \
++PROTO2='const u_char *msg, int msglen, u_char *answer, int anslen'
++for PROTO in "${PROTO1}" \
+ "${PROTO2}"
+ do
+ if test "${PROTO}" = ""; then
+@@ -397,8 +395,8 @@
+ dnl Find the correct res_search prototype on this machine
+ AC_MSG_CHECKING(for correct res_search prototype)
+ PROTO=
+-PROTO1='const char *dname, int class, int type,unsigned char *answer, int anslen'
+-for testproto in "${PROTO1}"
++PROTO1='const char *dname, int class, int type, u_char *answer, int anslen'
++for PROTO in "${PROTO1}"
+ do
+ if test "${PROTO}" = ""; then
+ AC_TRY_COMPILE([
+@@ -417,8 +415,8 @@
+ dnl Find the correct res_query prototype on this machine
+ AC_MSG_CHECKING(for correct res_query prototype)
+ PROTO=
+-PROTO1='const char *dname, int class, int type,unsigned char *answer, int anslen'
+-for testproto in "${PROTO1}"
++PROTO1='const char *dname, int class, int type, u_char *answer, int anslen'
++for PROTO in "${PROTO1}"
+ do
+ if test "${PROTO}" = ""; then
+ AC_TRY_COMPILE([
+@@ -462,7 +460,7 @@
+ dnl Find the correct poll prototype on this machine
+ AC_MSG_CHECKING(for correct poll prototype)
+ PROTO=
+-for testproto in 'struct pollfd *ufds, unsigned long nfds, int timeout' \
++for testproto in 'struct pollfd *ufds, u_long nfds, int timeout' \
+ 'struct pollfd *ufds, nfds_t nfds, int timeout'
+ do
+ if test "${PROTO}" = ""; then
diff --git a/net/torsocks/files/patch-torsocks.in b/net/torsocks/files/patch-torsocks.in
new file mode 100644
index 000000000000..6d7bc6ed8aaf
--- /dev/null
+++ b/net/torsocks/files/patch-torsocks.in
@@ -0,0 +1,37 @@
+--- src/torsocks.in.orig 2008-12-08 23:43:55.000000000 +0200
++++ src/torsocks.in 2009-03-01 22:31:16.263795616 +0200
+@@ -72,16 +72,16 @@
+ on)
+ if [ -z "$LD_PRELOAD" ]
+ then
+- export LD_PRELOAD="@prefix@/lib/torsocks/libtorsocks.so"
++ export LD_PRELOAD="@prefix@/lib/libtorsocks.so"
+ else
+- echo $LD_PRELOAD | grep -q "@prefix@/lib/torsocks/libtorsocks\.so" || \
+- export LD_PRELOAD="@prefix@/lib/torsocks/libtorsocks.so $LD_PRELOAD"
++ echo $LD_PRELOAD | grep -q "@prefix@/lib/libtorsocks\.so" || \
++ export LD_PRELOAD="@prefix@/lib/libtorsocks.so $LD_PRELOAD"
+ fi
+ ;;
+ off)
+ #replace '/' with '\/' in @prefix@
+ escprefix=`echo '@prefix@' |sed 's/\\//\\\\\//g'`
+- export LD_PRELOAD=`echo -n $LD_PRELOAD | sed "s/$escprefix\/lib\/torsocks\/libtorsocks.so \?//"`
++ export LD_PRELOAD=`echo -n $LD_PRELOAD | sed "s/$escprefix\/lib\/libtorsocks.so \?//"`
+ if [ -z "$LD_PRELOAD" ]
+ then
+ unset LD_PRELOAD
+@@ -96,10 +96,10 @@
+ *)
+ if [ -z "$LD_PRELOAD" ]
+ then
+- export LD_PRELOAD="@prefix@/lib/torsocks/libtorsocks.so"
++ export LD_PRELOAD="@prefix@/lib/libtorsocks.so"
+ else
+- echo $LD_PRELOAD | grep -q "@prefix@/lib/torsocks/libtorsocks\.so" || \
+- export LD_PRELOAD="@prefix@/lib/torsocks/libtorsocks.so $LD_PRELOAD"
++ echo $LD_PRELOAD | grep -q "@prefix@/lib/libtorsocks\.so" || \
++ export LD_PRELOAD="@prefix@/lib/libtorsocks.so $LD_PRELOAD"
+ fi
+
+ if [ $# = 0 ]
diff --git a/net/torsocks/files/patch-tsocks.c b/net/torsocks/files/patch-tsocks.c
new file mode 100644
index 000000000000..5cdbab984160
--- /dev/null
+++ b/net/torsocks/files/patch-tsocks.c
@@ -0,0 +1,11 @@
+--- src/tsocks.c.orig 2009-02-12 15:59:50.000000000 +0200
++++ src/tsocks.c 2009-02-12 23:18:14.870533468 +0200
+@@ -164,7 +164,7 @@
+ void tsocks_init(void) {
+
+ #define LOAD_ERROR(s,l) { \
+- char *error; \
++ const char *error; \
+ error = dlerror(); \
+ show_msg(l, "The symbol %s() was not found in any shared " \
+ "library. The error reported was: %s!\n", s, \
diff --git a/net/torsocks/files/patch-usewithtor.in b/net/torsocks/files/patch-usewithtor.in
new file mode 100644
index 000000000000..71da1270906f
--- /dev/null
+++ b/net/torsocks/files/patch-usewithtor.in
@@ -0,0 +1,16 @@
+--- src/usewithtor.in.orig 2009-02-12 15:59:50.000000000 +0200
++++ src/usewithtor.in 2009-02-12 19:49:41.000000000 +0200
+@@ -1,3 +1,5 @@
++#!/bin/sh
++#
+ # ***************************************************************************
+ # * *
+ # * $Id: usewithtor.in,v 1.3 2008-07-06 15:17:35 hoganrobert Exp $*
+@@ -26,7 +28,6 @@
+ # ***************************************************************************
+
+
+-#! /bin/sh
+
+ # Wrapper script for use of the torsocks(8) transparent socksification library
+ # See the torsocks(1) and usewithtor(1) manpages.
diff --git a/net/torsocks/files/pkg-message.in b/net/torsocks/files/pkg-message.in
new file mode 100644
index 000000000000..81434dee0c78
--- /dev/null
+++ b/net/torsocks/files/pkg-message.in
@@ -0,0 +1,12 @@
+Simple setup file was copied to %%PREFIX%%/etc/torsocks.conf.sample
+An example of a more complex setup file can be found in
+%%PREFIX%%/share/examples/torsocks/
+
+Once you have installed torsocks, just launch it like so:
+ usewithtor [application]
+
+So, for example you can use ssh to a some.ssh.com by doing:
+ usewithtor ssh username@some.ssh.com -l <user>
+
+or launch pidgin by doing:
+ usewithtor pidgin