aboutsummaryrefslogtreecommitdiff
path: root/net/transmission/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/transmission/Makefile')
-rw-r--r--net/transmission/Makefile68
1 files changed, 0 insertions, 68 deletions
diff --git a/net/transmission/Makefile b/net/transmission/Makefile
deleted file mode 100644
index 9128f90d8cc5..000000000000
--- a/net/transmission/Makefile
+++ /dev/null
@@ -1,68 +0,0 @@
-# New ports collection makefile for: transmission
-# Date created: 08 October 2005
-# Whom: Mezz <mezz@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= transmission
-PORTVERSION= 0.4
-CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_LOCAL} \
- http://download.m0k.org/${PORTNAME}/files/
-MASTER_SITE_SUBDIR=mezz
-DISTNAME= Transmission-${PORTVERSION}
-
-MAINTAINER= mezz@FreeBSD.org
-COMMENT= A free BitTorrent client written from scratch in C
-
-BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
-
-CFLAGS+= -Wall -W ${CPPFLAGS}
-USE_REINPLACE= yes
-HAS_CONFIGURE= yes
-USE_GETOPT_LONG=yes
-
-EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude macosx \
- --exclude packageOSX.sh
-
-PLIST_FILES= bin/transmissioncli
-PORTDOCS= AUTHORS LICENSE NEWS README
-
-.if defined(WITHOUT_OPENSSL)
-CONFIGURE_ARGS+=--disable-openssl
-.else
-USE_OPENSSL= yes
-CONFIGURE_ARGS+=--openssl-prefix=${OPENSSLBASE}
-.endif
-
-pre-everything::
-.if !defined(WITHOUT_OPENSSL)
- @${ECHO_MSG} "You may specify the following on the command line:"
- @${ECHO_MSG} " "
-.endif
-.if !defined(WITHOUT_OPENSSL)
- @${ECHO_MSG} "WITHOUT_OPENSSL=yes to disable OpenSSL support, using built-in SHA1 implementation. Warning, it is a bit slower if you use this option." | ${FMT} 75 75
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
- s|$$LINKLIBS ;|${LDFLAGS} $$LINKLIBS ;|g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-O3||g' \
- ${WRKSRC}/Jamrules
-
-# jam -dx, it will giving a verbose of build.
-do-build:
- @(cd ${BUILD_WRKSRC} ; ${SETENV} ${MAKE_ENV} jam -dx)
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/transmissioncli ${PREFIX}/bin/
-.ifndef (NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.mk>