aboutsummaryrefslogtreecommitdiff
path: root/net/twinkle
diff options
context:
space:
mode:
Diffstat (limited to 'net/twinkle')
-rw-r--r--net/twinkle/Makefile61
-rw-r--r--net/twinkle/distinfo2
-rw-r--r--net/twinkle/files/patch-src-call_script.cpp33
-rw-r--r--net/twinkle/files/patch-src-parser_parser.yxx11
-rw-r--r--net/twinkle/files/patch-src-threads_mutex.cpp11
-rw-r--r--net/twinkle/files/patch-src_address_book.h12
-rw-r--r--net/twinkle/files/pkg-message.in15
-rw-r--r--net/twinkle/pkg-descr7
-rw-r--r--net/twinkle/pkg-plist15
9 files changed, 0 insertions, 167 deletions
diff --git a/net/twinkle/Makefile b/net/twinkle/Makefile
deleted file mode 100644
index 188589f2d170..000000000000
--- a/net/twinkle/Makefile
+++ /dev/null
@@ -1,61 +0,0 @@
-# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= twinkle
-PORTVERSION= 1.4.2
-PORTREVISION= 9
-CATEGORIES= net
-MASTER_SITES= http://mfnboer.home.xs4all.nl/twinkle/download/
-
-MAINTAINER= acm@FreeBSD.org
-COMMENT= Soft phone for your VoIP communications using the SIP protocol
-
-BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
-LIB_DEPENDS= ccgnu2:${PORTSDIR}/devel/commoncpp \
- ccrtp:${PORTSDIR}/devel/ccrtp \
- sndfile.1:${PORTSDIR}/audio/libsndfile \
- boost_regex:${PORTSDIR}/devel/boost-libs \
- speex.1:${PORTSDIR}/audio/speex \
- ilbc.0:${PORTSDIR}/net/ilbc \
- zrtpcpp:${PORTSDIR}/devel/libzrtpcpp
-
-GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libtool
-USES= bison
-USE_XORG= xext
-USE_GMAKE= yes
-USE_GNOME= libxml2
-USE_PERL5= yes
-USE_QT_VER= 3
-
-OPTIONS_DEFINE= KDE
-KDE_DESC= Compile with kde3 features
-
-CONFIGURE_ARGS= --with-qt-dir=${QT_PREFIX} QTDIR=${LOCALBASE}
-CONFIGURE_ENV= QMAKESPEC="${QMAKESPEC}"
-MAKE_ENV= QTDIR=${QT_PREFIX}
-SUB_FILES= pkg-message
-
-QMAKESPEC?= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MKDE}
-USE_KDELIBS_VER=3
-.else
-CONFIGURE_ARGS+=--without-kde
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-lresolv||g' -e 's|-lbind||g' \
- -e 's|libccrtp1|libccrtp|g' ${WRKSRC}/${CONFIGURE_SCRIPT}
- @${REINPLACE_CMD} -e 's|localtime_r|ost::localtime_r|g' \
- ${WRKSRC}/src/log.cpp
-
-post-configure:
- @${REINPLACE_CMD} -e 's|-lresolv||g' ${WRKSRC}/src/gui/${MAKEFILE}
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>
diff --git a/net/twinkle/distinfo b/net/twinkle/distinfo
deleted file mode 100644
index 5b3a0584afea..000000000000
--- a/net/twinkle/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (twinkle-1.4.2.tar.gz) = 807686c7ac1b54bb0ea27ff4be362db6926d1d3d6f1802f6d359a353157e89a5
-SIZE (twinkle-1.4.2.tar.gz) = 1601100
diff --git a/net/twinkle/files/patch-src-call_script.cpp b/net/twinkle/files/patch-src-call_script.cpp
deleted file mode 100644
index cbbdfe1cffbb..000000000000
--- a/net/twinkle/files/patch-src-call_script.cpp
+++ /dev/null
@@ -1,33 +0,0 @@
---- src/call_script.cpp Wed Jul 12 13:20:34 2006
-+++ src/call_script.cpp Wed Jul 12 13:23:34 2006
-@@ -46,6 +46,8 @@
- #define SCR_TRIGGER_LOCAL_RELEASE "local_release"
- #define SCR_TRIGGER_REMOTE_RELEASE "remote_release"
-
-+extern char **environ;
-+
- /////////////////////////
- // class t_script_result
- /////////////////////////
-@@ -324,14 +326,16 @@
- }
-
- char *line_buf = NULL;
-- size_t line_buf_len = 0;
-- ssize_t num_read;
-+ char *num_read;
-+ int line_buf_len;
-+ int count=0;
-
- // Read and parse script results.
-- while ((num_read = getline(&line_buf, &line_buf_len, fp_result)) != -1) {
-+ while ((num_read = fgets(line_buf, sizeof(line_buf), fp_result)) != NULL) {
-+ count++;
- // Strip newline if present
-- if (line_buf[num_read - 1] == '\n') {
-- line_buf[num_read - 1] = 0;
-+ if (line_buf[count - 1] == '\n') {
-+ line_buf[count - 1] = 0;
- }
-
- // Convert the read line to a C++ string
diff --git a/net/twinkle/files/patch-src-parser_parser.yxx b/net/twinkle/files/patch-src-parser_parser.yxx
deleted file mode 100644
index e59c7a67aa4d..000000000000
--- a/net/twinkle/files/patch-src-parser_parser.yxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/parser/parser.yxx 2007-11-11 13:43:28.000000000 -0500
-+++ src/parser/parser.yxx 2007-11-11 13:44:00.000000000 -0500
-@@ -48,7 +48,7 @@
-
- %union {
- int yyt_int;
-- ulong yyt_ulong;
-+ u_long yyt_ulong;
- float yyt_float;
- string *yyt_str;
- t_parameter *yyt_param;
diff --git a/net/twinkle/files/patch-src-threads_mutex.cpp b/net/twinkle/files/patch-src-threads_mutex.cpp
deleted file mode 100644
index eef9edb7e50f..000000000000
--- a/net/twinkle/files/patch-src-threads_mutex.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/threads/mutex.cpp Sat Apr 22 21:09:20 2006
-+++ src/threads/mutex.cpp Sat Apr 22 21:08:41 2006
-@@ -35,7 +35,7 @@
- pthread_mutexattr_init(&attr);
-
-
-- int ret = pthread_mutexattr_settype(&attr, PTHREAD_MUTEX_RECURSIVE_NP);
-+ int ret = pthread_mutexattr_settype(&attr, PTHREAD_MUTEX_RECURSIVE);
- if (ret != 0) throw string(
- "t_mutex::t_mutex failed to create a recursive mutex.");
-
diff --git a/net/twinkle/files/patch-src_address_book.h b/net/twinkle/files/patch-src_address_book.h
deleted file mode 100644
index 4e180dd77d96..000000000000
--- a/net/twinkle/files/patch-src_address_book.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/address_book.h 2007-11-11 13:35:53.000000000 -0500
-+++ src/address_book.h 2007-11-11 13:36:25.000000000 -0500
-@@ -27,6 +27,9 @@
- #include <string>
- #include <list>
-
-+#include <sys/types.h>
-+#include <sys/stat.h>
-+
- #include "user.h"
- #include "sockets/url.h"
- #include "threads/mutex.h"
diff --git a/net/twinkle/files/pkg-message.in b/net/twinkle/files/pkg-message.in
deleted file mode 100644
index 2c983e8d9ee1..000000000000
--- a/net/twinkle/files/pkg-message.in
+++ /dev/null
@@ -1,15 +0,0 @@
-###############################################################################
-
-Twinkle SIP Softphone was installed
-
-1) If you are using a desktop/window manager different than KDE, you must to
- disable tray icon system. Edit your ~/.twinkle/twinkle.sys file and change
- the following line:
-
- # gui_use_systray=no
-
- It avoids a crash when you run twinkle softphone
-
-2) Enjoy it ;)
-
-###############################################################################
diff --git a/net/twinkle/pkg-descr b/net/twinkle/pkg-descr
deleted file mode 100644
index c6ee949006a6..000000000000
--- a/net/twinkle/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-Twinkle is a soft phone for your voice over IP communcations using the SIP
-protocol.
-
-You can use it for direct IP phone to IP phone communication or in a network
-using a SIP proxy to route your calls.
-
-WWW: http://www.twinklephone.com/
diff --git a/net/twinkle/pkg-plist b/net/twinkle/pkg-plist
deleted file mode 100644
index 0c56413b93cd..000000000000
--- a/net/twinkle/pkg-plist
+++ /dev/null
@@ -1,15 +0,0 @@
-bin/twinkle
-%%DATADIR%%/lang/twinkle_cs.qm
-%%DATADIR%%/lang/twinkle_de.qm
-%%DATADIR%%/lang/twinkle_fr.qm
-%%DATADIR%%/lang/twinkle_nl.qm
-%%DATADIR%%/lang/twinkle_ru.qm
-%%DATADIR%%/lang/twinkle_sv.qm
-%%DATADIR%%/providers.csv
-%%DATADIR%%/ringback.wav
-%%DATADIR%%/ringtone.wav
-%%DATADIR%%/twinkle16.png
-%%DATADIR%%/twinkle32.png
-%%DATADIR%%/twinkle48.png
-@dirrm %%DATADIR%%/lang
-@dirrm %%DATADIR%%