aboutsummaryrefslogtreecommitdiff
path: root/net/unfs3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/unfs3/Makefile')
-rw-r--r--net/unfs3/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/net/unfs3/Makefile b/net/unfs3/Makefile
index 401b383ab369..fd87caae14bb 100644
--- a/net/unfs3/Makefile
+++ b/net/unfs3/Makefile
@@ -1,30 +1,33 @@
# Created by: Clement Laforet <clement@FreeBSD.org>
PORTNAME= unfs3
-PORTVERSION= 0.9.22
-PORTREVISION= 1
+DISTVERSION= 0.9.22
+PORTREVISION= 2
CATEGORIES= net
-MASTER_SITES= SF
+MASTER_SITES= https://github.com/unfs3/unfs3/releases/download/unfs3-${DISTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= fuz@fuz.su
COMMENT= User-space implementation of the NFSv3 server specification
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_FreeBSD_13= ld: error: duplicate symbol: export_path
-BROKEN_FreeBSD_14= ld: error: duplicate symbol: export_path
-
USES= autoreconf
GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
CONFIGURE_ENV= YACC=byacc
-PLIST_FILES= sbin/unfsd man/man7/tags.7.gz man/man8/unfsd.8.gz
-
MAKE_JOBS_UNSAFE= yes
+INSTALL_TARGET= install-strip
+
+PLIST_FILES= man/man7/tags.7.gz \
+ man/man8/unfsd.8.gz \
+ sbin/unfsd
OPTIONS_DEFINE= CLUSTER_EXT
+CLUSTER_EXT_DESC= include clustering extensions
CLUSTER_EXT_CONFIGURE_ON= --enable-cluster
+post-extract:
+ @${RM} ${WRKSRC}/Config/lex.yy.c
+
.include <bsd.port.mk>