aboutsummaryrefslogtreecommitdiff
path: root/net/unison/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/unison/Makefile')
-rw-r--r--net/unison/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/net/unison/Makefile b/net/unison/Makefile
new file mode 100644
index 000000000000..256eb12ed317
--- /dev/null
+++ b/net/unison/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: unison
+# Date created: 4 October 2000
+# Whom: Dan Pelleg <dpelleg+unison@cs.cmu.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unison
+PORTVERSION= 2.5.1
+CATEGORIES= net
+MASTER_SITES= http://www.cis.upenn.edu/~bcpierce/unison/download/stable/unison-${PORTVERSION}/
+DISTNAME= src
+DIST_SUBDIR= unison
+
+MAINTAINER= Dan Pelleg <dpelleg+unison@cs.cmu.edu>
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_GMAKE= yes
+MAKE_ARGS= UISTYLE=text CFLAGS=""
+
+post-install:
+ strip ${PREFIX}/bin/unison
+
+.include <bsd.port.mk>