aboutsummaryrefslogtreecommitdiff
path: root/net/unison232/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/unison232/Makefile')
-rw-r--r--net/unison232/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/net/unison232/Makefile b/net/unison232/Makefile
index b3de6afbdb4c..149126354848 100644
--- a/net/unison232/Makefile
+++ b/net/unison232/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= daniel+unison@pelleg.org
COMMENT= A user-level file synchronization tool
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+PATCH_DEPENDS= ${BUILD_DEPENDS}
USE_GMAKE= yes
MAKE_ARGS= UISTYLE=text CFLAGS=""
@@ -28,6 +29,16 @@ EXTRA_DOCS= unison-manual.dvi unison-manual.html \
unison-manual.pdf unison-manual.ps
.endif
+pre-patch:
+ @if [ `ocamlc -version | ${SED} -e s/\\\.//g -e s/\\\+.*//` -gt 307 ] ; then \
+ if ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/ocaml-external-patch-ab ; then \
+ ${TRUE} ; \
+ else \
+ ${ECHO_MSG} ">> Patch ocaml-external-patch-ab failed to apply cleanly." ; \
+ ${FALSE} ; \
+ fi; \
+ fi
+
post-install:
@${STRIP_CMD} ${PREFIX}/bin/unison
.if !defined(NOPORTDOCS)