aboutsummaryrefslogtreecommitdiff
path: root/net/unison
diff options
context:
space:
mode:
Diffstat (limited to 'net/unison')
-rw-r--r--net/unison/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/net/unison/Makefile b/net/unison/Makefile
index 91083b37d87d..5f36204852f7 100644
--- a/net/unison/Makefile
+++ b/net/unison/Makefile
@@ -3,7 +3,7 @@
PORTNAME= unison
PORTVERSION= 2.40.102
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${DISTNAME}/
DISTFILES= ${EXTRACT_ONLY} ${EXTRA_DOCS}
@@ -24,17 +24,15 @@ CONFLICTS?= unison-devel-[0-9]* unison-nox11-[0-9]*
MAKE_JOBS_UNSAFE= yes
ALL_TARGET= unison all
+DOCS= BUGS.txt NEWS README
+EXTRA_DOCS= unison-${PORTVERSION}-manual.html \
+ unison-${PORTVERSION}-manual.pdf unison-${PORTVERSION}-manual.ps
+
OPTIONS_DEFINE= DOCS X11
OPTIONS_DEFAULT?= DOCS X11
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
-DOCS= BUGS.txt NEWS README
-EXTRA_DOCS= unison-${PORTVERSION}-manual.html \
- unison-${PORTVERSION}-manual.pdf unison-${PORTVERSION}-manual.ps
-.endif
-
.if ${PORT_OPTIONS:MX11}
MAKE_ARGS+= UISTYLE=gtk2
PLIST_SUB+= TEXT=""
@@ -44,7 +42,6 @@ BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml \
RUN_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
PATCH_DEPENDS+= ${BUILD_DEPENDS}
CONFLICTS+= ocaml-nox11*
-USE_GNOME= desktopfileutils
SUB_FILES+= ${PORTNAME}.desktop
PLIST_FILES+= share/pixmaps/${PORTNAME}.png
.else
@@ -78,7 +75,6 @@ post-install:
@${INSTALL_PROGRAM} ${WRKSRC}/unison-text ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DESKTOPDIR}
@${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
- @-update-desktop-database > /dev/null
@${INSTALL_DATA} ${WRKSRC}/win32rc/U_4_48x48x32.png ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
.endif