aboutsummaryrefslogtreecommitdiff
path: root/net/vinagre/.#Makefile.1.17
diff options
context:
space:
mode:
Diffstat (limited to 'net/vinagre/.#Makefile.1.17')
-rw-r--r--net/vinagre/.#Makefile.1.1751
1 files changed, 51 insertions, 0 deletions
diff --git a/net/vinagre/.#Makefile.1.17 b/net/vinagre/.#Makefile.1.17
new file mode 100644
index 000000000000..2435a45c069a
--- /dev/null
+++ b/net/vinagre/.#Makefile.1.17
@@ -0,0 +1,51 @@
+# New ports collection makefile for: vinagre
+# Date created: 16 December 2007
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/net/vinagre/Makefile,v 1.17 2008/10/20 22:58:02 kwm Exp $
+#
+
+PORTNAME= vinagre
+PORTVERSION= 2.24.1
+PORTREVISION= 1
+CATEGORIES= net gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= VNC client for the GNOME Desktop
+
+LIB_DEPENDS= gtk-vnc-1.0.0:${PORTSDIR}/net/gtk-vnc \
+ avahi-core.6:${PORTSDIR}/net/avahi-app \
+ avahi-ui.0:${PORTSDIR}/net/avahi-gtk \
+ gnome-keyring:${PORTSDIR}/security/gnome-keyring
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GNOME= gnomeprefix intlhack gnomehack libglade2 gconf2 gnomedocutils \
+ gnomepanel
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+INSTALLS_OMF= yes
+INSTALLS_ICONS= yes
+CONFIGURE_ARGS= --enable-avahi
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= vinagre.schemas
+
+MAN1= vinagre.1
+
+post-install:
+ @-update-desktop-database > /dev/null
+ @-update-mime-database ${PREFIX}/share/mime > /dev/null
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in AUTHORS COPYING ChangeLog MAINTAINERS NEWS README
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>