aboutsummaryrefslogtreecommitdiff
path: root/net/wais/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/wais/Makefile')
-rw-r--r--net/wais/Makefile23
1 files changed, 18 insertions, 5 deletions
diff --git a/net/wais/Makefile b/net/wais/Makefile
index 8caeed52ffb2..a2d6efa25ea5 100644
--- a/net/wais/Makefile
+++ b/net/wais/Makefile
@@ -1,18 +1,31 @@
# New ports collection makefile for: wais
-# Version required: 0.3
+# Version required: 0.5
# Date created: 20 Sep 1994
# Whom: adam
#
-# $Id: Makefile,v 1.7 1995/11/27 04:05:48 asami Exp $
+# $Id: Makefile,v 1.8 1996/04/12 08:43:43 asami Exp $
#
-DISTNAME= freeWAIS-0.3
+DISTNAME= freeWAIS-0.5
CATEGORIES+= net
MASTER_SITES= ftp://ftp.cnidr.org/pub/NIDR.tools/freewais/
-BROKEN= yes
-USE_GMAKE= yes
+NO_PACKAGE= not yet
+NO_INSTALL= almost
+ALL_TARGET= freebsd
+MAKE_ENV:= TOP=${WRKSRC}
is_depended: all
+pre-patch:
+ @${CP} ${WRKSRC}/Makefile.bsdi ${WRKSRC}/Makefile.freebsd
+ @mv ${WRKSRC}/src/client/x/Imakefile ${WRKDIR} \
+ && ${SED} -e '\;/SETME_IN_Imakefile;s;;${WRKSRC};' \
+ <${WRKDIR}/Imakefile >${WRKSRC}/src/client/x/Imakefile
+
+.if ${MAKEFILE} != Makefile.freebsd
+do-install:
+ ${MAKE} MAKEFILE=Makefile.freebsd do-install
+.endif
+
.include <bsd.port.mk>