aboutsummaryrefslogtreecommitdiff
path: root/net/wireshark/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/wireshark/Makefile')
-rw-r--r--net/wireshark/Makefile57
1 files changed, 0 insertions, 57 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
deleted file mode 100644
index b8ab7b35b057..000000000000
--- a/net/wireshark/Makefile
+++ /dev/null
@@ -1,57 +0,0 @@
-# New ports collection makefile for: ethereal
-# Date created: 10 August 1998
-# Whom: Bill Fumerola <billf@chc-chimes.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= ethereal
-PORTVERSION= 0.9.14
-PORTREVISION= 1
-CATEGORIES= net ipv6
-MASTER_SITES= ftp://ftp.ethereal.com/pub/ethereal/%SUBDIR%/ \
- ftp://gd.tuwien.ac.at/infosys/security/ethereal/%SUBDIR%/ \
- ftp://ftp.sunet.se/pub/network/monitoring/ethereal/%SUBDIR%/ \
- ftp://ftp.mirrors.wiretapped.net/pub/security/packet-capture/ethereal/%SUBDIR%/ \
- http://www.mirrors.wiretapped.net/pub/security/packet-capture/ethereal/%SUBDIR%/
-MASTER_SITE_SUBDIR= . old-versions
-
-MAINTAINER= billf@FreeBSD.org
-COMMENT= An X11/GTK network analyzer/capture tool
-
-.if !defined(WITHOUT_SNMP)
-LIB_DEPENDS= netsnmp.6:${PORTSDIR}/net/net-snmp
-.endif
-
-CONFIGURE_ARGS= --program-transform-name=""
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-.if !defined(WITHOUT_X11)
-USE_X_PREFIX= yes
-USE_GNOME= gtk12
-MAN1+= ethereal.1
-PLIST_SUB+= ETHEREAL=bin/ethereal
-.else
-PLIST_SUB+= ETHEREAL="@comment ethereal not built"
-USE_GNOME= glib12
-CONFIGURE_ARGS+= --enable-ethereal=no \
- --disable-gtktest
-.endif
-
-USE_LIBTOOL= yes
-LIBTOOLFILES= configure epan/configure wiretap/configure
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
-
-.if !defined(WITHOUT_SNMP)
-CONFIGURE_ARGS+= --enable-snmp=yes \
- --with-net-snmp=${LOCALBASE}/lib \
- --without-ucdsnmp
-.if exists(/usr/include/openssl/crypto.h)
-CONFIGURE_ARGS+= --with-ssl=/usr
-.endif
-.else
-CONFIGURE_ARGS+= --enable-snmp=no --without-ucdsnmp --without-net-snmp
-.endif
-
-MAN1+= editcap.1 idl2eth.1 mergecap.1 tethereal.1 text2pcap.1
-
-.include <bsd.port.mk>