aboutsummaryrefslogtreecommitdiff
path: root/net/x2goclient
diff options
context:
space:
mode:
Diffstat (limited to 'net/x2goclient')
-rw-r--r--net/x2goclient/Makefile93
-rw-r--r--net/x2goclient/distinfo4
-rw-r--r--net/x2goclient/files/patch-cupsprint.h10
-rw-r--r--net/x2goclient/files/patch-sshmasterconnection.cpp12
-rw-r--r--net/x2goclient/files/patch-sshprocess.cpp12
-rw-r--r--net/x2goclient/files/patch-sshprocess.h15
6 files changed, 111 insertions, 35 deletions
diff --git a/net/x2goclient/Makefile b/net/x2goclient/Makefile
index af2911c5d7c5..cd8878ff2c89 100644
--- a/net/x2goclient/Makefile
+++ b/net/x2goclient/Makefile
@@ -1,46 +1,93 @@
-# New ports collection makefile for: x2goclient
-# Date created: 2010-08-16
-# Whom: arved
-#
+# Created by: arved
# $FreeBSD$
PORTNAME= x2goclient
-DISTVERSION= 3.01-5
-PORTREVISION= 2
+PORTVERSION= 3.99.2.2
CATEGORIES= net
-MASTER_SITES= http://code.x2go.org/releases/source/x2goclient/pre-git/
-DISTNAME= ${PORTNAME}_${DISTVERSION}
+MASTER_SITES= http://code.x2go.org/releases/source/x2goclient/
MAINTAINER= ports@FreeBSD.org
-COMMENT= The x2go perl client
+COMMENT= The x2go Qt client
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-client
+LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ pcre:${PORTSDIR}/devel/pcre \
+ png15:${PORTSDIR}/graphics/png \
+ cups:${PORTSDIR}/print/cups-client \
+ freetype:${PORTSDIR}/print/freetype2 \
+ ssh:${PORTSDIR}/security/libssh \
+ expat:${PORTSDIR}/textproc/expat2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ xcb:${PORTSDIR}/x11/libxcb
RUN_DEPENDS= nxproxy:${PORTSDIR}/net/nxproxy \
x2goclient-cli:${PORTSDIR}/net/x2goclient-cli
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:S,-5,,}
+OPTIONS_DEFINE= LDAP DOCS
+OPTIONS_DEFAULT=LDAP
-USE_QT4= gui network svg qmake_build moc_build uic_build rcc_build
-USE_OPENLDAP= yes
+USE_GETTEXT= yes
+USE_ICONV= yes
+USE_XORG= ice sm x11 xau xdmcp xext xpm xrender
+USE_QT4= corelib gui network svg \
+ linguist_build moc_build qmake_build rcc_build uic_build
+QMAKEFLAGS= QMAKE_LRELEASE="${QT_PREFIX}/bin/lrelease-qt4"
+INSTALLS_ICONS= yes
MAKE_JOBS_SAFE= yes
-PLIST_FILES= bin/x2goclient
+MAN1= x2goclient.1
+
+PORTSCOUT= limit:\^3\.0
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MLDAP}
+USE_OPENLDAP= yes
+CFLAGS+= -DUSELDAP
+QMAKEFLAGS+= LIBS+="-lX11 -lXpm -lcups -lldap"
+.else
+QMAKEFLAGS+= LIBS+="-lX11 -lXpm -lcups"
+.endif
post-patch:
- cd ${WRKSRC}; ${REINPLACE_CMD} -e "s,Q_OS_LINUX,Q_OS_FREEBSD," \
- embedwidget.cpp onmainwindow.cpp ongetpass.cpp \
- clicklineedit.cpp embedwidget.h clicklineedit.h
- ${REINPLACE_CMD} -e "s,#include <linux/fs.h>,," \
- ${WRKSRC}/onmainwindow.cpp
- ${REINPLACE_CMD} -e "s,linux,freebsd," ${WRKSRC}/x2goclient.pro
+ @${FIND} ${WRKSRC} -name "*.cpp" -or -name "*.h" | ${XARGS} \
+ ${REINPLACE_CMD} -e \
+ 's|Q_OS_LINUX|Q_OS_${OPSYS:U}| ; \
+ /<linux\/fs.h>/s|^|//| ; \
+ /#define USELDAP/s|^|//|'
+ @${FIND} ${WRKSRC} -name "*.cpp" -or -name "*.ts" | ${XARGS} \
+ ${REINPLACE_CMD} -e \
+ 's|authentification|authentication|g'
+ @${REINPLACE_CMD} -e \
+ '/MACOSX/s|^|#|' ${WRKSRC}/x2goclient.pro
+ @${REINPLACE_CMD} -e \
+ 's|/usr/bin/||' ${WRKSRC}/desktop/x2goclient.desktop
do-configure:
- cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS}
+ @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS}
+
+pre-build:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} compiler_TSQM_make_all
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/x2goclient ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/x2goclient ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/man1/x2goclient.1 ${MANPREFIX}/man/man1
+ @${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/desktop/x2goclient.desktop \
+ ${PREFIX}/share/applications
+.for dir in 16x16 32x32 64x64 128x128
+ @${MKDIR} ${PREFIX}/share/icons/hicolor/${dir}/apps
+ ${INSTALL_DATA} ${WRKSRC}/icons/${dir}/x2goclient.png \
+ ${PREFIX}/share/icons/hicolor/${dir}/apps
+.endfor
+ @${MKDIR} ${DATADIR}/icons
+ ${INSTALL_DATA} ${WRKSRC}/icons/x2goclient.xpm ${DATADIR}/icons
+ ${INSTALL_DATA} ${WRKSRC}/icons/128x128/x2goclient.png ${DATADIR}/icons
+ ${INSTALL_DATA} ${WRKSRC}/icons/128x128/x2gosession.png ${DATADIR}/icons
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/HOWTO.GPGCARD ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/net/x2goclient/distinfo b/net/x2goclient/distinfo
index f1c265b9e577..40a1c5e09adf 100644
--- a/net/x2goclient/distinfo
+++ b/net/x2goclient/distinfo
@@ -1,2 +1,2 @@
-SHA256 (x2goclient_3.01-5.tar.gz) = ce671a628b17614bdcf443bd5ff22f644ceca1dad634c8823fcad8438a3751e3
-SIZE (x2goclient_3.01-5.tar.gz) = 10274153
+SHA256 (x2goclient-3.99.2.2.tar.gz) = ef3653cb7643ea17a2e5a3beb2d3072e4c6ddff6fcee2021e5d7251a07f6ca6a
+SIZE (x2goclient-3.99.2.2.tar.gz) = 1120830
diff --git a/net/x2goclient/files/patch-cupsprint.h b/net/x2goclient/files/patch-cupsprint.h
deleted file mode 100644
index 7a283600d214..000000000000
--- a/net/x2goclient/files/patch-cupsprint.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- cupsprint.h.orig 2009-11-12 06:47:37.000000000 +0900
-+++ cupsprint.h 2011-11-23 03:23:33.000000000 +0900
-@@ -15,6 +15,7 @@
- #ifndef Q_OS_WIN
- #include <QStringList>
- #include <cups/cups.h>
-+#include <cups/ppd.h>
- /**
- @author Oleksandr Shneyder <oleksandr.shneyder@obviously-nice.de>
- */
diff --git a/net/x2goclient/files/patch-sshmasterconnection.cpp b/net/x2goclient/files/patch-sshmasterconnection.cpp
new file mode 100644
index 000000000000..c8c349e6129b
--- /dev/null
+++ b/net/x2goclient/files/patch-sshmasterconnection.cpp
@@ -0,0 +1,12 @@
+--- sshmasterconnection.cpp.orig 2011-11-25 21:08:10.000000000 +0900
++++ sshmasterconnection.cpp 2011-12-20 01:50:14.000000000 +0900
+@@ -25,6 +25,9 @@
+ #include <QDir>
+ #include <QTemporaryFile>
+ #ifndef Q_OS_WIN
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
+ #include <arpa/inet.h>
+ #endif
+
diff --git a/net/x2goclient/files/patch-sshprocess.cpp b/net/x2goclient/files/patch-sshprocess.cpp
new file mode 100644
index 000000000000..41247a0aef96
--- /dev/null
+++ b/net/x2goclient/files/patch-sshprocess.cpp
@@ -0,0 +1,12 @@
+--- sshprocess.cpp.orig 2011-11-25 21:08:10.000000000 +0900
++++ sshprocess.cpp 2011-12-20 01:53:47.000000000 +0900
+@@ -21,6 +21,9 @@
+ #include <QTimer>
+
+ #ifndef Q_OS_WIN
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <netinet/tcp.h>
+ #endif
diff --git a/net/x2goclient/files/patch-sshprocess.h b/net/x2goclient/files/patch-sshprocess.h
new file mode 100644
index 000000000000..a6030305a0d3
--- /dev/null
+++ b/net/x2goclient/files/patch-sshprocess.h
@@ -0,0 +1,15 @@
+--- sshprocess.h.orig 2011-11-25 21:08:10.000000000 +0900
++++ sshprocess.h 2011-12-20 01:56:29.000000000 +0900
+@@ -17,6 +17,12 @@
+ #ifndef SSHPROCESS_H
+ #define SSHPROCESS_H
+
++#ifndef Q_OS_WIN
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
++#include <arpa/inet.h>
++#endif
+ #include <libssh/libssh.h>
+ #include <QObject>
+