aboutsummaryrefslogtreecommitdiff
path: root/net/xboxproxy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/xboxproxy/Makefile')
-rw-r--r--net/xboxproxy/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/xboxproxy/Makefile b/net/xboxproxy/Makefile
new file mode 100644
index 000000000000..4587e5ea1109
--- /dev/null
+++ b/net/xboxproxy/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xboxproxy
+# Date created: 6 October 2005
+# Whom: Antony Mawer <ports@mawer.org>
+#
+# $FreeBSD$
+
+PORTNAME= xboxproxy
+PORTVERSION= 1.9
+CATEGORIES= net
+MASTER_SITES= http://www.csh.rit.edu/~psionic/projects/xboxproxy/
+DISTNAME= proxy-${PORTVERSION}
+
+MAINTAINER= ports@mawer.org
+COMMENT= A proxy for the XBox system link protocol
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-prefix=xbox
+USE_GMAKE= yes
+
+PLIST_FILES= bin/xboxproxy
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Doesn't build on FreeBSD < 5.x"
+.endif
+
+.include <bsd.port.post.mk>