aboutsummaryrefslogtreecommitdiff
path: root/net/xmlrpc++/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/xmlrpc++/Makefile')
-rw-r--r--net/xmlrpc++/Makefile9
1 files changed, 1 insertions, 8 deletions
diff --git a/net/xmlrpc++/Makefile b/net/xmlrpc++/Makefile
index 78722f7e26ba..94c0db60541e 100644
--- a/net/xmlrpc++/Makefile
+++ b/net/xmlrpc++/Makefile
@@ -20,13 +20,6 @@ COMMENT= A C++ implementation of the XML-RPC protocol
USE_GCC= 3.4
USE_GMAKE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 501103
-# Work around bsd.port.mk bug: Does not currently set up MAKE_ENV for gcc 3.2 and 3.3
-MAKE_ENV+= CC="${CC}" CXX="${CXX}"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s|^CXX|#CXX|" -e "s|^CXXFLAGS|#CXXFLAGS|" \
-e "s|tests$$||" ${WRKSRC}/Makefile
@@ -36,4 +29,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/src/XmlRpc*.h ${PREFIX}/include/xmlrpc++
${INSTALL_PROGRAM} ${WRKSRC}/libXmlRpc.a ${PREFIX}/lib
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>