aboutsummaryrefslogtreecommitdiff
path: root/net/ysm/files
diff options
context:
space:
mode:
Diffstat (limited to 'net/ysm/files')
-rw-r--r--net/ysm/files/patch-Makefile13
-rw-r--r--net/ysm/files/patch-iconv24
-rw-r--r--net/ysm/files/patch-network13
-rw-r--r--net/ysm/files/patch-setup11
4 files changed, 61 insertions, 0 deletions
diff --git a/net/ysm/files/patch-Makefile b/net/ysm/files/patch-Makefile
new file mode 100644
index 000000000000..1472baa97709
--- /dev/null
+++ b/net/ysm/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Thu Jan 1 06:00:00 1970
++++ Makefile Tue May 28 12:06:00 2002
+@@ -0,0 +1,10 @@
++PROG= ysm
++CFLAGS+= -Wall -ansi -I/usr/local/include -DYSM_USE_ICONV
++LDADD+= -L/usr/local/lib -liconv
++PREFIX?= /usr/local
++BINDIR?= ${PREFIX}/bin
++SRCS= YSM_Main.c YSM_Network.c YSM_Prompt.c YSM_Setup.c \
++ YSM_ToolBox.c YSM_Slaves.c YSM_Help.c YSM_Win32.c
++MAN= docs/ysm.1
++MANDIR= ${PREFIX}/man/man
++.include <bsd.prog.mk>
diff --git a/net/ysm/files/patch-iconv b/net/ysm/files/patch-iconv
new file mode 100644
index 000000000000..68f9deb98200
--- /dev/null
+++ b/net/ysm/files/patch-iconv
@@ -0,0 +1,24 @@
+--- YSM_ToolBox.c.orig Fri Apr 12 11:07:38 2002
++++ YSM_ToolBox.c Tue May 28 11:19:33 2002
+@@ -45,6 +45,7 @@
+ #include "YSM.h"
+ /* International Languages Charset Convertion! */
+ #include "YSM_Iconv.h"
++#include <iconv.h>
+
+
+ static struct timeval tv;
+@@ -428,9 +429,12 @@
+ bytes_in = strlen(buf_from) + 1;
+ bytes_out = maxlen - 1;
+ conv_d = iconv_open(charset_to, charset_from);
+- bytes_res = iconv(conv_d, &inptr, &bytes_in, &outptr, &bytes_out);
++ if ( conv_d == (iconv_t)( -1)) { perror("iconv_open:"); return -1; }
++ else {
++ bytes_res = iconv(conv_d, (const char **)&inptr, &bytes_in, &outptr, &bytes_out);
+ iconv_close(conv_d);
+ return 0;
++ }
+ }
+
+ #endif
diff --git a/net/ysm/files/patch-network b/net/ysm/files/patch-network
new file mode 100644
index 000000000000..4d3590511652
--- /dev/null
+++ b/net/ysm/files/patch-network
@@ -0,0 +1,13 @@
+--- YSM_Network.c.orig Fri Apr 12 11:07:38 2002
++++ YSM_Network.c Tue May 28 11:18:47 2002
+@@ -1547,8 +1547,8 @@
+ int log_len = 0;
+
+ #ifdef YSM_USE_ICONV
+- if( YSM_Iconv( YSM_SETTING_CHARSET_TRANS,
+- YSM_SETTING_CHARSET_LOCAL,
++ if( YSM_Iconv( YSM_SETTING_CHARSET_LOCAL,
++ YSM_SETTING_CHARSET_TRANS,
+ data,
+ &data_conv,
+ YSM_ICONV_MAXLEN) < 0 )
diff --git a/net/ysm/files/patch-setup b/net/ysm/files/patch-setup
new file mode 100644
index 000000000000..20011b82dbbc
--- /dev/null
+++ b/net/ysm/files/patch-setup
@@ -0,0 +1,11 @@
+--- YSM_Setup.c.orig Fri Apr 12 11:07:38 2002
++++ YSM_Setup.c Tue May 28 11:21:08 2002
+@@ -441,7 +441,7 @@
+
+ fprintf(YSM_CFGFD,"\n# TRANS_CHARSET is charset for transfering/receiving of messages");
+ fprintf(YSM_CFGFD,"\n# LOCAL_CHARSET is charset for displaying/inputting of messages");
+- fprintf(YSM_CFGFD,"\n# Russian Generic are TRANS: CP1251 LOCAL: KOI8R\n");
++ fprintf(YSM_CFGFD,"\n# Russian Generic are TRANS: CP1251 LOCAL: KOI8-R\n");
+ fprintf(YSM_CFGFD,"\nCHARSET_TRANS>0");
+ fprintf(YSM_CFGFD,"\nCHARSET_LOCAL>0");
+ #endif