aboutsummaryrefslogtreecommitdiff
path: root/net/zaptel12/files
diff options
context:
space:
mode:
Diffstat (limited to 'net/zaptel12/files')
-rw-r--r--net/zaptel12/files/patch-test::Makefile31
-rw-r--r--net/zaptel12/files/patch-wcfxo::wcfxo.c22
-rw-r--r--net/zaptel12/files/patch-wcfxs::wcfxs.c20
-rw-r--r--net/zaptel12/files/patch-zaptel::zaptel.c26
-rw-r--r--net/zaptel12/files/patch-zaptel::zaptel.h16
-rw-r--r--net/zaptel12/files/patch-ztcfg::Makefile26
-rw-r--r--net/zaptel12/files/zaptel.sh79
7 files changed, 0 insertions, 220 deletions
diff --git a/net/zaptel12/files/patch-test::Makefile b/net/zaptel12/files/patch-test::Makefile
deleted file mode 100644
index c8e181554796..000000000000
--- a/net/zaptel12/files/patch-test::Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-
-$FreeBSD$
-
---- test/Makefile
-+++ test/Makefile
-@@ -7,17 +7,17 @@
-
- all: zttool fxo_test ztmonitor zttest
-
--fxo_test: fxo_test.o
-- ${CC} ${CFLAGS} -o fxo_test fxo_test.o -ltonezone -L../ztcfg
-+fxo_test: fxo_test.c
-+ ${CC} ${CFLAGS} -o fxo_test fxo_test.c -ltonezone -L../ztcfg
-
--ztmonitor: ztmonitor.o
-- ${CC} ${CFLAGS} -o ztmonitor ztmonitor.o -ltonezone -L../ztcfg
-+ztmonitor: ztmonitor.c
-+ ${CC} ${CFLAGS} -o ztmonitor ztmonitor.c -ltonezone -L../ztcfg
-
--zttool: zttool.o
-- ${CC} ${CFLAGS} -o zttool zttool.o -ltonezone -L${LOCALBASE}/lib -lnewt -L../ztcfg
-+zttool: zttool.c
-+ ${CC} ${CFLAGS} -o zttool zttool.c -ltonezone -L${LOCALBASE}/lib -lnewt -L../ztcfg
-
--zttest: zttest.o
-- ${CC} ${CFLAGS} -o zttest zttest.o
-+zttest: zttest.c
-+ ${CC} ${CFLAGS} -o zttest zttest.c
-
- clean:
- rm -f fxo_test ztmonitor zttool ztls zttest *.o
diff --git a/net/zaptel12/files/patch-wcfxo::wcfxo.c b/net/zaptel12/files/patch-wcfxo::wcfxo.c
deleted file mode 100644
index 1a2810a58b6d..000000000000
--- a/net/zaptel12/files/patch-wcfxo::wcfxo.c
+++ /dev/null
@@ -1,22 +0,0 @@
-
-$FreeBSD$
-
---- wcfxo/wcfxo.c
-+++ wcfxo/wcfxo.c
-@@ -267,8 +267,14 @@
-
- /* Character device entry points */
- static struct cdevsw wcfxo_cdevsw = {
--#if __FreeBSD_version >= 502103
-- .d_version = D_VERSION,
-+#if __FreeBSD_version < 502103
-+#ifdef MAJOR_AUTO
-+ .d_maj = MAJOR_AUTO,
-+#else
-+ .d_maj = 197,
-+#endif
-+#else
-+ .d_version = D_VERSION,
- #endif
- .d_name = "wcfxo",
- .d_open = wcfxo_sys_open,
diff --git a/net/zaptel12/files/patch-wcfxs::wcfxs.c b/net/zaptel12/files/patch-wcfxs::wcfxs.c
deleted file mode 100644
index bab8faf9d09e..000000000000
--- a/net/zaptel12/files/patch-wcfxs::wcfxs.c
+++ /dev/null
@@ -1,20 +0,0 @@
-
-$FreeBSD$
-
---- wcfxs/wcfxs.c
-+++ wcfxs/wcfxs.c
-@@ -308,7 +308,13 @@
-
- /* Character device entry points */
- static struct cdevsw wcfxs_cdevsw = {
--#if __FreeBSD_version >= 502103
-+#if __FreeBSD_version < 502103
-+#ifdef MAJOR_AUTO
-+ .d_maj = MAJOR_AUTO,
-+#else
-+ .d_maj = 198,
-+#endif
-+#else
- .d_version = D_VERSION,
- #endif
- .d_name = "wcfxs",
diff --git a/net/zaptel12/files/patch-zaptel::zaptel.c b/net/zaptel12/files/patch-zaptel::zaptel.c
deleted file mode 100644
index a5fc0b4cf7d9..000000000000
--- a/net/zaptel12/files/patch-zaptel::zaptel.c
+++ /dev/null
@@ -1,26 +0,0 @@
-
-$FreeBSD$
-
---- zaptel/zaptel.c
-+++ zaptel/zaptel.c
-@@ -156,12 +156,17 @@
- #endif
-
- static struct cdevsw zt_devsw = {
--#if __FreeBSD_version >= 502103
-+#if __FreeBSD_version < 502103
-+#ifdef MAJOR_AUTO
-+ .d_maj = MAJOR_AUTO,
-+#else
-+ .d_maj = ZT_MAJOR,
-+#endif
-+#else
- .d_version = D_VERSION,
- #endif
- .d_open = ztopen,
-- .d_name = "zaptel",
-- .d_maj = ZT_MAJOR
-+ .d_name = "zaptel"
- };
-
-
diff --git a/net/zaptel12/files/patch-zaptel::zaptel.h b/net/zaptel12/files/patch-zaptel::zaptel.h
deleted file mode 100644
index b25d6f31755b..000000000000
--- a/net/zaptel12/files/patch-zaptel::zaptel.h
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- zaptel/zaptel.h.orig
-+++ zaptel/zaptel.h
-@@ -34,9 +34,9 @@
- #if !defined(_ZAPTEL_H)
- #define _ZAPTEL_H
-
-+#ifdef _KERNEL
- #include "os.h"
-
--#ifdef _KERNEL
- #include <sys/select.h>
- #include <sys/param.h>
-
diff --git a/net/zaptel12/files/patch-ztcfg::Makefile b/net/zaptel12/files/patch-ztcfg::Makefile
deleted file mode 100644
index cc147a290b14..000000000000
--- a/net/zaptel12/files/patch-ztcfg::Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
-
-$FreeBSD$
-
---- ztcfg/Makefile
-+++ ztcfg/Makefile
-@@ -10,10 +10,19 @@
-
- all: ztcfg libtonezone.a
-
--ztcfg: ztcfg.o tonezone.o zonedata.o
-+ztcfg: ztcfg.o tonezone.o zonedata.o
- ${CC} ${CFLAGS} -o ztcfg ztcfg.o tonezone.o zonedata.o -lm
-
- ztcfg.c: ztcfg.h
-+
-+ztcfg.o: ztcfg.c
-+ ${CC} ${CFLAGS} -o ztcfg.o -c ztcfg.c
-+
-+tonezone.o: tonezone.c
-+ ${CC} ${CFLAGS} -o tonezone.o -c tonezone.c
-+
-+zonedata.o: zonedata.c
-+ ${CC} ${CFLAGS} -o zonedata.o -c zonedata.c
-
- libtonezone.a: tonezone.o
- ar r libtonezone.a tonezone.o zonedata.o
diff --git a/net/zaptel12/files/zaptel.sh b/net/zaptel12/files/zaptel.sh
deleted file mode 100644
index 29da7fc86ad4..000000000000
--- a/net/zaptel12/files/zaptel.sh
+++ /dev/null
@@ -1,79 +0,0 @@
-#!/bin/sh
-
-PREFIX=%%PREFIX%%
-LIBDIR=${PREFIX}/lib/zaptel
-
-case "$1" in
- start)
- /sbin/kldload ${LIBDIR}/zaptel.ko || exit 1
- /sbin/kldload ${LIBDIR}/wcfxo.ko || exit 1
- /sbin/kldload ${LIBDIR}/wcfxs.ko || exit 1
- if [ ! -d /dev/zap ]
- then
- mkdir -p /dev/zap || exit 1
- fi
- if [ ! -c /dev/zap/channel ]
- then
- /sbin/mknod /dev/zap/channel c 196 254 || exit 1
- fi
- if [ ! -c /dev/zap/ctl ]
- then
- /sbin/mknod /dev/zap/ctl c 196 0 || exit 1
- fi
- if [ ! -c /dev/zap/pseudo ]
- then
- /sbin/mknod /dev/zap/pseudo c 196 255 || exit 1
- fi
- if [ ! -c /dev/zap/timer ]
- then
- /sbin/mknod /dev/zap/timer c 196 253 || exit 1
- fi
- z=" zaptel"
- if /usr/sbin/pciconf -l | /usr/bin/grep -q ^wcfxo
- then
- for i in 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
- do
- if /usr/sbin/pciconf -l | /usr/bin/grep -q ^wcfxo${i}
- then
- if [ ! -c /dev/wcfxo${i} ]
- then
- /sbin/mknod /dev/wcfxo${i} c 197 ${i} || exit 1
- fi
- fi
- done
- ${PREFIX}/bin/ztcfg 2> /dev/null
- else
- if /usr/sbin/pciconf -l | /usr/bin/grep -q ^wcfxs
- then
- for i in 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
- do
- if /usr/sbin/pciconf -l | /usr/bin/grep -q ^wcfxs${i}
- then
- if [ ! -c /dev/wcfxs${i} ]
- then
- /sbin/mknod /dev/wcfxo${i} c 198 ${i} || exit 1
- fi
- fi
- done
- ${PREFIX}/bin/ztcfg 2> /dev/null
- else
- z=""
- fi
- fi
- echo -n ${z}
- ;;
-
- stop)
- /sbin/kldunload wcfxs.ko || exit 1
- /sbin/kldunload wcfxo.ko || exit 1
- /sbin/kldunload zaptel.ko || exit 1
- echo -n " zaptel"
- ;;
-
- *)
- echo ""
- echo "Usage: `basename $0` { start | stop }"
- echo ""
- exit 64
- ;;
-esac