aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/c3270/Makefile4
-rw-r--r--net/crtmpserver/Makefile3
-rw-r--r--net/cvsync/Makefile3
-rw-r--r--net/easysoap/Makefile3
-rw-r--r--net/echoping/Makefile3
-rw-r--r--net/g2ipmsg/Makefile3
-rw-r--r--net/glusterfs/Makefile3
-rw-r--r--net/gogoc/Makefile3
-rw-r--r--net/ifstat/Makefile2
-rw-r--r--net/libarms/Makefile3
-rw-r--r--net/libexosip2/Makefile3
-rw-r--r--net/mpd5/Makefile2
-rw-r--r--net/netembryo/Makefile2
-rw-r--r--net/ntop/Makefile3
-rw-r--r--net/openbsc/Makefile3
-rw-r--r--net/openslp/Makefile3
-rw-r--r--net/openvswitch/Makefile3
-rw-r--r--net/p5-Socket-Class/Makefile3
-rw-r--r--net/pipsecd/Makefile2
-rw-r--r--net/proftpd-mod_ldap/Makefile2
-rw-r--r--net/qoauth/Makefile3
-rw-r--r--net/radsecproxy/Makefile3
-rw-r--r--net/rdesktop/Makefile3
-rw-r--r--net/relayd/Makefile3
-rw-r--r--net/sofia-sip/Makefile3
-rw-r--r--net/ssldump/Makefile2
-rw-r--r--net/stone/Makefile5
-rw-r--r--net/svnup/Makefile3
-rw-r--r--net/tinyfugue/Makefile2
-rw-r--r--net/ulxmlrpcpp/Makefile3
-rw-r--r--net/x11vnc/Makefile3
31 files changed, 34 insertions, 55 deletions
diff --git a/net/c3270/Makefile b/net/c3270/Makefile
index cf5263dcc686..99e9c1feb1f5 100644
--- a/net/c3270/Makefile
+++ b/net/c3270/Makefile
@@ -18,7 +18,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= ac_cv_search_libiconv=${ICONV_LIB}
USES= iconv readline gmake
-USE_OPENSSL= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
@@ -49,7 +48,8 @@ PORTDOCS= *
.if ! ${PORT_OPTIONS:MOPENSSL}
CONFIGURE_ARGS+= --disable-ssl
-.undef USE_OPENSSL
+.else
+USES+= ssl
.endif
.if ! ${PORT_OPTIONS:MREADLINE}
diff --git a/net/crtmpserver/Makefile b/net/crtmpserver/Makefile
index 3c448cf1ee6b..6e39e36447f5 100644
--- a/net/crtmpserver/Makefile
+++ b/net/crtmpserver/Makefile
@@ -14,10 +14,9 @@ LICENSE= GPLv3
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
-USES= cmake:outsource execinfo lua
+USES= cmake:outsource execinfo lua ssl
CMAKE_SOURCE_PATH= ${WRKSRC}/builders/cmake
CMAKE_ARGS= -DCRTMPSERVER_INSTALL_PREFIX:STRING=${PREFIX} -DTEMP_FRAMEWORK_VER=${PORTVERSION}
-USE_OPENSSL= yes
USERS= crtmpserver
GROUPS= crtmpserver
diff --git a/net/cvsync/Makefile b/net/cvsync/Makefile
index 200e464325da..fc07d0baaeb5 100644
--- a/net/cvsync/Makefile
+++ b/net/cvsync/Makefile
@@ -13,9 +13,8 @@ COMMENT= Portable CVS repository synchronization utility
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/doc/COPYRIGHT
-USES= gmake
+USES= gmake ssl
USE_RC_SUBR= cvsyncd
-USE_OPENSSL= yes
PORTDOCS= ChangeLog FAQ TODO
PORTEXAMPLES= cvsync.conf cvsyncd-FreeBSD.conf \
diff --git a/net/easysoap/Makefile b/net/easysoap/Makefile
index 853bd905edcf..a263509b1dee 100644
--- a/net/easysoap/Makefile
+++ b/net/easysoap/Makefile
@@ -15,8 +15,7 @@ LICENSE= LGPL21
LIB_DEPENDS= libexpat.so:textproc/expat2
-USE_OPENSSL= yes
-USES= libtool
+USES= libtool ssl
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_lib_stdcpp_main=no
INSTALL_TARGET= install-strip
diff --git a/net/echoping/Makefile b/net/echoping/Makefile
index 444e0f9574bd..347de84d7cef 100644
--- a/net/echoping/Makefile
+++ b/net/echoping/Makefile
@@ -16,9 +16,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpopt.so:devel/popt \
libidn.so:dns/libidn
-USES= cpe libtool
+USES= cpe libtool ssl
CPE_VENDOR= echoping_project
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-http --enable-icp --enable-smtp --with-ssl \
--enable-ttcp --enable-tos --with-libidn=${LOCALBASE} \
diff --git a/net/g2ipmsg/Makefile b/net/g2ipmsg/Makefile
index 5f2bce1902fc..1a7c77d96949 100644
--- a/net/g2ipmsg/Makefile
+++ b/net/g2ipmsg/Makefile
@@ -12,10 +12,9 @@ COMMENT= Popup style message communication tool for GNOME2
LICENSE= GPLv2+
-USES= gettext gmake pathfix pkgconfig
+USES= gettext gmake pathfix pkgconfig ssl
USE_GNOME= gnomeprefix intltool libgnomeui
USE_GSTREAMER= vorbis
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-doxygen-doc \
--enable-systray \
diff --git a/net/glusterfs/Makefile b/net/glusterfs/Makefile
index 7e5514af1751..617d229ebd21 100644
--- a/net/glusterfs/Makefile
+++ b/net/glusterfs/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libargp.so:devel/argp-standalone liburcu-bp.so:sysutils/liburcu
USE_GCC= any
USES= bison gettext libtool pkgconfig python readline shebangfix \
- sqlite
+ sqlite ssl
SHEBANG_FILES= extras/ganesha/scripts/create-export-ganesha.sh \
extras/ganesha/scripts/dbus-send.sh \
@@ -28,7 +28,6 @@ SHEBANG_FILES= extras/ganesha/scripts/create-export-ganesha.sh \
USE_GNOME= glib20 libxml2
USE_LDCONFIG= yes
-USE_OPENSSL= yes
USE_RC_SUBR= glusterd
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig \
diff --git a/net/gogoc/Makefile b/net/gogoc/Makefile
index 66b94799efbf..9128052d873d 100644
--- a/net/gogoc/Makefile
+++ b/net/gogoc/Makefile
@@ -11,9 +11,8 @@ DISTNAME= gogoc-1_2-RELEASE
MAINTAINER= kami@k5-storitve.net
COMMENT= GogoCLIENT, connect to Freenet6 tunnel
-USES= gmake
+USES= gmake ssl
USE_RC_SUBR= gogoc
-USE_OPENSSL= yes
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/net/ifstat/Makefile b/net/ifstat/Makefile
index 57c90900bf84..d7984c8fd46e 100644
--- a/net/ifstat/Makefile
+++ b/net/ifstat/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= alexey@renatasystems.org
COMMENT= Network interface statistics monitoring tool
GNU_CONFIGURE= yes
-USE_OPENSSL= yes
+USES= ssl
OPTIONS_DEFINE= SNMP
SNMP_LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
diff --git a/net/libarms/Makefile b/net/libarms/Makefile
index c56b15179992..d012e809648c 100644
--- a/net/libarms/Makefile
+++ b/net/libarms/Makefile
@@ -14,9 +14,8 @@ COMMENT= SMFv2/ARMS client library for C
LIB_DEPENDS= libexpat.so:textproc/expat2
GNU_CONFIGURE= yes
-USES= gmake libtool
+USES= gmake libtool ssl
USE_LDCONFIG= yes
-USE_OPENSSL= yes
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/net/libexosip2/Makefile b/net/libexosip2/Makefile
index 989516d52d5e..c978cf05f31a 100644
--- a/net/libexosip2/Makefile
+++ b/net/libexosip2/Makefile
@@ -18,9 +18,8 @@ CONFLICTS_INSTALL= libeXosip2-legacy-[0-9]*
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= libtool
+USES= libtool ssl
USE_LDCONFIG= yes
-USE_OPENSSL= yes
SHLIB_VER= 11
PLIST_SUB+= SHLIB_VER=${SHLIB_VER}
diff --git a/net/mpd5/Makefile b/net/mpd5/Makefile
index df4b971400f7..f48316eed100 100644
--- a/net/mpd5/Makefile
+++ b/net/mpd5/Makefile
@@ -17,7 +17,7 @@ NG_IPACCT_DESC= Use ng_ipacct kernel module from port
HAS_CONFIGURE= YES
CONFIGURE_WRKSRC= "${WRKSRC}/src"
-USE_OPENSSL= yes
+USES= ssl
.include <bsd.port.options.mk>
diff --git a/net/netembryo/Makefile b/net/netembryo/Makefile
index 09be5d9f7c66..db3164b7abd9 100644
--- a/net/netembryo/Makefile
+++ b/net/netembryo/Makefile
@@ -32,7 +32,7 @@ INSTALL_TARGET= install-strip
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENSSL}
-USE_OPENSSL= yes
+USES+= ssl
CONFIGURE_ENV+= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
OPENSSL_LIBS="-L${OPENSSLLIB}"
.else
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index 968c6ee37123..55cf66eac601 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -23,9 +23,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
DBDIR?= /var/db
-USES= autoreconf:build cpe gmake libtool python
+USES= autoreconf:build cpe gmake libtool python ssl
USE_GNOME= libxml2
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
PLIST_SUB= DBDIR=${DBDIR} \
diff --git a/net/openbsc/Makefile b/net/openbsc/Makefile
index a52e7067a68e..fac3927027eb 100644
--- a/net/openbsc/Makefile
+++ b/net/openbsc/Makefile
@@ -20,8 +20,7 @@ LIB_DEPENDS= libdbi.so:databases/libdbi \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${PORTNAME}
-USES= autoreconf compiler:c11 gmake pathfix pkgconfig
-USE_OPENSSL= yes
+USES= autoreconf compiler:c11 gmake pathfix pkgconfig ssl
GNU_CONFIGURE= yes
AUTOMAKE_ARGS= --gnu --add-missing --copy
CONFIGURE_ARGS+= CFLAGS="-I${LOCALBASE}/include"
diff --git a/net/openslp/Makefile b/net/openslp/Makefile
index 543ac6fa80df..ea6b75635a62 100644
--- a/net/openslp/Makefile
+++ b/net/openslp/Makefile
@@ -12,8 +12,7 @@ COMMENT= Open-source implementation of the Service Location Protocol
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= alias libtool
-USE_OPENSSL= yes
+USES= alias libtool ssl
USE_LDCONFIG= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/openslp \
--localstatedir=/var
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index a94cdbbe05e6..552e816fe4b1 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -11,9 +11,8 @@ COMMENT= Production quality, multilayer virtual switch
LICENSE= APACHE20
-USES= cpe gmake libtool perl5 pkgconfig python shebangfix
+USES= cpe gmake libtool perl5 pkgconfig python shebangfix ssl
SHEBANG_FILES= vtep/ovs-vtep
-USE_OPENSSL= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --localstatedir=/var \
diff --git a/net/p5-Socket-Class/Makefile b/net/p5-Socket-Class/Makefile
index 1bee0a81b612..66127fb5e876 100644
--- a/net/p5-Socket-Class/Makefile
+++ b/net/p5-Socket-Class/Makefile
@@ -11,8 +11,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl class to communicate with sockets
-USES= perl5
-USE_OPENSSL= yes
+USES= perl5 ssl
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/net/pipsecd/Makefile b/net/pipsecd/Makefile
index d77ccbd4a645..fc155897788b 100644
--- a/net/pipsecd/Makefile
+++ b/net/pipsecd/Makefile
@@ -12,7 +12,7 @@ DISTNAME= pipsec-19991014
MAINTAINER= cy@FreeBSD.org
COMMENT= Simple IPSEC tunnel tool from Pierre Beyssac
-USE_OPENSSL= YES
+USES+= ssl
ALL_TARGET= pipsecd
diff --git a/net/proftpd-mod_ldap/Makefile b/net/proftpd-mod_ldap/Makefile
index 77ba0f09c5ad..c681f1c4a29e 100644
--- a/net/proftpd-mod_ldap/Makefile
+++ b/net/proftpd-mod_ldap/Makefile
@@ -16,7 +16,7 @@ DESCR= ${.CURDIR}/pkg-descr
MASTERDIR= ${.CURDIR}/../../ftp/proftpd
USE_OPENLDAP= yes
-USE_OPENSSL= yes
+USES= ssl
INCLUDEDIRS= ${LOCALBASE}/include
LIBDIRS= ${LOCALBASE}/lib
diff --git a/net/qoauth/Makefile b/net/qoauth/Makefile
index 2b6fe832d394..c09a1c86879f 100644
--- a/net/qoauth/Makefile
+++ b/net/qoauth/Makefile
@@ -13,10 +13,9 @@ COMMENT= Qt 4 support for OAuth-powered network services
LIB_DEPENDS= libqca.so:devel/qca
-USES= qmake tar:bzip2
+USES= qmake tar:bzip2 ssl
USE_LDCONFIG= yes
USE_QT4= corelib qtestlib network moc_build
-USE_OPENSSL= yes
post-patch:
@${REINPLACE_CMD} -e 's,target.path}/pkgconfig,INSTALL_PREFIX}/libdata/pkgconfig,g' \
diff --git a/net/radsecproxy/Makefile b/net/radsecproxy/Makefile
index 831bb1e5e6f6..5a097d311509 100644
--- a/net/radsecproxy/Makefile
+++ b/net/radsecproxy/Makefile
@@ -12,12 +12,11 @@ COMMENT= Radsecproxy is a generic RADIUS proxy
LICENSE= GPLv2 BSD3CLAUSE
LICENSE_COMB= dual
-USES= cpe tar:xz
+USES= cpe tar:xz ssl
CPE_VENDOR= uninett
GNU_CONFIGURE= yes
USE_RC_SUBR= ${PORTNAME}
-USE_OPENSSL= yes
CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE}
post-install:
diff --git a/net/rdesktop/Makefile b/net/rdesktop/Makefile
index ca5f1340a2bd..4de668764d5f 100644
--- a/net/rdesktop/Makefile
+++ b/net/rdesktop/Makefile
@@ -12,9 +12,8 @@ COMMENT= RDP client for Windows NT/2000/2003 Terminal Server
LICENSE= GPLv3
USE_XORG= x11
-USES= gmake iconv pkgconfig
+USES= gmake iconv pkgconfig ssl
CONFIGURE_ARGS+= ${ICONV_CONFIGURE_ARG} --disable-credssp
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
DOCS= doc/AUTHORS doc/TODO doc/*.txt
diff --git a/net/relayd/Makefile b/net/relayd/Makefile
index fcd96a81556c..320b4634a330 100644
--- a/net/relayd/Makefile
+++ b/net/relayd/Makefile
@@ -12,9 +12,8 @@ LICENSE= ISCL
GH_ACCOUNT= mmatuska
-USES= uidfix
+USES= uidfix ssl
USE_GITHUB= yes
-USE_OPENSSL= yes
USE_RC_SUBR= relayd
WRKSRC_SUBDIR= src/usr.sbin
diff --git a/net/sofia-sip/Makefile b/net/sofia-sip/Makefile
index 8547d17c329e..1d2d7ed870ff 100644
--- a/net/sofia-sip/Makefile
+++ b/net/sofia-sip/Makefile
@@ -14,8 +14,7 @@ LICENSE= LGPL21
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
# Looks like GNU make(1) is needed for parallel (-jX) builds to work
-USES= gmake libtool pathfix pkgconfig
-USE_OPENSSL= yes
+USES= gmake libtool pathfix pkgconfig ssl
USE_GNOME= glib20
.include <bsd.port.mk>
diff --git a/net/ssldump/Makefile b/net/ssldump/Makefile
index 53335e3279b2..f52977d7c867 100644
--- a/net/ssldump/Makefile
+++ b/net/ssldump/Makefile
@@ -12,7 +12,7 @@ PATCH_SITES= https://gist.githubusercontent.com/mtigas/5969597/raw/e62ea9ab8a66a
MAINTAINER= arved@FreeBSD.org
COMMENT= SSLv3/TLS network protocol analyzer
-USE_OPENSSL= yes
+USES= ssl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openssl=${OPENSSLBASE} \
diff --git a/net/stone/Makefile b/net/stone/Makefile
index 72a4bbc2d663..4c1f1f3f58c7 100644
--- a/net/stone/Makefile
+++ b/net/stone/Makefile
@@ -14,12 +14,13 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}-2.3d-2.3.2.7
USE_RC_SUBR= stone
-USE_OPENSSL= yes
+.if !defined(WITHOUT_SSL)
+USES= ssl
+.endif
.include <bsd.port.pre.mk>
.if defined(WITHOUT_SSL)
-.undef USE_OPENSSL
ALL_TARGET= bsd-pop
MAKE_ARGS= POP_LIBS="-lmd" LIBS="-DUNIX_DAEMON"
post-extract:
diff --git a/net/svnup/Makefile b/net/svnup/Makefile
index df9027a88f59..b2e18165189b 100644
--- a/net/svnup/Makefile
+++ b/net/svnup/Makefile
@@ -16,8 +16,7 @@ OPTIONS_DEFINE= DOCS
CFLAGS= -I${OPENSSLINC}
LDFLAGS= -L${OPENSSLLIB} -lmd -lssl
-USES= tar:xz
-USE_OPENSSL= yes
+USES= tar:xz ssl
PORTDOCS= ChangeLog
diff --git a/net/tinyfugue/Makefile b/net/tinyfugue/Makefile
index d598b8483c09..8539cb94fa49 100644
--- a/net/tinyfugue/Makefile
+++ b/net/tinyfugue/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libpcre.so:devel/pcre
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-manpage --enable-version --enable-symlink \
--datadir=${PREFIX}/lib --with-inclibpfx=${LOCALBASE}
-USE_OPENSSL= yes
+USES= ssl
LDFLAGS+= -L${LOCALBASE}
PLIST_SUB= DISTNAME=${DISTNAME}
diff --git a/net/ulxmlrpcpp/Makefile b/net/ulxmlrpcpp/Makefile
index 3710625032d6..82075d59fe3b 100644
--- a/net/ulxmlrpcpp/Makefile
+++ b/net/ulxmlrpcpp/Makefile
@@ -15,8 +15,7 @@ LIB_DEPENDS= libexpat.so:textproc/expat2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= tar:bzip2 pathfix iconv libtool
-USE_OPENSSL= yes
+USES= tar:bzip2 pathfix iconv libtool ssl
GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_LIBS="-lpthread"
INSTALL_TARGET= install-strip
diff --git a/net/x11vnc/Makefile b/net/x11vnc/Makefile
index d126bc3c32f4..6c0119c799f4 100644
--- a/net/x11vnc/Makefile
+++ b/net/x11vnc/Makefile
@@ -19,8 +19,7 @@ USE_XORG= x11 xcb xdamage xfixes xrandr xinerama xext xtst xau xrender \
xdmcp recordproto
# Sets LDFLAGS and adds to CONFIGURE_ENV, therefore we set LDFLAGS
LDFLAGS+= -L${LOCALBASE}/lib
-USE_OPENSSL= yes
-USES= iconv pkgconfig jpeg
+USES= iconv pkgconfig jpeg ssl
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include