aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile2
-rw-r--r--net/hs-maccatcher/Makefile17
-rw-r--r--net/hs-maccatcher/distinfo2
-rw-r--r--net/hs-maccatcher/pkg-descr3
-rw-r--r--net/hs-network-conduit/Makefile4
-rw-r--r--net/hs-network-conduit/distinfo4
-rw-r--r--net/hs-publicsuffixlist/Makefile15
-rw-r--r--net/hs-publicsuffixlist/distinfo2
-rw-r--r--net/hs-publicsuffixlist/pkg-descr3
-rw-r--r--net/hs-sendfile/Makefile3
-rw-r--r--net/hs-sendfile/distinfo4
-rw-r--r--net/hs-simple-sendfile/Makefile2
-rw-r--r--net/hs-simple-sendfile/distinfo4
-rw-r--r--net/hs-socks/Makefile3
-rw-r--r--net/hs-socks/distinfo4
15 files changed, 57 insertions, 15 deletions
diff --git a/net/Makefile b/net/Makefile
index 5169ea5ec90d..6786d095d251 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -221,11 +221,13 @@
SUBDIR += hping
SUBDIR += hping-devel
SUBDIR += hs-hostname
+ SUBDIR += hs-maccatcher
SUBDIR += hs-network
SUBDIR += hs-network-conduit
SUBDIR += hs-network-info
SUBDIR += hs-network-multicast
SUBDIR += hs-pcap
+ SUBDIR += hs-publicsuffixlist
SUBDIR += hs-sendfile
SUBDIR += hs-simple-sendfile
SUBDIR += hs-socks
diff --git a/net/hs-maccatcher/Makefile b/net/hs-maccatcher/Makefile
new file mode 100644
index 000000000000..17f98d401856
--- /dev/null
+++ b/net/hs-maccatcher/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= maccatcher
+PORTVERSION= 2.1.5
+CATEGORIES= net haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Obtain the host MAC address on *NIX and Windows
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= parsec
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/net/hs-maccatcher/distinfo b/net/hs-maccatcher/distinfo
new file mode 100644
index 000000000000..600eb5dc15a3
--- /dev/null
+++ b/net/hs-maccatcher/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/maccatcher-2.1.5.tar.gz) = cbafc38151d9c4c17c3055a7f8f0702bf5d7d5240db3369c84326e94ddcaa67c
+SIZE (cabal/maccatcher-2.1.5.tar.gz) = 4947
diff --git a/net/hs-maccatcher/pkg-descr b/net/hs-maccatcher/pkg-descr
new file mode 100644
index 000000000000..fb4c6372c111
--- /dev/null
+++ b/net/hs-maccatcher/pkg-descr
@@ -0,0 +1,3 @@
+Obtain the host MAC address on *NIX and Windows.
+
+WWW: http://hackage.haskell.org/package/maccatcher
diff --git a/net/hs-network-conduit/Makefile b/net/hs-network-conduit/Makefile
index 7429be6f70d5..571fb593743c 100644
--- a/net/hs-network-conduit/Makefile
+++ b/net/hs-network-conduit/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= network-conduit
-PORTVERSION= 0.6.2.2
+PORTVERSION= 1.0.0
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
@@ -9,7 +9,7 @@ COMMENT= Stream socket data using conduits
LICENSE= BSD
-USE_CABAL= conduit>=0.5 lifted-base>=0.1 monad-control>=0.3 \
+USE_CABAL= conduit>=1.0 lifted-base>=0.1 monad-control>=0.3 \
network>=2.3 transformers>=0.2.2
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/net/hs-network-conduit/distinfo b/net/hs-network-conduit/distinfo
index b58b9cf364eb..94d0fadad127 100644
--- a/net/hs-network-conduit/distinfo
+++ b/net/hs-network-conduit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/network-conduit-0.6.2.2.tar.gz) = ac0a0019871730fc7a2719dabd9d826b2d4580ef2b433d213a199e93385c0aed
-SIZE (cabal/network-conduit-0.6.2.2.tar.gz) = 5814
+SHA256 (cabal/network-conduit-1.0.0.tar.gz) = 63de6be7775d99a56485be57af965aea957c228ea9cae8389b20d03bb9796f9a
+SIZE (cabal/network-conduit-1.0.0.tar.gz) = 5853
diff --git a/net/hs-publicsuffixlist/Makefile b/net/hs-publicsuffixlist/Makefile
new file mode 100644
index 000000000000..3c623f0f87ad
--- /dev/null
+++ b/net/hs-publicsuffixlist/Makefile
@@ -0,0 +1,15 @@
+# $FreeBSD$
+
+PORTNAME= publicsuffixlist
+PORTVERSION= 0.0.3
+CATEGORIES= net haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Is a given string a domain suffix?
+
+LICENSE= BSD
+
+USE_CABAL= cereal data-default text>=0.11 utf8-string
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/net/hs-publicsuffixlist/distinfo b/net/hs-publicsuffixlist/distinfo
new file mode 100644
index 000000000000..d043640385e9
--- /dev/null
+++ b/net/hs-publicsuffixlist/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/publicsuffixlist-0.0.3.tar.gz) = 9161ef67b0d52a590f70d5a9ff9b3fcb90cefe7b2319e07f4ec280717fa83ab7
+SIZE (cabal/publicsuffixlist-0.0.3.tar.gz) = 36122
diff --git a/net/hs-publicsuffixlist/pkg-descr b/net/hs-publicsuffixlist/pkg-descr
new file mode 100644
index 000000000000..db2bcf2ee94a
--- /dev/null
+++ b/net/hs-publicsuffixlist/pkg-descr
@@ -0,0 +1,3 @@
+Is a given string a domain suffix?
+
+WWW: https://github.com/litherum/publicsuffixlist
diff --git a/net/hs-sendfile/Makefile b/net/hs-sendfile/Makefile
index da52943ce0e3..0f00f79b652e 100644
--- a/net/hs-sendfile/Makefile
+++ b/net/hs-sendfile/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= sendfile
-PORTVERSION= 0.7.8
-PORTREVISION= 1
+PORTVERSION= 0.7.9
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-sendfile/distinfo b/net/hs-sendfile/distinfo
index 5cb44a3e7d9e..56eb2caf27af 100644
--- a/net/hs-sendfile/distinfo
+++ b/net/hs-sendfile/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/sendfile-0.7.8.tar.gz) = b47be35bd1f8f9f55fdf6df0c89c74996502091f1fe501e97a84903c6364c977
-SIZE (cabal/sendfile-0.7.8.tar.gz) = 10659
+SHA256 (cabal/sendfile-0.7.9.tar.gz) = 102fdf6db8c00f5a5981c6eed5acba1368a2d79b2970ce5b22ceb180aa0fdc42
+SIZE (cabal/sendfile-0.7.9.tar.gz) = 10656
diff --git a/net/hs-simple-sendfile/Makefile b/net/hs-simple-sendfile/Makefile
index 28be573ec3e9..adf21643a16d 100644
--- a/net/hs-simple-sendfile/Makefile
+++ b/net/hs-simple-sendfile/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= simple-sendfile
-PORTVERSION= 0.2.10
+PORTVERSION= 0.2.11
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-simple-sendfile/distinfo b/net/hs-simple-sendfile/distinfo
index be40ced2787a..74441c13ab9d 100644
--- a/net/hs-simple-sendfile/distinfo
+++ b/net/hs-simple-sendfile/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/simple-sendfile-0.2.10.tar.gz) = 55253bee2269e8f310fa95fb89881b06ae2fd8598930cd87de4279ef130a5a1e
-SIZE (cabal/simple-sendfile-0.2.10.tar.gz) = 7329
+SHA256 (cabal/simple-sendfile-0.2.11.tar.gz) = d26162f7025660e9a6cb38b866522a76444a289307381a94b1d3c9b43b4d35e1
+SIZE (cabal/simple-sendfile-0.2.11.tar.gz) = 7166
diff --git a/net/hs-socks/Makefile b/net/hs-socks/Makefile
index 7b1d48d29fde..a60bb8c9f370 100644
--- a/net/hs-socks/Makefile
+++ b/net/hs-socks/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= socks
-PORTVERSION= 0.4.2
-PORTREVISION= 1
+PORTVERSION= 0.5.0
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-socks/distinfo b/net/hs-socks/distinfo
index 235da18514f6..37bd784a1490 100644
--- a/net/hs-socks/distinfo
+++ b/net/hs-socks/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/socks-0.4.2.tar.gz) = 19711104679ab984ca66bb226e70fc9e40a602201a190a1496b3c828a5e870d9
-SIZE (cabal/socks-0.4.2.tar.gz) = 5779
+SHA256 (cabal/socks-0.5.0.tar.gz) = 47e3dd9c8d0cf6bbde2c01db428c345b70cc3e7e1ac484fef9b61855faf666d2
+SIZE (cabal/socks-0.5.0.tar.gz) = 7306