aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/ruby-drb/Makefile37
-rw-r--r--net/ruby-drb/distinfo1
-rw-r--r--net/ruby-drb/pkg-comment1
-rw-r--r--net/ruby-drb/pkg-descr5
-rw-r--r--net/ruby-drb/pkg-plist21
6 files changed, 66 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 554c2c2e2af5..e0a71cb438cd 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -217,6 +217,7 @@
SUBDIR += rshell
SUBDIR += rsync
SUBDIR += rtsp_proxy
+ SUBDIR += ruby-drb
SUBDIR += ruby-snmp
SUBDIR += ruby-uri
SUBDIR += rwhois
diff --git a/net/ruby-drb/Makefile b/net/ruby-drb/Makefile
new file mode 100644
index 000000000000..167a9093be50
--- /dev/null
+++ b/net/ruby-drb/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: Ruby-DRb
+# Date created: 9 Sep 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= drb
+PORTVERSION= 1.2.1
+CATEGORIES= net ruby
+MASTER_SITES= http://www2a.biglobe.ne.jp/~seki/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+# not mandatory, but recommended to use acl with DRb
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/acl.rb:${PORTSDIR}/security/ruby-acl
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+post-extract:
+ ${RM} ${WRKSRC}/lib/acl.rb
+
+do-install:
+ @cd ${WRKSRC}; \
+ ${RUBY} install.rb
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/drb
+ ${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}/drb
+.endif
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.ruby.mk"
+.include <bsd.port.post.mk>
diff --git a/net/ruby-drb/distinfo b/net/ruby-drb/distinfo
new file mode 100644
index 000000000000..5bc7b5e22b7f
--- /dev/null
+++ b/net/ruby-drb/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/drb-1.2.1.tar.gz) = e8f78a6f78568fa6e4fac1a9ca28d65a
diff --git a/net/ruby-drb/pkg-comment b/net/ruby-drb/pkg-comment
new file mode 100644
index 000000000000..b024f22e5e2c
--- /dev/null
+++ b/net/ruby-drb/pkg-comment
@@ -0,0 +1 @@
+Distributed Ruby
diff --git a/net/ruby-drb/pkg-descr b/net/ruby-drb/pkg-descr
new file mode 100644
index 000000000000..e8c7a6d6955a
--- /dev/null
+++ b/net/ruby-drb/pkg-descr
@@ -0,0 +1,5 @@
+druby (DRb) - distributed ruby.
+DRb can be used to exchange messages among Ruby scripts.
+
+Author: Masatoshi SEKI <m_seki@mva.biglobe.ne.jp>
+WWW: http://www.ruby-lang.org/en/raa-list.rhtml?name=druby+-+distributed+ruby
diff --git a/net/ruby-drb/pkg-plist b/net/ruby-drb/pkg-plist
new file mode 100644
index 000000000000..857454bbdad7
--- /dev/null
+++ b/net/ruby-drb/pkg-plist
@@ -0,0 +1,21 @@
+%%RUBY_SITELIBDIR%%/drb.rb
+%%RUBY_SITELIBDIR%%/drb/drb.rb
+@dirrm %%RUBY_SITELIBDIR%%/drb
+%%RUBY_EXAMPLESDIR%%/drb/darray.rb
+%%RUBY_EXAMPLESDIR%%/drb/darrayc.rb
+%%RUBY_EXAMPLESDIR%%/drb/dchatc.rb
+%%RUBY_EXAMPLESDIR%%/drb/dchats.rb
+%%RUBY_EXAMPLESDIR%%/drb/dhasen.rb
+%%RUBY_EXAMPLESDIR%%/drb/dhasenc.rb
+%%RUBY_EXAMPLESDIR%%/drb/dlogc.rb
+%%RUBY_EXAMPLESDIR%%/drb/dlogd.rb
+%%RUBY_EXAMPLESDIR%%/drb/dqin.rb
+%%RUBY_EXAMPLESDIR%%/drb/dqout.rb
+%%RUBY_EXAMPLESDIR%%/drb/dqueue.rb
+%%RUBY_EXAMPLESDIR%%/drb/drbc.rb
+%%RUBY_EXAMPLESDIR%%/drb/drbs-acl.rb
+%%RUBY_EXAMPLESDIR%%/drb/drbs.rb
+%%RUBY_EXAMPLESDIR%%/drb/name.rb
+%%RUBY_EXAMPLESDIR%%/drb/namec.rb
+%%RUBY_EXAMPLESDIR%%/drb/rinda.rb
+@dirrm %%RUBY_EXAMPLESDIR%%/drb