aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Whois-RIPE/Makefile26
-rw-r--r--net/p5-Net-Whois-RIPE/distinfo1
-rw-r--r--net/p5-Net-Whois-RIPE/pkg-comment1
-rw-r--r--net/p5-Net-Whois-RIPE/pkg-descr3
-rw-r--r--net/p5-Net-Whois-RIPE/pkg-plist15
6 files changed, 47 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 22201d70584c..ddecf5d49d4e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -382,6 +382,7 @@
SUBDIR += p5-Net-Traceroute6
SUBDIR += p5-Net-Wake
SUBDIR += p5-Net-Whois
+ SUBDIR += p5-Net-Whois-RIPE
SUBDIR += p5-Net-Whois-Raw
SUBDIR += p5-Net-XWhois
SUBDIR += p5-Net-Z3950
diff --git a/net/p5-Net-Whois-RIPE/Makefile b/net/p5-Net-Whois-RIPE/Makefile
new file mode 100644
index 000000000000..a457e2632aa5
--- /dev/null
+++ b/net/p5-Net-Whois-RIPE/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: p5-Net-Whois-RIPE
+# Date created: Sep 11, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Whois-RIPE
+PORTVERSION= 1.19
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ${PORTNAME:L} Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Net::Whois::RIPE::Iterator.3 \
+ Net::Whois::RIPE::Object.3 \
+ Net::Whois::RIPE.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Whois-RIPE/distinfo b/net/p5-Net-Whois-RIPE/distinfo
new file mode 100644
index 000000000000..93f1c7caa085
--- /dev/null
+++ b/net/p5-Net-Whois-RIPE/distinfo
@@ -0,0 +1 @@
+MD5 (Net-Whois-RIPE-1.19.tar.gz) = 69020ae7f50b096df01fc6ea8a20456d
diff --git a/net/p5-Net-Whois-RIPE/pkg-comment b/net/p5-Net-Whois-RIPE/pkg-comment
new file mode 100644
index 000000000000..4218af56ca3c
--- /dev/null
+++ b/net/p5-Net-Whois-RIPE/pkg-comment
@@ -0,0 +1 @@
+Implementation of RIPE Whois
diff --git a/net/p5-Net-Whois-RIPE/pkg-descr b/net/p5-Net-Whois-RIPE/pkg-descr
new file mode 100644
index 000000000000..7cab7f1eadca
--- /dev/null
+++ b/net/p5-Net-Whois-RIPE/pkg-descr
@@ -0,0 +1,3 @@
+This is an object-orienated perl module that provides methods to query,
+retrieve and update RIPE-157 formated objects, from whois servers that
+support this format.
diff --git a/net/p5-Net-Whois-RIPE/pkg-plist b/net/p5-Net-Whois-RIPE/pkg-plist
new file mode 100644
index 000000000000..76fc74303a2c
--- /dev/null
+++ b/net/p5-Net-Whois-RIPE/pkg-plist
@@ -0,0 +1,15 @@
+lib/perl5/site_perl/%%PERL_VER%%/Net/Whois/RIPE.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Whois/RIPE.pod
+lib/perl5/site_perl/%%PERL_VER%%/Net/Whois/RIPE/Iterator.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Whois/RIPE/Iterator.pod
+lib/perl5/site_perl/%%PERL_VER%%/Net/Whois/RIPE/Object.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Whois/RIPE/Object.pod
+lib/perl5/site_perl/%%PERL_VER%%/Net/Whois/RIPE/Object/Template.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Net/Whois/RIPE/Object
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Net/Whois/RIPE
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net/Whois 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2>/dev/null || true
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Whois/RIPE/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Whois/RIPE
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Whois 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true