aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/sendfile/Makefile8
-rw-r--r--net/socks5/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/net/sendfile/Makefile b/net/sendfile/Makefile
index f878dda865b3..a26fb9bcbe07 100644
--- a/net/sendfile/Makefile
+++ b/net/sendfile/Makefile
@@ -36,4 +36,10 @@ post-install:
${CP} -p ${PREFIX}/etc/sendfile.deny.sample ${PREFIX}/etc/sendfile.deny ; \
fi
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/socks5/Makefile b/net/socks5/Makefile
index e6c1550cc99e..1fb5bfa89149 100644
--- a/net/socks5/Makefile
+++ b/net/socks5/Makefile
@@ -44,6 +44,12 @@ MAN1= runsocks.1 socks5.1 stopsocks.1 socks5_clients.1
MAN5= libsocks5.conf.5 socks5.conf.5 socks5.passwd.5
CONFIGURE_ENV= LIBS=-lcrypt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}
@@ -52,4 +58,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>