aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/vyqchat/Makefile2
-rw-r--r--net/vyqchat/files/patch-src-sound.cpp10
2 files changed, 11 insertions, 1 deletions
diff --git a/net/vyqchat/Makefile b/net/vyqchat/Makefile
index 700f45d937cc..fc0e230506aa 100644
--- a/net/vyqchat/Makefile
+++ b/net/vyqchat/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vyqchat
PORTVERSION= 0.2.8
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net
MASTER_SITES= http://linux.bydg.org/~yogin/
diff --git a/net/vyqchat/files/patch-src-sound.cpp b/net/vyqchat/files/patch-src-sound.cpp
new file mode 100644
index 000000000000..9119cf1d8d3a
--- /dev/null
+++ b/net/vyqchat/files/patch-src-sound.cpp
@@ -0,0 +1,10 @@
+--- src/sound.cpp.orig 2010-06-06 16:28:57.000000000 +0200
++++ src/sound.cpp 2010-06-06 16:29:34.000000000 +0200
+@@ -173,6 +173,7 @@ void SoundLibAo::play(VyEvent evt)/*{{{*
+ {
+ ao_sample_format frmt;
+
++ memset(&frmt, 0, sizeof(frmt));
+ frmt.bits = sizeof(short) << 3;
+ frmt.channels = sfinf[evt].channels;
+ frmt.rate = sfinf[evt].samplerate;