aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/gupnp-igd/Makefile5
-rw-r--r--net/libevnet/files/patch-gmake38230
2 files changed, 35 insertions, 0 deletions
diff --git a/net/gupnp-igd/Makefile b/net/gupnp-igd/Makefile
index 9c963473f136..eb15382e8286 100644
--- a/net/gupnp-igd/Makefile
+++ b/net/gupnp-igd/Makefile
@@ -23,4 +23,9 @@ USE_GNOME= gnomehack intlhack libglade2 glib20
USE_LDCONFIG= yes
USE_PYTHON= yes
+# For gmake >= 3.82 -- no idea where this line comes from, patching
+# the Makefile.in seems to have no effect
+post-configure:
+ @${REINPLACE_CMD} -e 's|^\[|# \[|' ${WRKSRC}/python/Makefile
+
.include <bsd.port.mk>
diff --git a/net/libevnet/files/patch-gmake382 b/net/libevnet/files/patch-gmake382
new file mode 100644
index 000000000000..4777ceb12c19
--- /dev/null
+++ b/net/libevnet/files/patch-gmake382
@@ -0,0 +1,30 @@
+--- mk/Epilogue.mk.orig 2009-11-28 23:02:27.000000000 -0600
++++ mk/Epilogue.mk 2011-03-25 15:05:17.000000000 -0500
+@@ -4,6 +4,6 @@
+ #
+-d := $(dirstack_$(sp))
++d:= $(dirstack_$(sp))
+
+-sp ?= $(shell basename "$(sp)")
+-sp != basename "$(sp)"
++sp?= $(shell basename "$(sp)")
++sp!= basename "$(sp)"
+
+--- mk/Prologue.mk.orig 2011-03-25 15:05:05.000000000 -0500
++++ mk/Prologue.mk 2011-03-25 15:05:34.000000000 -0500
+@@ -4,5 +4,5 @@
+ #
+-sp := $(sp).x
+-dirstack_$(sp) := $(d)
+-d := $(dir)
++sp:= $(sp).x
++dirstack_$(sp):= $(d)
++d:= $(dir)
+
+@@ -10,4 +10,4 @@
+ # Our parent directory
+-$(d)/.. ?= $(shell dirname "$(d)")
+-$(d)/.. != dirname "$(d)"
++$(d)/..?= $(shell dirname "$(d)")
++$(d)/..!= dirname "$(d)"
+