aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/pear-Net_NNTP/Makefile19
-rw-r--r--net/pear-Net_NNTP/distinfo2
-rw-r--r--net/pear-Net_NNTP/pkg-plist12
3 files changed, 22 insertions, 11 deletions
diff --git a/net/pear-Net_NNTP/Makefile b/net/pear-Net_NNTP/Makefile
index ad8347912e9a..93562c5b07fd 100644
--- a/net/pear-Net_NNTP/Makefile
+++ b/net/pear-Net_NNTP/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Net_NNTP
-PORTVERSION= 0.10.0
+PORTVERSION= 0.10.1
CATEGORIES= net news www pear
MAINTAINER= sheepkiller@cultdeadsheep.org
@@ -18,7 +18,14 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
-LIB_FILES= NNTP/Protocol.php NNTP/Header.php NNTP/Message.php
+LIB_FILES= NNTP/Realtime.php NNTP/Protocol.php NNTP/Header.php NNTP/Message.php
+PORTDOCS= README
+
+.if defined(NOPORTEXAMPLES)
+PLIST_SUB+= PORTEXAMPLES="@comment "
+.else
+PLIST_SUB+= PORTEXAMPLES=""
+.endif
do-install:
@${MKDIR} ${PEARDIR}/Net/NNTP
@@ -27,9 +34,13 @@ do-install:
@${CP} -p ${WRKSRC}/${FILE} ${PEARDIR}/Net/NNTP
.endfor
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Net
-.if !(NOPORTDOCS)
+.if !(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/examples/news.php.net/* ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/examples/news.php.net/*.php ${EXAMPLESDIR}
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/examples/news.php.net/${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/net/pear-Net_NNTP/distinfo b/net/pear-Net_NNTP/distinfo
index 3aa53b5a204d..24462b57af20 100644
--- a/net/pear-Net_NNTP/distinfo
+++ b/net/pear-Net_NNTP/distinfo
@@ -1 +1 @@
-MD5 (PEAR/Net_NNTP-0.10.0.tgz) = 4ab0cf46f366086ec161f97d5f4eb6c1
+MD5 (PEAR/Net_NNTP-0.10.1.tgz) = 495b9bb0218c9d43d291f0cec7b5dd87
diff --git a/net/pear-Net_NNTP/pkg-plist b/net/pear-Net_NNTP/pkg-plist
index 2c50e63cfdbe..50300031992e 100644
--- a/net/pear-Net_NNTP/pkg-plist
+++ b/net/pear-Net_NNTP/pkg-plist
@@ -1,13 +1,13 @@
%%PEARDIR%%/Net/NNTP.php
-%%PEARDIR%%/Net/NNTP/Protocol.php
%%PEARDIR%%/Net/NNTP/Header.php
%%PEARDIR%%/Net/NNTP/Message.php
+%%PEARDIR%%/Net/NNTP/Protocol.php
+%%PEARDIR%%/Net/NNTP/Realtime.php
%%PKGREGDIR%%/package.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/README
-%%PORTDOCS%%%%EXAMPLESDIR%%/read.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/group.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/index.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/read.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/group.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/index.php
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrm %%PEARDIR%%/Net/NNTP
@dirrm %%PKGREGDIR%%
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
@unexec rmdir %D/share/pear/Net 2> /dev/null || true